aboutsummaryrefslogtreecommitdiffstats
path: root/games/spring
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-07-12 23:01:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-07-12 23:01:45 +0800
commit816503d0c5051e291b1c9d153597bec2c0d90e3e (patch)
tree713942325bda393305edb21d46cd7f38d213aebc /games/spring
parent422d267e1126322ee1278071a404f04be2383f95 (diff)
downloadfreebsd-ports-graphics-816503d0c5051e291b1c9d153597bec2c0d90e3e.tar.gz
freebsd-ports-graphics-816503d0c5051e291b1c9d153597bec2c0d90e3e.tar.zst
freebsd-ports-graphics-816503d0c5051e291b1c9d153597bec2c0d90e3e.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful - Canonicalize patch names - Fix DOS line endings in patch files
Diffstat (limited to 'games/spring')
-rw-r--r--games/spring/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 6d327230389..41a41bff3aa 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -13,12 +13,12 @@ COMMENT= A project aiming to create a new and versatile RTS Engine
BROKEN= Does not build with recent boost
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- boost_thread.4:${PORTSDIR}/devel/boost-libs \
- IL.2:${PORTSDIR}/graphics/devil \
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ IL:${PORTSDIR}/graphics/devil \
ogg:${PORTSDIR}/audio/libogg \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- execinfo.1:${PORTSDIR}/devel/libexecinfo
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ execinfo:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
ONLY_FOR_ARCHS= i386 amd64
@@ -66,7 +66,7 @@ post-patch:
${WRKSRC}/rts/System/Platform/Misc.cpp
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "userdocs DevGuide.html HowTo* \
SelectionKeys.txt StartScriptFormat.txt changelog.txt" ${DOCSDIR}/