aboutsummaryrefslogtreecommitdiffstats
path: root/games/sudoku
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-13 02:41:38 +0800
committerpawel <pawel@FreeBSD.org>2014-04-13 02:41:38 +0800
commit9720ee8cbb403812a57c44b697b65b640fa84d40 (patch)
tree263cea9ef66b3d627c2dff5a63de25f7437f2837 /games/sudoku
parentede0480e409ebddd198bad8efaa3f2fd19ebddcb (diff)
downloadfreebsd-ports-graphics-9720ee8cbb403812a57c44b697b65b640fa84d40.tar.gz
freebsd-ports-graphics-9720ee8cbb403812a57c44b697b65b640fa84d40.tar.zst
freebsd-ports-graphics-9720ee8cbb403812a57c44b697b65b640fa84d40.zip
- Add staging support
- Convert to USES=tar:bzip2 - Unmute build/install commands
Diffstat (limited to 'games/sudoku')
-rw-r--r--games/sudoku/Makefile31
1 files changed, 10 insertions, 21 deletions
diff --git a/games/sudoku/Makefile b/games/sudoku/Makefile
index e4230b1e5f4..acc9bf716fd 100644
--- a/games/sudoku/Makefile
+++ b/games/sudoku/Makefile
@@ -10,39 +10,28 @@ EXTRACT_SUFX= .tbz
MAINTAINER= ports@FreeBSD.org
COMMENT= Console based Sudoku games
-USE_BZIP2= yes
-USES= ncurses
+USES= ncurses tar:bzip2
PLIST_FILES= bin/sudoku \
+ man/man6/sudoku.6.gz \
share/sudoku/template
PLIST_DIRS= share/sudoku
-
-MAN6= sudoku.6
-
-NO_STAGE= yes
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
-
post-patch:
@${GREP} -lR "/usr/lib/sudoku" ${WRKSRC} | ${XARGS} \
${REINPLACE_CMD} -e "s,/usr/lib/sudoku,${DATADIR},"
do-build:
- @cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} sudoku.c -lcurses
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} sudoku.c -lcurses
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/template ${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/sudoku.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sudoku.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/template ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sudoku.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
e74289962f7bde8f57d9a999e61b74241ad6b'>Convert a bunch of USE_BZIP2 to USES=tar:bzip2adamw2014-07-301-2/+1 * Reset maintainership for ports not staged with no pending PRbapt2014-07-241-1/+1 * Modernize LIB_DEPENDSbapt2014-07-141-1/+1 * The FreeBSD x11@ and graphics team proudly presentszeising2014-04-171-2/+2 * Convert the tree to USES=openalantoine2013-12-261-2/+1 * Update freetype to 2.5.2.kwm2013-12-251-0/+14 * Use setuptools for all Python ports.wg2013-12-161-1/+3 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-5/+2 * - Update devel/sdl12 to 1.2.15mva2012-02-181-1/+1 * -remove MD5ohauer2011-07-031-2/+0 * - Add glew to the list of supported USE_GL variablesgahr2010-04-281-2/+1 * - update to jpeg-8dinoex2010-02-051-1/+1 * - Introduce USE_OPENAL variable for OpenAL consumerspav2010-01-261-3/+2 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-1/+1 * - Fix an issue in my previous commitacm2009-06-181-1/+1 * - Fix with custom LOCALBASEacm2009-06-181-1/+3 * - Use correctly NOPORTDOCS and NOPORTEXAMPLESacm2009-04-292-369/+373 * Bump PORTREVISION for DEPENDS change.itetcu2009-04-291-0/+1 * - Add sdl dependencyacm2009-04-271-0/+1 * - Update to 0.14acm2009-04-274-38/+75 * - Bump PORTREVISION, because devel/ode was updatedacm2009-01-161-1/+1 * CATEGORIES+= python for py- ports missing itpgollucci2008-12-281-1/+1 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-201-2/+2 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-221-2/+1 * - Fix problem with new version of pyrex. It is not necessary as a dependency.acm2007-11-082-7/+26 * Mark as broken with current version of devel/pyrex. A new version oflinimon2007-10-261-0/+2 * - Update to 0.13.2acm2007-08-206-133/+224 * - Make Python 2.5.1 the default Python versionalexbl2007-07-301-0/+2 * - Welcome X.org 7.2 \o/.flz2007-05-201-1/+1 * - Really respect X11BASErafan2006-12-091-2/+2 * - Respect X11BASEacm2006-12-011-0/+1 * - Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directorystas2006-09-202-19/+0 * - Fix build with recent graphics/cal3dacm2006-08-222-29/+17 * - Fix problem on 4.xacm2006-08-081-1/+1 * - Update to 0.12acm2006-07-307-99/+103 * Change maintainer address to my @FreeBSD.org emailacm2006-07-231-1/+1 * - Update Soya3d to 0.11.2erwin2006-06-164-125/+81 * Update to 0.10.5erwin2006-05-193-16/+4 * Unbreak on i386arved2006-05-182-3/+9 * Update to 0.10.4arved2006-05-084-14/+65 * Update to 0.10.2arved2006-04-163-127/+172 * SHA256ifyedwin2006-01-22