aboutsummaryrefslogtreecommitdiffstats
path: root/games/xevil/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-04 02:59:15 +0800
committerkrion <krion@FreeBSD.org>2003-11-04 02:59:15 +0800
commit988d23bfeaa6dc26ccc5d57fc573e5973e0f86fe (patch)
tree79b0b982d17c2952b260758f237e55983eb5336d /games/xevil/Makefile
parent444fe828506f78b8ed9043a08a0ce1f7fc82fee0 (diff)
downloadfreebsd-ports-graphics-988d23bfeaa6dc26ccc5d57fc573e5973e0f86fe.tar.gz
freebsd-ports-graphics-988d23bfeaa6dc26ccc5d57fc573e5973e0f86fe.tar.zst
freebsd-ports-graphics-988d23bfeaa6dc26ccc5d57fc573e5973e0f86fe.zip
- Fix build on -current
PR: 58876 Submitted by: Ports Fury
Diffstat (limited to 'games/xevil/Makefile')
-rw-r--r--games/xevil/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/games/xevil/Makefile b/games/xevil/Makefile
index 3b51a50bf7a..06ea81e9d35 100644
--- a/games/xevil/Makefile
+++ b/games/xevil/Makefile
@@ -17,6 +17,9 @@ COMMENT= A fast-action, networked, anti-social, kill-everything game
USE_X_PREFIX= yes
USE_ZIP= yes
USE_XPM= yes
+USE_REINPLACE= yes
+MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+MAKEFILE= makefile
ALL_TARGET= freebsd
.include <bsd.port.pre.mk>
@@ -26,26 +29,19 @@ ALL_TARGET= freebsd
CFLAGS+="-DXEVIL_KEYSET=UIalpha"
.endif
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
do-extract:
@unzip -aqo ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
-post-extract:
- @${MV} -f ${WRKDIR}/${DISTNAME}/makefile ${WRKDIR}/${DISTNAME}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/x11/FREEBSD/xevil ${PREFIX}/bin/xevil
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/xevil/instructions
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/xevil
- ${INSTALL_DATA} ${WRKSRC}/instructions/* \
- ${PREFIX}/share/doc/xevil/instructions
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/instructions
+ ${INSTALL_DATA} ${WRKSRC}/instructions/* ${DOCSDIR}/instructions
.endif
.include <bsd.port.post.mk>