aboutsummaryrefslogtreecommitdiffstats
path: root/games/xmoto
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-08 05:07:54 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-08 05:07:54 +0800
commit4edb4cc004c516183e00287eed04c570a06a0f0f (patch)
tree68d5bb2671e176ef2e69847d2159058aa649a6c9 /games/xmoto
parent98b24c3c40fff0cfdb030bec55691ef3d029fe09 (diff)
downloadfreebsd-ports-graphics-4edb4cc004c516183e00287eed04c570a06a0f0f.tar.gz
freebsd-ports-graphics-4edb4cc004c516183e00287eed04c570a06a0f0f.tar.zst
freebsd-ports-graphics-4edb4cc004c516183e00287eed04c570a06a0f0f.zip
- Convert USE_DOS2UNIX to USES
- Use new OPTIONS features
Diffstat (limited to 'games/xmoto')
-rw-r--r--games/xmoto/Makefile35
1 files changed, 12 insertions, 23 deletions
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 4ba3a3daf1b..d07ea54ce08 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -21,13 +21,13 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libode.a:${PORTSDIR}/devel/ode
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake dos2unix
USE_GNOME= libxml2
USE_LUA= 5.1
USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
-USE_DOS2UNIX= src/*.cpp src/*.h
+DOS2UNIX_GLOB= *.cpp *.h
CPPFLAGS+= -I${LOCALBASE}/include -I${LUA_INCDIR}
LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
@@ -38,8 +38,17 @@ PORTDOCS= README ChangeLog
PORTDATA= *
OPTIONS_DEFINE= ASIAN_TTF DOCS NLS
+OPTIONS_SUB= yes
+
ASIAN_TTF_DESC= Use asian TTF font
+ASIAN_TTF_RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
+ASIAN_TTF_CONFIGURE_ON= --with-asian-ttf-file=${LOCALBASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf
+ASIAN_TTF_CONFIGURE_OFF=--without-asian-ttf-file
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
DESKTOP_ENTRIES="XMoto" \
"Motorcross game" \
"${DATADIR}/xmoto_icone_x.ico" \
@@ -47,30 +56,10 @@ DESKTOP_ENTRIES="XMoto" \
"Game;SportsGame;ArcadeGame;" \
false
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASIAN_TTF}
-RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
-CONFIGURE_ARGS+=--with-asian-ttf-file=${LOCALBASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf
-.else
-CONFIGURE_ARGS+=--without-asian-ttf-file
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CONFIGURE_ENV+= LIBS="-lintl"
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
.include <bsd.port.mk>