aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-10-26 02:31:54 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-10-26 02:31:54 +0800
commit0005b722b1ad39c92abfe8ab925cd8abbf1ffef8 (patch)
tree3073f53316ad10d8fd7c4fa612672059abeb2f49 /games
parent3b212f581c156f53a7533acb9fb3854dd83aa57d (diff)
downloadfreebsd-ports-graphics-0005b722b1ad39c92abfe8ab925cd8abbf1ffef8.tar.gz
freebsd-ports-graphics-0005b722b1ad39c92abfe8ab925cd8abbf1ffef8.tar.zst
freebsd-ports-graphics-0005b722b1ad39c92abfe8ab925cd8abbf1ffef8.zip
The GNUbik program is an interactive, graphical, single player
puzzle. Yes, this is another implementation of the classic game like that invented by Erno Rubik. You have to manipulate the cube using the mouse. When each face shows only one colour, the game is solved. WWW: https://www.gnu.org/software/gnubik/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/gnubik/Makefile39
-rw-r--r--games/gnubik/distinfo3
-rw-r--r--games/gnubik/files/patch-src_guile-hooks.c14
-rw-r--r--games/gnubik/pkg-descr7
-rw-r--r--games/gnubik/pkg-plist38
6 files changed, 102 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 25c0b328d26..752bb28b5ce 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -355,6 +355,7 @@
SUBDIR += gnomekiss
SUBDIR += gnono
SUBDIR += gnubg
+ SUBDIR += gnubik
SUBDIR += gnuchess
SUBDIR += gnudoku
SUBDIR += gnugo
diff --git a/games/gnubik/Makefile b/games/gnubik/Makefile
new file mode 100644
index 00000000000..da560427868
--- /dev/null
+++ b/games/gnubik/Makefile
@@ -0,0 +1,39 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gnubik
+PORTVERSION= 2.4.1
+CATEGORIES= games
+MASTER_SITES= GNU
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= 3D Rubik's cube game
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libguile.so:lang/guile \
+ libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
+
+GNU_CONFIGURE= yes
+USES= gettext gmake localbase pkgconfig
+USE_GNOME= gtk20
+USE_GL= gl glu
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+INFO= gnubik
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/24x24/apps
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/24x24
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/gnubik/distinfo b/games/gnubik/distinfo
new file mode 100644
index 00000000000..ed1fb8f7aba
--- /dev/null
+++ b/games/gnubik/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477328506
+SHA256 (gnubik-2.4.1.tar.gz) = a59e7858c39fdd10aa4863cf00e2d98eb4130bbb543f2ce2bf38c440c6e7d755
+SIZE (gnubik-2.4.1.tar.gz) = 412615
diff --git a/games/gnubik/files/patch-src_guile-hooks.c b/games/gnubik/files/patch-src_guile-hooks.c
new file mode 100644
index 00000000000..6101ddb8021
--- /dev/null
+++ b/games/gnubik/files/patch-src_guile-hooks.c
@@ -0,0 +1,14 @@
+--- src/guile-hooks.c.orig 2012-01-07 17:29:10 UTC
++++ src/guile-hooks.c
+@@ -202,9 +202,9 @@ read_script_directory (const char *dir_n
+
+ scm_primitive_load (scm_from_locale_string (buffer));
+ }
+- }
+
+- closedir (directory);
++ closedir (directory);
++ }
+ }
+
+
diff --git a/games/gnubik/pkg-descr b/games/gnubik/pkg-descr
new file mode 100644
index 00000000000..22ae221de64
--- /dev/null
+++ b/games/gnubik/pkg-descr
@@ -0,0 +1,7 @@
+The GNUbik program is an interactive, graphical, single player
+puzzle. Yes, this is another implementation of the classic game
+like that invented by Erno Rubik. You have to manipulate the cube
+using the mouse. When each face shows only one colour, the game is
+solved.
+
+WWW: https://www.gnu.org/software/gnubik/
diff --git a/games/gnubik/pkg-plist b/games/gnubik/pkg-plist
new file mode 100644
index 00000000000..cfb93f82fce
--- /dev/null
+++ b/games/gnubik/pkg-plist
@@ -0,0 +1,38 @@
+bin/gnubik
+share/applications/gnubik.desktop
+%%DATADIR%%/scripts/debug.scm
+%%DATADIR%%/scripts/flubrd.scm
+%%DATADIR%%/scripts/mellor-solve.scm
+%%DATADIR%%/scripts/rand.scm
+share/icons/hicolor/16x16/apps/gnubik.png
+share/icons/hicolor/22x22/apps/gnubik.png
+share/icons/hicolor/32x32/apps/gnubik.png
+share/icons/hicolor/48x48/apps/gnubik.png
+share/locale/bg/LC_MESSAGES/gnubik.mo
+share/locale/ca/LC_MESSAGES/gnubik.mo
+share/locale/da/LC_MESSAGES/gnubik.mo
+share/locale/de/LC_MESSAGES/gnubik.mo
+share/locale/el/LC_MESSAGES/gnubik.mo
+share/locale/en_US/LC_MESSAGES/gnubik.mo
+share/locale/eo/LC_MESSAGES/gnubik.mo
+share/locale/es/LC_MESSAGES/gnubik.mo
+share/locale/eu/LC_MESSAGES/gnubik.mo
+share/locale/fi/LC_MESSAGES/gnubik.mo
+share/locale/fr/LC_MESSAGES/gnubik.mo
+share/locale/he/LC_MESSAGES/gnubik.mo
+share/locale/hr/LC_MESSAGES/gnubik.mo
+share/locale/it/LC_MESSAGES/gnubik.mo
+share/locale/ms/LC_MESSAGES/gnubik.mo
+share/locale/nb/LC_MESSAGES/gnubik.mo
+share/locale/nl/LC_MESSAGES/gnubik.mo
+share/locale/pl/LC_MESSAGES/gnubik.mo
+share/locale/pt/LC_MESSAGES/gnubik.mo
+share/locale/pt_BR/LC_MESSAGES/gnubik.mo
+share/locale/ro/LC_MESSAGES/gnubik.mo
+share/locale/ru/LC_MESSAGES/gnubik.mo
+share/locale/sl/LC_MESSAGES/gnubik.mo
+share/locale/sr/LC_MESSAGES/gnubik.mo
+share/locale/sv/LC_MESSAGES/gnubik.mo
+share/locale/tr/LC_MESSAGES/gnubik.mo
+share/locale/uk/LC_MESSAGES/gnubik.mo
+share/locale/zh_CN/LC_MESSAGES/gnubik.mo