aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-17 20:15:00 +0800
committerpav <pav@FreeBSD.org>2004-07-17 20:15:00 +0800
commit05a0590a4526889197b0ea6cfb15f4fb3544d32a (patch)
treea16212d0c21b0f41f177099bf1fba2d6b9960dc1 /games
parentb44d161c0786583237da6f1b7806d4d88b63f5cd (diff)
downloadfreebsd-ports-graphics-05a0590a4526889197b0ea6cfb15f4fb3544d32a.tar.gz
freebsd-ports-graphics-05a0590a4526889197b0ea6cfb15f4fb3544d32a.tar.zst
freebsd-ports-graphics-05a0590a4526889197b0ea6cfb15f4fb3544d32a.zip
- Update to 1.4.2
Diffstat (limited to 'games')
-rw-r--r--games/bygfoot/Makefile2
-rw-r--r--games/bygfoot/distinfo4
-rw-r--r--games/bygfoot/files/patch-src-games.c42
3 files changed, 45 insertions, 3 deletions
diff --git a/games/bygfoot/Makefile b/games/bygfoot/Makefile
index 61298574626..69d8da20747 100644
--- a/games/bygfoot/Makefile
+++ b/games/bygfoot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bygfoot
-PORTVERSION= 1.4.1
+PORTVERSION= 1.4.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/games/bygfoot/distinfo b/games/bygfoot/distinfo
index 849d0f01e36..9e47dff2341 100644
--- a/games/bygfoot/distinfo
+++ b/games/bygfoot/distinfo
@@ -1,2 +1,2 @@
-MD5 (bygfoot-1.4.1.tar.bz2) = 0cfed4affc9ad3865b4a449c591582d8
-SIZE (bygfoot-1.4.1.tar.bz2) = 248727
+MD5 (bygfoot-1.4.2.tar.bz2) = 7eb56353a62500d7d08c207682e4e27c
+SIZE (bygfoot-1.4.2.tar.bz2) = 248654
diff --git a/games/bygfoot/files/patch-src-games.c b/games/bygfoot/files/patch-src-games.c
new file mode 100644
index 00000000000..25773c0931c
--- /dev/null
+++ b/games/bygfoot/files/patch-src-games.c
@@ -0,0 +1,42 @@
+--- src/games.c.orig Mon Jul 12 10:33:02 2004
++++ src/games.c Sat Jul 17 14:05:39 2004
+@@ -436,9 +436,6 @@
+ gint i;
+ gfloat random = rnd(0,1);
+
+- if(debug && fix.team_id[team] == my_team)
+- return;
+-
+ player *pl =
+ &(teams[fix.team_id[team]].players[player_number]);
+
+@@ -454,6 +451,9 @@
+ in weeks: 1,2,3,4 or 5 */
+ gfloat duration[6]={0,0.7,0.85,0.95,0.975,1};
+
++ if(debug && fix.team_id[team] == my_team)
++ return;
++
+ /* injured or banned players don't really participate
+ in the game */
+ if(!pl->cskill ||
+@@ -496,9 +496,6 @@
+ gint i;
+ gfloat random = rnd(0,1);
+
+- if(debug && fix.team_id[team] == my_team)
+- return;
+-
+ /* for convenience, so as not to write
+ teams[fix.team_id[team]].players[player_number]
+ each time */
+@@ -538,6 +535,9 @@
+ {4,12},{5,12},{6,16},{3,8},
+ {5,14},{12,30}};
+
++ if(debug && fix.team_id[team] == my_team)
++ return;
++
+ for(i=1;i<12;i++)
+ if(injury_probs[i - 1] * prob < random &&
+ random <= injury_probs[i] * prob &&