aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-01-02 07:25:37 +0800
committermadpilot <madpilot@FreeBSD.org>2013-01-02 07:25:37 +0800
commit0d8f215161b3f94369ca800fa2052fecb6ca4156 (patch)
treeceae07e99bed8478f2d25d653cf563874458e58a /games
parent437c82cb4afb4b813788436ddd69770744f25b67 (diff)
downloadfreebsd-ports-graphics-0d8f215161b3f94369ca800fa2052fecb6ca4156.tar.gz
freebsd-ports-graphics-0d8f215161b3f94369ca800fa2052fecb6ca4156.tar.zst
freebsd-ports-graphics-0d8f215161b3f94369ca800fa2052fecb6ca4156.zip
- Modify clang 3.2 fix to be the same as committed to the project's
repository. - Bump PORTREVISION Obtained from: http://trac.wildfiregames.com/changeset/13031#file10
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile1
-rw-r--r--games/0ad/files/patch-source-lib-debug.cpp11
-rw-r--r--games/0ad/files/patch-source-lib-debug.h6
3 files changed, 4 insertions, 14 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index b654217ddbe..8e9a3700929 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= 0ad
PORTVERSION= 0.0.12
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/zero-ad/releases
DISTFILES= ${PORTNAME}-${PORTVERSION}-alpha-unix-build.tar.xz \
diff --git a/games/0ad/files/patch-source-lib-debug.cpp b/games/0ad/files/patch-source-lib-debug.cpp
deleted file mode 100644
index 486c277fef2..00000000000
--- a/games/0ad/files/patch-source-lib-debug.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- source/lib/debug.cpp.orig 2012-12-27 22:33:04.665325819 +0100
-+++ source/lib/debug.cpp 2012-12-27 22:34:32.369332795 +0100
-@@ -353,6 +353,8 @@
- // exit really doesn't want to see any more messages.
- static atomic_bool isExiting;
-
-+const atomic_bool DEBUG_SUPPRESS = 0xAB;
-+
- // this logic is applicable to any type of error. special cases such as
- // suppressing certain expected WARN_ERRs are done there.
- static bool ShouldSuppressError(atomic_bool* suppress)
diff --git a/games/0ad/files/patch-source-lib-debug.h b/games/0ad/files/patch-source-lib-debug.h
index e0d7b0df804..9dfccd1bec9 100644
--- a/games/0ad/files/patch-source-lib-debug.h
+++ b/games/0ad/files/patch-source-lib-debug.h
@@ -1,11 +1,11 @@
---- source/lib/debug.h.orig 2012-12-27 22:32:56.384331917 +0100
-+++ source/lib/debug.h 2012-12-27 22:33:41.699327215 +0100
+--- source/lib/debug.h.orig 2013-01-01 21:48:34.000000000 +0100
++++ source/lib/debug.h 2013-01-01 21:49:29.000000000 +0100
@@ -122,7 +122,7 @@
* debugging the symbol engine.
* use 0 as the initial value to avoid allocating .rdata space.
**/
-const atomic_bool DEBUG_SUPPRESS = 0xAB;
-+extern const atomic_bool DEBUG_SUPPRESS;
++static const atomic_bool DEBUG_SUPPRESS = 0xAB;
/**
* choices offered by the error dialog that are returned