aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-02-28 19:40:16 +0800
committeredwin <edwin@FreeBSD.org>2004-02-28 19:40:16 +0800
commit0f3813b9df5a3bcc860042ac1287f26a7e207330 (patch)
treebc780ff1ed3c3bd59e17f05767e0796879b350f2 /games
parent7f65ad4252fc583ab19393f09807e97e51e656a9 (diff)
downloadfreebsd-ports-graphics-0f3813b9df5a3bcc860042ac1287f26a7e207330.tar.gz
freebsd-ports-graphics-0f3813b9df5a3bcc860042ac1287f26a7e207330.tar.zst
freebsd-ports-graphics-0f3813b9df5a3bcc860042ac1287f26a7e207330.zip
Unbreak for non-i386.
Diffstat (limited to 'games')
-rw-r--r--games/xrobots/Makefile8
-rw-r--r--games/xrobots/files/patch-main.c11
2 files changed, 12 insertions, 7 deletions
diff --git a/games/xrobots/Makefile b/games/xrobots/Makefile
index 9e899d400bc..353889c0bcc 100644
--- a/games/xrobots/Makefile
+++ b/games/xrobots/Makefile
@@ -19,12 +19,6 @@ USE_IMAKE= yes
WRKSRC= ${WRKDIR}/xrobots-1.0
MAN6= xrobots.6
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-install:
${INSTALL} -c -g games -m 664 ${FILESDIR}/xrobotscores ${PREFIX}/lib/X11
@@ -32,4 +26,4 @@ post-patch:
${REINPLACE_CMD} -e 's|__PREFIX__|${PREFIX}|g' \
${WRKSRC}/xrobots.man ${WRKSRC}/Imakefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/xrobots/files/patch-main.c b/games/xrobots/files/patch-main.c
new file mode 100644
index 00000000000..882172cf2dc
--- /dev/null
+++ b/games/xrobots/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig Sat Feb 28 22:37:53 2004
++++ main.c Sat Feb 28 22:38:30 2004
+@@ -170,7 +170,7 @@
+ {"-scorefile","scorefile",XrmoptionSepArg, NULL },
+ };
+
+-static XtResource application_resources[] = {
++XtResource application_resources[] = {
+ {"foreground", "Foreground", XtRPixel, sizeof(Pixel),
+ (Cardinal)&fg, XtRString, (caddr_t) "Black"},
+ {"background", "Background", XtRPixel, sizeof(Pixel),