aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-04-03 12:24:48 +0800
committerjylefort <jylefort@FreeBSD.org>2006-04-03 12:24:48 +0800
commit1ea77037ebb0b718c45d0cfa3df09504c6975b02 (patch)
tree6b3d179a92e3c7e49f6231b674fe58f274d91dad /games
parentee5004f452158112b92846a3004d3d30874398e1 (diff)
downloadfreebsd-ports-graphics-1ea77037ebb0b718c45d0cfa3df09504c6975b02.tar.gz
freebsd-ports-graphics-1ea77037ebb0b718c45d0cfa3df09504c6975b02.tar.zst
freebsd-ports-graphics-1ea77037ebb0b718c45d0cfa3df09504c6975b02.zip
Add blobandconquer.
Blob and Conquer is a mission and objective based 3D action game. This is episode 2 of the Blob Wars saga (see /usr/ports/games/blobwars). With the apparent defeat of Galdov and the reclaiming of the Fire, Time, Space and Reality Crystals the Blobs' battle was only just beginning. Bob had rescued many Blobs and fought many battles, but now he had an ever bigger task ahead of him. The Blobs' homeworld is still littered with the alien forces and Bob once again makes it his task to lead the counter attack. But even without Galdov the aliens are still extremely well organised... WWW: http://www.parallelrealities.co.uk/blobAndConquer.php PR: ports/95240 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/blobandconquer/Makefile57
-rw-r--r--games/blobandconquer/distinfo3
-rw-r--r--games/blobandconquer/files/patch-makefile40
-rw-r--r--games/blobandconquer/files/patch-src_headers.h28
-rw-r--r--games/blobandconquer/files/patch-src_main.cpp10
-rw-r--r--games/blobandconquer/pkg-descr12
-rw-r--r--games/blobandconquer/pkg-plist369
8 files changed, 520 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b5f60f44b14..f348a434af3 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -58,6 +58,7 @@
SUBDIR += biloba
SUBDIR += biorythm
SUBDIR += blackjack
+ SUBDIR += blobandconquer
SUBDIR += blobwars
SUBDIR += block
SUBDIR += blockade
diff --git a/games/blobandconquer/Makefile b/games/blobandconquer/Makefile
new file mode 100644
index 00000000000..cc8c6837665
--- /dev/null
+++ b/games/blobandconquer/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: blobandconquer
+# Date created: 02 Apr 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blobandconquer
+DISTVERSION= 0.1-1
+CATEGORIES= games
+MASTER_SITES= http://www.parallelrealities.co.uk/download.php?type=zip&file=
+DISTNAME= blobAndConquer-${DISTVERSION}
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A somewhat violent 3D action game
+
+FETCH_BEFORE_ARGS+= -o ${DISTNAME}${EXTRACT_SUFX}
+
+USE_X_PREFIX= yes
+USE_SDL= sdl mixer image ttf
+USE_GL= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= makefile src/headers.h src/main.cpp
+
+WRKSRC= ${WRKDIR}/BlobAndConquer
+PORTDOCS= *
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}" DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+
+DESKTOP_ENTRIES="Blob and Conquer" \
+ "Save Blobs" \
+ "" \
+ "blobAndConquer" \
+ "Application;Game;" \
+ false
+
+post-patch:
+ @${RM} -f ${WRKSRC}/doc/LICENSE
+ @${FIND} ${WRKSRC} -type d -empty -exec ${TOUCH} "{}/.keep_me" \;
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/blobAndConquer ${PREFIX}/bin
+.for d in data gfx music sound textures
+ cd ${WRKSRC} && \
+ ${FIND} ${d} -type d -exec ${MKDIR} "${DATADIR}/{}" \; ;\
+ ${FIND} ${d} -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && \
+ ${FIND} . -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; ;\
+ ${FIND} . -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/blobandconquer/distinfo b/games/blobandconquer/distinfo
new file mode 100644
index 00000000000..47ca85e0065
--- /dev/null
+++ b/games/blobandconquer/distinfo
@@ -0,0 +1,3 @@
+MD5 (blobAndConquer-0.1-1.tar.gz) = 3211cf0eea63d185d25eae69b2f134cb
+SHA256 (blobAndConquer-0.1-1.tar.gz) = 6255b01f828b018e1874dbf049239f01550324f2d51282e96795d4fd57ea0992
+SIZE (blobAndConquer-0.1-1.tar.gz) = 12695926
diff --git a/games/blobandconquer/files/patch-makefile b/games/blobandconquer/files/patch-makefile
new file mode 100644
index 00000000000..0e9b99fa2b7
--- /dev/null
+++ b/games/blobandconquer/files/patch-makefile
@@ -0,0 +1,40 @@
+--- makefile.orig Mon Apr 3 06:09:24 2006
++++ makefile Mon Apr 3 06:09:45 2006
+@@ -12,16 +12,16 @@
+
+ PREFIX=$(DESTDIR)/usr
+ BINDIR = $(PREFIX)/games/
+-DATADIR = $(PREFIX)/share/games/blobAndConquer/
+-DOCDIR = $(PREFIX)/share/doc/$(PROG)/
++DATADIR := $(DATADIR)/
++DOCDIR = $(DOCSDIR)/
+ ICONDIR = $(PREFIX)/share/icons/
+ KDE = $(PREFIX)/share/applnk/Games/Arcade/
+ GNOME = $(PREFIX)/share/gnome/apps/Games/
+
+-CFLAGS += `sdl-config --cflags` -DVERSION=$(VERSION) -DRELEASE=$(RELEASE) -DUSEPAK=$(USEPAK)
+-CFLAGS += -DPAKNAME=\"$(PAKNAME)\" -DPAKLOCATION=\"$(DATADIR)\" -DGAMEPLAYMANUAL=\"$(DOCDIR)index.html\" -Wall -pedantic
+-LIBPATH = -L/usr/X11/lib -L/usr/X11R6/lib
+-LIBS = -lGL -lGLU `sdl-config --libs` -lSDL_mixer -lSDL_image -lSDL_ttf -lz
++CXXFLAGS += -I$(X11BASE)/include `$(SDL_CONFIG) --cflags` -DVERSION=$(VERSION) -DRELEASE=$(RELEASE) -DUSEPAK=$(USEPAK)
++CXXFLAGS += -DPAKNAME=\"$(PAKNAME)\" -DPAKLOCATION=\"$(DATADIR)\" -DGAMEPLAYMANUAL=\"$(DOCDIR)index.html\" -Wall
++LIBPATH = -L$(X11BASE)/lib
++LIBS = -lGL -lGLU `$(SDL_CONFIG) --libs` -lSDL_mixer -lSDL_image -lSDL_ttf -lz
+
+ # Yes, it means compiling is a little slower... but it's less hassle
+ SEARCHPATH = src/ src/3d/ src/common/ src/gui/ src/util/ src/game/ src/system/
+@@ -75,12 +75,12 @@
+ all: $(PROG) $(PAK)
+
+ %.o: %.cpp %.h defines.h defs.h headers.h
+- $(CXX) $(CFLAGS) -c $<
++ $(CXX) $(CXXFLAGS) -c $<
+
+ # linking the program.
+ $(PROG): $(OBJS) main.o
+ $(CXX) $(LIBPATH) $(OBJS) main.o -o $(PROG) $(LIBS)
+-
++
+ $(PAK): $(PAKOBJS)
+ $(CXX) $(LIBPATH) $(LIBS) $(PAKOBJS) -o pak
+
diff --git a/games/blobandconquer/files/patch-src_headers.h b/games/blobandconquer/files/patch-src_headers.h
new file mode 100644
index 00000000000..dafde97dc0b
--- /dev/null
+++ b/games/blobandconquer/files/patch-src_headers.h
@@ -0,0 +1,28 @@
+--- src/headers.h.orig Mon Apr 3 05:24:55 2006
++++ src/headers.h Mon Apr 3 05:26:10 2006
+@@ -18,7 +18,7 @@
+
+ */
+
+-#include "mcheck.h"
++#include <unistd.h>
+ #include "stdlib.h"
+ #include "stdio.h"
+ #include "string.h"
+@@ -29,11 +29,11 @@
+
+ #include "zlib.h"
+
+-#include "SDL/SDL.h"
+-#include "SDL/SDL_image.h"
+-#include "SDL/SDL_mixer.h"
+-#include "SDL/SDL_ttf.h"
+-#include "SDL/SDL_endian.h"
++#include "SDL11/SDL.h"
++#include "SDL11/SDL_image.h"
++#include "SDL11/SDL_mixer.h"
++#include "SDL11/SDL_ttf.h"
++#include "SDL11/SDL_endian.h"
+
+ #include "GL/gl.h"
+ #include "GL/glu.h"
diff --git a/games/blobandconquer/files/patch-src_main.cpp b/games/blobandconquer/files/patch-src_main.cpp
new file mode 100644
index 00000000000..bb8ebc01571
--- /dev/null
+++ b/games/blobandconquer/files/patch-src_main.cpp
@@ -0,0 +1,10 @@
+--- src/main.cpp.orig Mon Apr 3 06:07:33 2006
++++ src/main.cpp Mon Apr 3 06:08:15 2006
+@@ -88,6 +88,7 @@
+
+ int main(int argc, char *argv[])
+ {
++ chdir(PAKLOCATION);
+ atexit(cleanup);
+
+ loadLocaleIndex();
diff --git a/games/blobandconquer/pkg-descr b/games/blobandconquer/pkg-descr
new file mode 100644
index 00000000000..39dd0d323e5
--- /dev/null
+++ b/games/blobandconquer/pkg-descr
@@ -0,0 +1,12 @@
+Blob and Conquer is a mission and objective based 3D action game.
+This is episode 2 of the Blob Wars saga (see /usr/ports/games/blobwars).
+
+With the apparent defeat of Galdov and the reclaiming of the Fire,
+Time, Space and Reality Crystals the Blobs' battle was only just
+beginning. Bob had rescued many Blobs and fought many battles, but
+now he had an ever bigger task ahead of him. The Blobs' homeworld
+is still littered with the alien forces and Bob once again makes
+it his task to lead the counter attack. But even without Galdov the
+aliens are still extremely well organised...
+
+WWW: http://www.parallelrealities.co.uk/blobAndConquer.php
diff --git a/games/blobandconquer/pkg-plist b/games/blobandconquer/pkg-plist
new file mode 100644
index 00000000000..23f06187167
--- /dev/null
+++ b/games/blobandconquer/pkg-plist
@@ -0,0 +1,369 @@
+bin/blobAndConquer
+%%DATADIR%%/data/bsp/caves1.bak
+%%DATADIR%%/data/bsp/caves1.bsp
+%%DATADIR%%/data/bsp/caves1.map
+%%DATADIR%%/data/bsp/caves2.bak
+%%DATADIR%%/data/bsp/caves2.bsp
+%%DATADIR%%/data/bsp/caves2.map
+%%DATADIR%%/data/bsp/enemyTest.bak
+%%DATADIR%%/data/bsp/enemyTest.bsp
+%%DATADIR%%/data/bsp/enemyTest.map
+%%DATADIR%%/data/bsp/grasslands2.bak
+%%DATADIR%%/data/bsp/grasslands2.bsp
+%%DATADIR%%/data/bsp/grasslands2.map
+%%DATADIR%%/data/bsp/ground.bsp
+%%DATADIR%%/data/bsp/ground.map
+%%DATADIR%%/data/bsp/hub.bak
+%%DATADIR%%/data/bsp/hub.bsp
+%%DATADIR%%/data/bsp/hub.map
+%%DATADIR%%/data/bsp/sewers1.bak
+%%DATADIR%%/data/bsp/sewers1.bsp
+%%DATADIR%%/data/bsp/sewers1.map
+%%DATADIR%%/data/bsp/start.bak
+%%DATADIR%%/data/bsp/start.bsp
+%%DATADIR%%/data/bsp/start.map
+%%DATADIR%%/data/bsp/test.bak
+%%DATADIR%%/data/bsp/test.bsp
+%%DATADIR%%/data/bsp/test.map
+%%DATADIR%%/data/bsp/training.bak
+%%DATADIR%%/data/bsp/training.bsp
+%%DATADIR%%/data/bsp/training.map
+%%DATADIR%%/data/bsp/waste.bak
+%%DATADIR%%/data/bsp/waste.bsp
+%%DATADIR%%/data/bsp/waste.map
+%%DATADIR%%/data/combatResources/models
+%%DATADIR%%/data/combatResources/sounds
+%%DATADIR%%/data/combatResources/textures
+%%DATADIR%%/data/fonts/909.ttf
+%%DATADIR%%/data/fonts/tele.ttf
+%%DATADIR%%/data/fonts/tycho.ttf
+%%DATADIR%%/data/fonts/vera.ttf
+%%DATADIR%%/data/gameDefs/blobs
+%%DATADIR%%/data/gameDefs/defines.h
+%%DATADIR%%/data/gameDefs/enemies
+%%DATADIR%%/data/gameDefs/features
+%%DATADIR%%/data/gameDefs/items
+%%DATADIR%%/data/gameDefs/weapons
+%%DATADIR%%/data/locale/battle
+%%DATADIR%%/data/locale/controls
+%%DATADIR%%/data/locale/enemies
+%%DATADIR%%/data/locale/index
+%%DATADIR%%/data/locale/init
+%%DATADIR%%/data/locale/items
+%%DATADIR%%/data/locale/loadSave
+%%DATADIR%%/data/locale/options
+%%DATADIR%%/data/locale/status
+%%DATADIR%%/data/locale/system
+%%DATADIR%%/data/locale/weapons
+%%DATADIR%%/data/misc/letterFrequencyTable
+%%DATADIR%%/data/missions/enemytest
+%%DATADIR%%/data/missions/hub
+%%DATADIR%%/data/missions/hubLocale
+%%DATADIR%%/data/missions/mission1
+%%DATADIR%%/data/missions/mission1Locale
+%%DATADIR%%/data/missions/mission2
+%%DATADIR%%/data/missions/mission2Locale
+%%DATADIR%%/data/missions/mission3
+%%DATADIR%%/data/missions/mission3Locale
+%%DATADIR%%/data/missions/mission4
+%%DATADIR%%/data/missions/mission4Locale
+%%DATADIR%%/data/missions/mission5
+%%DATADIR%%/data/missions/mission5Locale
+%%DATADIR%%/data/missions/mission7
+%%DATADIR%%/data/missions/mission7Locale
+%%DATADIR%%/data/missions/test
+%%DATADIR%%/data/missions/training
+%%DATADIR%%/data/missions/trainingLocale
+%%DATADIR%%/data/texturespecs/common
+%%DATADIR%%/data/texturespecs/liquid
+%%DATADIR%%/data/texturespecs/list
+%%DATADIR%%/data/texturespecs/mech
+%%DATADIR%%/data/widgets/controlOptions
+%%DATADIR%%/data/widgets/gameover
+%%DATADIR%%/data/widgets/generalOptions
+%%DATADIR%%/data/widgets/inGameOptions
+%%DATADIR%%/data/widgets/loadSave
+%%DATADIR%%/data/widgets/status
+%%DATADIR%%/data/widgets/title
+%%DATADIR%%/gfx/game/episode2.png
+%%DATADIR%%/gfx/game/missionFailed.png
+%%DATADIR%%/gfx/game/orderIcon1.png
+%%DATADIR%%/gfx/game/orderIcon2.png
+%%DATADIR%%/gfx/game/orderIcon3.png
+%%DATADIR%%/gfx/game/orderIcon4.png
+%%DATADIR%%/gfx/game/targetter.png
+%%DATADIR%%/gfx/game/title.png
+%%DATADIR%%/gfx/game/titleBack.png
+%%DATADIR%%/gfx/game/violenceWarning.jpg
+%%DATADIR%%/gfx/gui/checked.png
+%%DATADIR%%/gfx/gui/downArrow.png
+%%DATADIR%%/gfx/gui/minus.png
+%%DATADIR%%/gfx/gui/plus.png
+%%DATADIR%%/gfx/gui/unchecked.png
+%%DATADIR%%/gfx/gui/upArrow.png
+%%DATADIR%%/gfx/md2/.keep_me
+%%DATADIR%%/gfx/primitive/blob.primitive
+%%DATADIR%%/gfx/primitive/bob.primitive
+%%DATADIR%%/gfx/primitive/c4.primitive
+%%DATADIR%%/gfx/primitive/eyedroid.primitive
+%%DATADIR%%/gfx/primitive/item.primitive
+%%DATADIR%%/gfx/primitive/keycard.primitive
+%%DATADIR%%/gfx/primitive/medipack.primitive
+%%DATADIR%%/gfx/primitive/weapon.primitive
+%%DATADIR%%/gfx/rw2/bullet.blend.raw
+%%DATADIR%%/gfx/rw2/cherry.blend.raw
+%%DATADIR%%/gfx/rw2/clip.blend.raw
+%%DATADIR%%/gfx/rw2/grenade.blend.raw
+%%DATADIR%%/gfx/rw2/gun.blend.raw
+%%DATADIR%%/gfx/rw2/pointer.blend.raw
+%%DATADIR%%/gfx/rw2/rifle.blend.raw
+%%DATADIR%%/gfx/rw2/uzi.blend.raw
+%%DATADIR%%/music/Dark Club.s3m
+%%DATADIR%%/music/Dragon Cave.xm
+%%DATADIR%%/music/Helmet Shake.mod
+%%DATADIR%%/music/Liquid Crystal.xm
+%%DATADIR%%/music/Neutral Zone.xm
+%%DATADIR%%/music/Sodom of Evil.xm
+%%DATADIR%%/music/Super Robot Fighter.xm
+%%DATADIR%%/music/Tales Untold.xm
+%%DATADIR%%/music/Temple.xm
+%%DATADIR%%/music/War Tales 3.xm
+%%DATADIR%%/music/Warlord Theme.s3m
+%%DATADIR%%/music/Zenith.s3m
+%%DATADIR%%/sound/ambience/general/rain.ogg
+%%DATADIR%%/sound/ambience/grasslands/birdsong.ogg
+%%DATADIR%%/sound/ambience/grasslands/cardinal.ogg
+%%DATADIR%%/sound/ambience/grasslands/falsebird.ogg
+%%DATADIR%%/sound/ambience/grasslands/lapwing.ogg
+%%DATADIR%%/sound/ambience/grasslands/robin.ogg
+%%DATADIR%%/sound/ambience/mech/commplus.ogg
+%%DATADIR%%/sound/ambience/mech/data_1.ogg
+%%DATADIR%%/sound/ambience/mech/dial.ogg
+%%DATADIR%%/sound/ambience/ruins/soulWail1.ogg
+%%DATADIR%%/sound/ambience/ruins/soulWail2.ogg
+%%DATADIR%%/sound/ambience/ruins/wolfHowl.ogg
+%%DATADIR%%/sound/combat/arm1.ogg
+%%DATADIR%%/sound/combat/arm2.ogg
+%%DATADIR%%/sound/combat/arm3.ogg
+%%DATADIR%%/sound/combat/barrierShutDown.ogg
+%%DATADIR%%/sound/combat/boom.ogg
+%%DATADIR%%/sound/combat/bulletHitWater.ogg
+%%DATADIR%%/sound/combat/clang.ogg
+%%DATADIR%%/sound/combat/command.ogg
+%%DATADIR%%/sound/combat/computer_write.ogg
+%%DATADIR%%/sound/combat/death1.ogg
+%%DATADIR%%/sound/combat/death2.ogg
+%%DATADIR%%/sound/combat/death3.ogg
+%%DATADIR%%/sound/combat/death4.ogg
+%%DATADIR%%/sound/combat/doorOpened.ogg
+%%DATADIR%%/sound/combat/doorStart.ogg
+%%DATADIR%%/sound/combat/drowning.ogg
+%%DATADIR%%/sound/combat/elecDeath1.ogg
+%%DATADIR%%/sound/combat/elecDeath2.ogg
+%%DATADIR%%/sound/combat/elecDeath3.ogg
+%%DATADIR%%/sound/combat/electricSparks01.ogg
+%%DATADIR%%/sound/combat/electricSparks02.ogg
+%%DATADIR%%/sound/combat/electricSparks03.ogg
+%%DATADIR%%/sound/combat/electricSparks04.ogg
+%%DATADIR%%/sound/combat/electricSparks05.ogg
+%%DATADIR%%/sound/combat/empty.ogg
+%%DATADIR%%/sound/combat/explode.ogg
+%%DATADIR%%/sound/combat/glassShatter1.ogg
+%%DATADIR%%/sound/combat/glassShatter2.ogg
+%%DATADIR%%/sound/combat/glassShatter3.ogg
+%%DATADIR%%/sound/combat/grenadeBounce.ogg
+%%DATADIR%%/sound/combat/gulp.ogg
+%%DATADIR%%/sound/combat/heavyPlasma.ogg
+%%DATADIR%%/sound/combat/hit.ogg
+%%DATADIR%%/sound/combat/ice.ogg
+%%DATADIR%%/sound/combat/item.ogg
+%%DATADIR%%/sound/combat/laser.ogg
+%%DATADIR%%/sound/combat/machineGun.ogg
+%%DATADIR%%/sound/combat/pain1.ogg
+%%DATADIR%%/sound/combat/pistol.ogg
+%%DATADIR%%/sound/combat/pistolReload.ogg
+%%DATADIR%%/sound/combat/plasma1.ogg
+%%DATADIR%%/sound/combat/rico1.ogg
+%%DATADIR%%/sound/combat/rico2.ogg
+%%DATADIR%%/sound/combat/rifle.ogg
+%%DATADIR%%/sound/combat/rocketLauncher.ogg
+%%DATADIR%%/sound/combat/silencedPistol.ogg
+%%DATADIR%%/sound/combat/sizzle.ogg
+%%DATADIR%%/sound/combat/smallExplode.ogg
+%%DATADIR%%/sound/combat/splat.ogg
+%%DATADIR%%/sound/combat/splatUnderwater.ogg
+%%DATADIR%%/sound/combat/switch1.ogg
+%%DATADIR%%/sound/combat/switch2.ogg
+%%DATADIR%%/sound/combat/switch3.ogg
+%%DATADIR%%/sound/combat/switchBleep.ogg
+%%DATADIR%%/sound/combat/teleport1.ogg
+%%DATADIR%%/sound/combat/teleport2.ogg
+%%DATADIR%%/sound/combat/teleport3.ogg
+%%DATADIR%%/sound/combat/throw1.ogg
+%%DATADIR%%/sound/combat/throw2.ogg
+%%DATADIR%%/sound/combat/waterIn.ogg
+%%DATADIR%%/sound/combat/waterOut.ogg
+%%DATADIR%%/sound/combat/weaponPickup.ogg
+%%DATADIR%%/sound/gui/buttonClick.ogg
+%%DATADIR%%/textures/arctic/snow01.jpg
+%%DATADIR%%/textures/common/blank.jpg
+%%DATADIR%%/textures/desert/.keep_me
+%%DATADIR%%/textures/game/arrow.png
+%%DATADIR%%/textures/game/black.png
+%%DATADIR%%/textures/game/blood01.png
+%%DATADIR%%/textures/game/bullet.png
+%%DATADIR%%/textures/game/c4.png
+%%DATADIR%%/textures/game/cherry.png
+%%DATADIR%%/textures/game/dawn.jpg
+%%DATADIR%%/textures/game/day.jpg
+%%DATADIR%%/textures/game/dusk.jpg
+%%DATADIR%%/textures/game/explosion.png
+%%DATADIR%%/textures/game/fire.png
+%%DATADIR%%/textures/game/goodBlob.png
+%%DATADIR%%/textures/game/goodBlobInjured.png
+%%DATADIR%%/textures/game/grad.png
+%%DATADIR%%/textures/game/grenade.png
+%%DATADIR%%/textures/game/grenadeBlob.png
+%%DATADIR%%/textures/game/grenadeDroid.png
+%%DATADIR%%/textures/game/grey.png
+%%DATADIR%%/textures/game/iceBlock.jpg
+%%DATADIR%%/textures/game/keycard.png
+%%DATADIR%%/textures/game/laserBlob.png
+%%DATADIR%%/textures/game/machineGunBlob.png
+%%DATADIR%%/textures/game/machineGunDroid.png
+%%DATADIR%%/textures/game/medipack.png
+%%DATADIR%%/textures/game/overcast.png
+%%DATADIR%%/textures/game/pistolBlob.png
+%%DATADIR%%/textures/game/pistolDroid.png
+%%DATADIR%%/textures/game/shotGunDroid.png
+%%DATADIR%%/textures/game/spotLightMap.png
+%%DATADIR%%/textures/game/sunset.png
+%%DATADIR%%/textures/game/teekaWeapon.png
+%%DATADIR%%/textures/game/weapon.png
+%%DATADIR%%/textures/game/white.png
+%%DATADIR%%/textures/grasslands/american_cherry.jpg
+%%DATADIR%%/textures/grasslands/brick01.jpg
+%%DATADIR%%/textures/grasslands/brick30.jpg
+%%DATADIR%%/textures/grasslands/dirt01.jpg
+%%DATADIR%%/textures/grasslands/dirt02.jpg
+%%DATADIR%%/textures/grasslands/drygrass.jpg
+%%DATADIR%%/textures/grasslands/grass.jpg
+%%DATADIR%%/textures/grasslands/grass02.jpg
+%%DATADIR%%/textures/grasslands/grass03.jpg
+%%DATADIR%%/textures/grasslands/grass04.jpg
+%%DATADIR%%/textures/grasslands/grass15.jpg
+%%DATADIR%%/textures/grasslands/grass42.jpg
+%%DATADIR%%/textures/grasslands/grass5.jpg
+%%DATADIR%%/textures/grasslands/gx_03_grass_01_patchy2.jpg
+%%DATADIR%%/textures/grasslands/gx_03_rock_01.jpg
+%%DATADIR%%/textures/grasslands/gx_04_grass_01_patchy3.jpg
+%%DATADIR%%/textures/grasslands/gx_05_grass_02.jpg
+%%DATADIR%%/textures/grasslands/kbtexture6.jpg
+%%DATADIR%%/textures/grasslands/rimu_coloured.jpg
+%%DATADIR%%/textures/grasslands/rock01.jpg
+%%DATADIR%%/textures/grasslands/rock43.jpg
+%%DATADIR%%/textures/grasslands/rusticblk.jpg
+%%DATADIR%%/textures/grasslands/sapele_cross_cut.jpg
+%%DATADIR%%/textures/grasslands/stonetile15.jpg
+%%DATADIR%%/textures/grasslands/stonetile4.jpg
+%%DATADIR%%/textures/grasslands/stonetile6.jpg
+%%DATADIR%%/textures/grasslands/stonewall03.jpg
+%%DATADIR%%/textures/liquid/lava01.jpg
+%%DATADIR%%/textures/liquid/lava02.jpg
+%%DATADIR%%/textures/liquid/slime.jpg
+%%DATADIR%%/textures/liquid/waste01.jpg
+%%DATADIR%%/textures/liquid/water01.jpg
+%%DATADIR%%/textures/liquid/water2.jpg
+%%DATADIR%%/textures/mech/basefloor01.jpg
+%%DATADIR%%/textures/mech/basefloor02.jpg
+%%DATADIR%%/textures/mech/basemetal.jpg
+%%DATADIR%%/textures/mech/biohazard.jpg
+%%DATADIR%%/textures/mech/box-metal01.jpg
+%%DATADIR%%/textures/mech/caution01.jpg
+%%DATADIR%%/textures/mech/computerscreen01.jpg
+%%DATADIR%%/textures/mech/computerscreen02.jpg
+%%DATADIR%%/textures/mech/computerscreen03.jpg
+%%DATADIR%%/textures/mech/computerscreen04.jpg
+%%DATADIR%%/textures/mech/computerscreen05.jpg
+%%DATADIR%%/textures/mech/computerscreen06.jpg
+%%DATADIR%%/textures/mech/computerscreen07.jpg
+%%DATADIR%%/textures/mech/computerscreen08.jpg
+%%DATADIR%%/textures/mech/computerscreen09.jpg
+%%DATADIR%%/textures/mech/crate.jpg
+%%DATADIR%%/textures/mech/e8_jumppad02.jpg
+%%DATADIR%%/textures/mech/e8_launchpad1.jpg
+%%DATADIR%%/textures/mech/energybarrier01.jpg
+%%DATADIR%%/textures/mech/floor-concrete06.jpg
+%%DATADIR%%/textures/mech/glass01.jpg
+%%DATADIR%%/textures/mech/glass02.jpg
+%%DATADIR%%/textures/mech/light01.jpg
+%%DATADIR%%/textures/mech/metal01.jpg
+%%DATADIR%%/textures/mech/metal02.jpg
+%%DATADIR%%/textures/mech/metal03.jpg
+%%DATADIR%%/textures/mech/metal04.jpg
+%%DATADIR%%/textures/mech/metal05.jpg
+%%DATADIR%%/textures/mech/metal06.jpg
+%%DATADIR%%/textures/mech/metal07.jpg
+%%DATADIR%%/textures/mech/metalbox.jpg
+%%DATADIR%%/textures/mech/pipe.jpg
+%%DATADIR%%/textures/mech/plasmapipe.jpg
+%%DATADIR%%/textures/mech/rollup.jpg
+%%DATADIR%%/textures/mech/rustedmetal07.jpg
+%%DATADIR%%/textures/mech/taillight.jpg
+%%DATADIR%%/textures/mech/wallpaintgrey01.jpg
+%%DATADIR%%/textures/radiant/notex.tga
+%%DATADIR%%/textures/radiant/shadernotex.tga
+%%DATADIR%%/textures/ruins/granite01.jpg
+%%DATADIR%%/textures/ruins/stone01.jpg
+%%DATADIR%%/textures/tools/nospawn.tga
+%%DATADIR%%/textures/tunnels/dkstone.jpg
+%%DATADIR%%/textures/tunnels/grate1.jpg
+%%DATADIR%%/textures/tunnels/metal04.jpg
+%%DATADIR%%/textures/tunnels/metalrust2.jpg
+%%DATADIR%%/textures/tunnels/metc1.jpg
+%%DATADIR%%/textures/tunnels/metc2.jpg
+%%DATADIR%%/textures/tunnels/ramp.jpg
+%%DATADIR%%/textures/tunnels/sewer.jpg
+%%DATADIR%%/textures/tunnels/sewerbricks1.jpg
+%%DATADIR%%/textures/tunnels/sewerbricks2.jpg
+%%DATADIR%%/textures/tunnels/sewerwall1.jpg
+%%DATADIR%%/textures/virtual/virtual.jpg
+@dirrm %%DATADIR%%/textures/virtual
+@dirrm %%DATADIR%%/textures/tunnels
+@dirrm %%DATADIR%%/textures/tools
+@dirrm %%DATADIR%%/textures/ruins
+@dirrm %%DATADIR%%/textures/radiant
+@dirrm %%DATADIR%%/textures/mech
+@dirrm %%DATADIR%%/textures/liquid
+@dirrm %%DATADIR%%/textures/grasslands
+@dirrm %%DATADIR%%/textures/game
+@dirrm %%DATADIR%%/textures/desert
+@dirrm %%DATADIR%%/textures/common
+@dirrm %%DATADIR%%/textures/arctic
+@dirrm %%DATADIR%%/textures
+@dirrm %%DATADIR%%/sound/gui
+@dirrm %%DATADIR%%/sound/combat
+@dirrm %%DATADIR%%/sound/ambience/ruins
+@dirrm %%DATADIR%%/sound/ambience/mech
+@dirrm %%DATADIR%%/sound/ambience/grasslands
+@dirrm %%DATADIR%%/sound/ambience/general
+@dirrm %%DATADIR%%/sound/ambience
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/gfx/rw2
+@dirrm %%DATADIR%%/gfx/primitive
+@dirrm %%DATADIR%%/gfx/md2
+@dirrm %%DATADIR%%/gfx/gui
+@dirrm %%DATADIR%%/gfx/game
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/data/widgets
+@dirrm %%DATADIR%%/data/texturespecs
+@dirrm %%DATADIR%%/data/missions
+@dirrm %%DATADIR%%/data/misc
+@dirrm %%DATADIR%%/data/locale
+@dirrm %%DATADIR%%/data/gameDefs
+@dirrm %%DATADIR%%/data/fonts
+@dirrm %%DATADIR%%/data/combatResources
+@dirrm %%DATADIR%%/data/bsp
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%