aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-05-31 04:57:13 +0800
committermadpilot <madpilot@FreeBSD.org>2016-05-31 04:57:13 +0800
commit402fd73a6416c5ee3b412fbd344f4245eb094dbf (patch)
treee067eed3c7bb0ff6e75119100db3a718e61dd1a8 /games
parent1c8c6bcb210108afbf0ddbe3bfafd22e8c275221 (diff)
downloadfreebsd-ports-graphics-402fd73a6416c5ee3b412fbd344f4245eb094dbf.tar.gz
freebsd-ports-graphics-402fd73a6416c5ee3b412fbd344f4245eb094dbf.tar.zst
freebsd-ports-graphics-402fd73a6416c5ee3b412fbd344f4245eb094dbf.zip
- Update to 0.60
- Add workaround for what appears to be a gcc bug on 9.x. - Enable again MOVIES option by default, it does not crash anymore.
Diffstat (limited to 'games')
-rw-r--r--games/corsix-th/Makefile15
-rw-r--r--games/corsix-th/distinfo5
-rw-r--r--games/corsix-th/files/patch-CMake_FindLua.cmake6
-rw-r--r--games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp10
-rw-r--r--games/corsix-th/pkg-plist19
5 files changed, 20 insertions, 35 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 20e06c6c4db..7c5cac39955 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= corsixth
-PORTVERSION= 0.50
+PORTVERSION= 0.60
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= games
MAINTAINER= madpilot@FreeBSD.org
@@ -16,7 +15,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2
RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
-USES= cmake compiler:c++11-lang dos2unix iconv lua pkgconfig
+USES= cmake compiler:c++11-lib dos2unix iconv lua pkgconfig
USE_SDL= mixer2
DOS2UNIX_FILES= CMake/FindFFmpeg.cmake \
CorsixTH/CMakeLists.txt \
@@ -29,13 +28,19 @@ GH_ACCOUNT= CorsixTH
GH_PROJECT= CorsixTH
OPTIONS_DEFINE= MOVIES
-#OPTIONS_DEFAULT= MOVIES
+OPTIONS_DEFAULT= MOVIES
MOVIES_DESC= Play in-game movies
MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
MOVIES_LIB_DEPENDS= libswresample.so:multimedia/ffmpeg
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000024 && ${CHOSEN_COMPILER_TYPE} == gcc
+CXXFLAGS+= -D_GLIBCXX_USE_C99
+.endif
+
post-patch:
# Allow the game to find its resources without wrapper scripts
@${REINPLACE_CMD} -e \
@@ -49,4 +54,4 @@ do-install:
cd ${WRKSRC}/CorsixTH && ${COPYTREE_SHARE} "Bitmap Levels Lua" \
${STAGEDIR}${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/corsix-th/distinfo b/games/corsix-th/distinfo
index 2be2cff6a4b..deee65c8175 100644
--- a/games/corsix-th/distinfo
+++ b/games/corsix-th/distinfo
@@ -1,2 +1,3 @@
-SHA256 (CorsixTH-CorsixTH-v0.50_GH0.tar.gz) = 822cb5b4a4ec863ba410b6a37e456b360516b2362337532689070e4555c037ee
-SIZE (CorsixTH-CorsixTH-v0.50_GH0.tar.gz) = 4334892
+TIMESTAMP = 1464603838
+SHA256 (CorsixTH-CorsixTH-v0.60_GH0.tar.gz) = f5ff7839b6469f1da39804de1df0a86e57b45620c26f044a1700e43d8da19ce9
+SIZE (CorsixTH-CorsixTH-v0.60_GH0.tar.gz) = 4236286
diff --git a/games/corsix-th/files/patch-CMake_FindLua.cmake b/games/corsix-th/files/patch-CMake_FindLua.cmake
index d6866d08fbb..21bc4a4e2a5 100644
--- a/games/corsix-th/files/patch-CMake_FindLua.cmake
+++ b/games/corsix-th/files/patch-CMake_FindLua.cmake
@@ -1,11 +1,11 @@
---- CMake/FindLua.cmake.orig 2015-08-30 20:29:45 UTC
+--- CMake/FindLua.cmake.orig 2016-05-29 23:31:27 UTC
+++ CMake/FindLua.cmake
@@ -26,8 +26,8 @@ IF (WITH_LUAJIT)
SET (LUA_INCLUDE_DIRS include/luajit-2.0 include)
ELSE (WITH_LUAJIT)
SET (LUA_INTERPRETER_TYPE "Lua")
-- SET (LUA_LIBRARY_NAME lua53 lua52 lua5.1 lua51 lua lua-5.1 liblua)
-- SET (LUA_INCLUDE_DIRS include include/lua include/lua5.1 include/lua51 include/lua-5.1)
+- SET (LUA_LIBRARY_NAME lua53 lua5.2 lua52 lua5.1 lua51 lua lua-5.1 liblua liblua.5.3.dylib)
+- SET (LUA_INCLUDE_DIRS include include/lua include/lua5.1 include/lua51 include/lua-5.1 include/lua5.2 include/lua5.3 include/lua-5.3)
+ SET (LUA_LIBRARY_NAME lua-5.1 lua-5.2 lua-5.3)
+ SET (LUA_INCLUDE_DIRS include include/lua include/lua51 include/lua52 include/lua53)
ENDIF(WITH_LUAJIT)
diff --git a/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp b/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
deleted file mode 100644
index b5ad16abc65..00000000000
--- a/games/corsix-th/files/patch-CorsixTH-Src-iso_fs.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- CorsixTH/Src/iso_fs.cpp.orig 2015-09-18 21:09:59 UTC
-+++ CorsixTH/Src/iso_fs.cpp
-@@ -31,6 +31,7 @@ SOFTWARE.
- #ifdef CORSIX_TH_HAS_ALLOCA_H
- #include <alloca.h>
- #endif
-+#include <cstdlib>
- #include <algorithm>
-
- IsoFilesystem::IsoFilesystem()
diff --git a/games/corsix-th/pkg-plist b/games/corsix-th/pkg-plist
index 4331ef8818a..0c38e5b91a2 100644
--- a/games/corsix-th/pkg-plist
+++ b/games/corsix-th/pkg-plist
@@ -14,7 +14,6 @@ bin/CorsixTH
%%DATADIR%%/Bitmap/flag_travel_north.bmp
%%DATADIR%%/Bitmap/flag_travel_south.bmp
%%DATADIR%%/Bitmap/flag_travel_west.bmp
-%%DATADIR%%/Bitmap/flags32.png
%%DATADIR%%/Bitmap/fullscreen_border_bottom.bmp
%%DATADIR%%/Bitmap/fullscreen_border_bottomleft.bmp
%%DATADIR%%/Bitmap/fullscreen_border_bottomright.bmp
@@ -37,14 +36,7 @@ bin/CorsixTH
%%DATADIR%%/Bitmap/mkfont.lua
%%DATADIR%%/Bitmap/mkraw.lua
%%DATADIR%%/Bitmap/mksheet.lua
-%%DATADIR%%/Bitmap/new32.png
-%%DATADIR%%/Bitmap/open32.png
-%%DATADIR%%/Bitmap/parcels32.png
-%%DATADIR%%/Bitmap/positions32.png
%%DATADIR%%/Bitmap/readme.txt
-%%DATADIR%%/Bitmap/redo32.png
-%%DATADIR%%/Bitmap/save32.png
-%%DATADIR%%/Bitmap/transparent_walls32.png
%%DATADIR%%/Bitmap/tree_collapsed.bmp
%%DATADIR%%/Bitmap/tree_ctrl.dat
%%DATADIR%%/Bitmap/tree_ctrl.pal
@@ -53,7 +45,6 @@ bin/CorsixTH
%%DATADIR%%/Bitmap/tree_expanded.bmp
%%DATADIR%%/Bitmap/tree_leaf.bmp
%%DATADIR%%/Bitmap/tree_level.bmp
-%%DATADIR%%/Bitmap/undo32.png
%%DATADIR%%/CorsixTH.lua
%%DATADIR%%/Levels/Example.map
%%DATADIR%%/Levels/avatar.level
@@ -77,11 +68,6 @@ bin/CorsixTH
%%DATADIR%%/Lua/base_config.lua
%%DATADIR%%/Lua/calls_dispatcher.lua
%%DATADIR%%/Lua/class.lua
-%%DATADIR%%/Lua/command.lua
-%%DATADIR%%/Lua/command_stack.lua
-%%DATADIR%%/Lua/commands/compound.lua
-%%DATADIR%%/Lua/commands/set_map_cell.lua
-%%DATADIR%%/Lua/commands/set_map_cell_flags.lua
%%DATADIR%%/Lua/config_finder.lua
%%DATADIR%%/Lua/debug_script.lua
%%DATADIR%%/Lua/diagnosis/diag_blood_machine.lua
@@ -114,7 +100,6 @@ bin/CorsixTH
%%DATADIR%%/Lua/dialogs/information.lua
%%DATADIR%%/Lua/dialogs/jukebox.lua
%%DATADIR%%/Lua/dialogs/machine_dialog.lua
-%%DATADIR%%/Lua/dialogs/map_editor.lua
%%DATADIR%%/Lua/dialogs/menu.lua
%%DATADIR%%/Lua/dialogs/message.lua
%%DATADIR%%/Lua/dialogs/patient.lua
@@ -130,11 +115,15 @@ bin/CorsixTH
%%DATADIR%%/Lua/dialogs/resizables/file_browser.lua
%%DATADIR%%/Lua/dialogs/resizables/file_browsers/choose_font.lua
%%DATADIR%%/Lua/dialogs/resizables/file_browsers/load_game.lua
+%%DATADIR%%/Lua/dialogs/resizables/file_browsers/load_map.lua
%%DATADIR%%/Lua/dialogs/resizables/file_browsers/save_game.lua
+%%DATADIR%%/Lua/dialogs/resizables/file_browsers/save_map.lua
%%DATADIR%%/Lua/dialogs/resizables/folder_settings.lua
%%DATADIR%%/Lua/dialogs/resizables/lua_console.lua
%%DATADIR%%/Lua/dialogs/resizables/main_menu.lua
+%%DATADIR%%/Lua/dialogs/resizables/map_editor.lua
%%DATADIR%%/Lua/dialogs/resizables/menu_list_dialog.lua
+%%DATADIR%%/Lua/dialogs/resizables/menu_list_dialogs/custom_campaign.lua
%%DATADIR%%/Lua/dialogs/resizables/menu_list_dialogs/custom_game.lua
%%DATADIR%%/Lua/dialogs/resizables/menu_list_dialogs/make_debug_patient.lua
%%DATADIR%%/Lua/dialogs/resizables/new_game.lua