aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2013-03-24 13:32:19 +0800
committeracm <acm@FreeBSD.org>2013-03-24 13:32:19 +0800
commit4861548be58375233b4a90f54d9e167d9fd29521 (patch)
tree04223de5726cfd31473f99cc1ab78d9b480b32e5 /games
parent7f21843f3f06fad30c8b6d4a11f580e948b6abb8 (diff)
downloadfreebsd-ports-graphics-4861548be58375233b4a90f54d9e167d9fd29521.tar.gz
freebsd-ports-graphics-4861548be58375233b4a90f54d9e167d9fd29521.tar.zst
freebsd-ports-graphics-4861548be58375233b4a90f54d9e167d9fd29521.zip
- Fix build using clang
- Bump PORTREVISION PR: 172205 Submitted by: Miklos Magyari <magyarimiki _at_ gmail.com>
Diffstat (limited to 'games')
-rw-r--r--games/ceferino/Makefile2
-rw-r--r--games/ceferino/files/patch-src_nivel.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 9fff2381b97..64d100cdd3e 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ceferino
PORTVERSION= 0.97.8
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= http://www.losersjuegos.com.ar/_media/juegos/ceferino/descargas/
diff --git a/games/ceferino/files/patch-src_nivel.h b/games/ceferino/files/patch-src_nivel.h
new file mode 100644
index 00000000000..979737a2689
--- /dev/null
+++ b/games/ceferino/files/patch-src_nivel.h
@@ -0,0 +1,11 @@
+--- src/nivel.h 2005-06-24 13:00:26.000000000 -0500
++++ src/nivel.h 2013-03-24 00:23:03.000000000 -0500
+@@ -34,7 +34,7 @@
+ class nivel
+ {
+ public:
+- void iniciar(juego *_pjuego, grafico *grafico, grafico *pfondos, SDL_Surface *fondo);
++ void iniciar(juego *_pjuego, grafico *grafico, class grafico *pfondos, SDL_Surface *fondo);
+ int avanzar_nivel(int salto = 1);
+ int reiniciar_nivel(void);
+ int get_dist_suelo(int x, int y, int max);