aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2006-07-06 18:02:05 +0800
committerdanfe <danfe@FreeBSD.org>2006-07-06 18:02:05 +0800
commit497007a73a7b673c19c51be81ba90518ac06015d (patch)
tree26a04380b579b48913b73efaf071567c3c4e6c11 /games
parent045fcfb4bb5af8dc7c7931b05cdd863ecb085046 (diff)
downloadfreebsd-ports-graphics-497007a73a7b673c19c51be81ba90518ac06015d.tar.gz
freebsd-ports-graphics-497007a73a7b673c19c51be81ba90518ac06015d.tar.zst
freebsd-ports-graphics-497007a73a7b673c19c51be81ba90518ac06015d.zip
Update to version 0.4.0.
Diffstat (limited to 'games')
-rw-r--r--games/quetoo/Makefile12
-rw-r--r--games/quetoo/distinfo6
-rw-r--r--games/quetoo/files/extra-patch-fbsd484
-rw-r--r--games/quetoo/files/patch-configure.in47
-rw-r--r--games/quetoo/pkg-plist8
5 files changed, 66 insertions, 91 deletions
diff --git a/games/quetoo/Makefile b/games/quetoo/Makefile
index 165e66e9ca8..9ece3bd34cf 100644
--- a/games/quetoo/Makefile
+++ b/games/quetoo/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= quetoo
-PORTVERSION= 0.3.4
+PORTVERSION= 0.4.0
CATEGORIES= games
MASTER_SITES= http://jdolan.dyndns.org/jaydolan/files/
MAINTAINER= danfe@FreeBSD.org
COMMENT= Fast, stable, compatible, and secure Quake II client
-USE_AUTOTOOLS= autoconf:259
USE_BZIP2= yes
USE_SDL= sdl
USE_GL= yes
@@ -66,11 +65,10 @@ CONFIGURE_ARGS+= --disable-opt --disable-sse
.endif
post-extract: .SILENT
- ${REINPLACE_CMD} -E 's,^(eval PKGDATADIR=).*$$,\1"${Q2DIR}",' \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} -E 's,-ldl,-rdynamic,' ${WRKSRC}/src/Makefile.in
- ${REINPLACE_CMD} 's,alsa,sdl,' ${WRKSRC}/src/snd_dma.c
- ${REINPLACE_CMD} 's,mysql/mysql,mysql,' ${WRKSRC}/src/qmass/g_local.h
+ ${REINPLACE_CMD} -E 's,^(eval PKGDATADIR=).*$$,\1"${Q2DIR}",; \
+ s,sdl-config,${SDL_CONFIG},' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,-ldl,,' ${WRKSRC}/src/Makefile.in
+ ${REINPLACE_CMD} -e 's,alsa,sdl,' ${WRKSRC}/src/snd_ref.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/quetoo ${PREFIX}/bin/quetoo
diff --git a/games/quetoo/distinfo b/games/quetoo/distinfo
index 0fa3649b9ba..5122ea00c10 100644
--- a/games/quetoo/distinfo
+++ b/games/quetoo/distinfo
@@ -1,3 +1,3 @@
-MD5 (quetoo-0.3.4.tar.bz2) = 12809b9aae8c4b7389c5478e910338fd
-SHA256 (quetoo-0.3.4.tar.bz2) = 1271f4a11fa9e954e87e07601c1e786e82c6d1ec2d794a02f7b5ec12da36476d
-SIZE (quetoo-0.3.4.tar.bz2) = 885752
+MD5 (quetoo-0.4.0.tar.bz2) = e1649d5cb1729c0561d3809a55f3edce
+SHA256 (quetoo-0.4.0.tar.bz2) = 4265cb461f278343d949f63e710e8c395b1568b2a5a74a2610f7aa52bce91a16
+SIZE (quetoo-0.4.0.tar.bz2) = 888077
diff --git a/games/quetoo/files/extra-patch-fbsd4 b/games/quetoo/files/extra-patch-fbsd4
index f965509532f..1a903afcc91 100644
--- a/games/quetoo/files/extra-patch-fbsd4
+++ b/games/quetoo/files/extra-patch-fbsd4
@@ -1,23 +1,3 @@
---- src/main.c.orig Sun Apr 9 20:11:49 2006
-+++ src/main.c Fri Jun 16 05:00:44 2006
-@@ -289,7 +289,7 @@
- ret = fread(ptr, size, nitems, fp);
- err = errno;
- if(ret != nitems){
-- printf("verify_fread(...,%zu,%zu,...): return value: %zu\n", size, nitems, ret);
-+ printf("verify_fread(...,%u,%u,...): return value: %u\n", size, nitems, ret);
- if(ret == 0 && ferror(fp)){
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));
-@@ -306,7 +306,7 @@
- ret = fwrite(ptr, size, nitems, fp);
- err = errno;
- if(ret != nitems){
-- printf("verify_fwrite(...,%zu,%zu,...) = %zu\n", size, nitems, ret);
-+ printf("verify_fwrite(...,%u,%u,...) = %u\n", size, nitems, ret);
- if(ret == 0 && ferror(fp)){
- printf(" error: %s\n", strerror(err));
- printf(" fileno=%d\n", fileno(fp));
--- src/qmass/p_client.c.orig Sat Apr 8 06:51:19 2006
+++ src/qmass/p_client.c Fri Jun 16 05:06:09 2006
@@ -850,6 +850,9 @@
@@ -59,8 +39,8 @@
gi.sound(ent, CHAN_NO_PHS_ADD, gi.soundindex(sound),
1, ATTN_NONE, 0);
}
---- src/ref_glx.c.orig Tue Apr 11 08:56:53 2006
-+++ src/ref_glx.c Fri Jun 16 04:53:40 2006
+--- src/vid_glx.c.orig Tue Apr 11 08:56:53 2006
++++ src/vid_glx.c Fri Jun 16 04:53:40 2006
@@ -785,6 +785,9 @@
XSizeHints *sizehints;
XWMHints *wmhints;
@@ -80,20 +60,21 @@
XF86VidModeGetAllModeLines(dpy, screen, &num_vidmodes, &vidmodes);
if(fullscreen){
---- src/ref_softx.c.orig Sat Apr 22 19:54:36 2006
-+++ src/ref_softx.c Fri Jun 16 04:50:02 2006
-@@ -846,6 +846,10 @@
+--- src/vid_softx.c.orig Sat Apr 22 19:54:36 2006
++++ src/vid_softx.c Fri Jun 16 04:50:02 2006
+@@ -747,6 +747,11 @@
+ XSizeHints *sizehints;
XWMHints *wmhints;
unsigned long mask;
- int i;
++ int i;
+#ifdef HAVE_XF86_VIDMODE
+ int num_vidmodes = 0;
+#endif
+ XGCValues vals;
- window_width = width;
- window_height = height;
-@@ -870,8 +874,6 @@
+ // destroy existing window
+ SWimp_Shutdown();
+@@ -768,8 +773,6 @@
}
#ifdef HAVE_XF86_VIDMODE
@@ -102,7 +83,7 @@
XF86VidModeGetAllModeLines(dpy, screen, &num_vidmodes, &vidmodes);
if(fullscreen){
-@@ -996,7 +998,6 @@
+@@ -894,7 +897,6 @@
}
#endif // HAVE_XF86_VIDMODE
@@ -110,6 +91,15 @@
vals.graphics_exposures = False;
gc = XCreateGC(dpy, win, GCGraphicsExposures, &vals);
+@@ -906,7 +908,7 @@
+ }
+
+ viddef.height = height; viddef.width = width;
+- int i = ((viddef.width * 4 + 7) & ~7) * viddef.height;
++ i = ((viddef.width * 4 + 7) & ~7) * viddef.height;
+
+ x_framebuffer = XCreateImage(dpy,
+ visinfo->visual,
--- src/tga.c.orig Wed Apr 26 23:26:50 2006
+++ src/tga.c Fri Jun 16 04:52:35 2006
@@ -35,6 +35,9 @@
@@ -132,3 +122,37 @@
red = green = blue = alpha = 0;
packet_header = packet_size = j = 0;
+--- src/cl_parse.c.orig Thu Jun 22 10:26:09 2006
++++ src/cl_parse.c Thu Jul 6 09:38:33 2006
+@@ -559,11 +559,12 @@
+ * Returns true of msg should be discarded, according to cl_ignore.
+ */
+ qboolean CL_IgnoreChatMessage(char *msg){
++ char *s;
+
+ if(!*cl_ignore->string || strlen(cl_ignore->string) < 1)
+ return false; // nothing currently filtered
+
+- char *s = strtok(cl_ignore->string, " ");
++ s = strtok(cl_ignore->string, " ");
+ while(s){
+ if(strstr(msg, s))
+ return true;
+--- src/common.c.orig Fri Jun 30 09:23:25 2006
++++ src/common.c Thu Jul 6 09:38:37 2006
+@@ -1188,6 +1188,7 @@
+ */
+ void Qcommon_Init(int argc, char **argv){
+ char *s;
++ #include "binds.h"
+
+ if(setjmp(abortframe))
+ Sys_Error("Error during initialization");
+@@ -1215,7 +1216,6 @@
+
+ FS_InitFilesystem();
+
+- #include "binds.h"
+ Cbuf_AddText(DEFAULT_BINDS);
+ Cbuf_AddText("exec quetoo.cfg\n");
+
diff --git a/games/quetoo/files/patch-configure.in b/games/quetoo/files/patch-configure.in
deleted file mode 100644
index 70003d18636..00000000000
--- a/games/quetoo/files/patch-configure.in
+++ /dev/null
@@ -1,47 +0,0 @@
---- configure.in.orig Sat Jun 3 00:56:38 2006
-+++ configure.in Sat Jun 3 01:01:40 2006
-@@ -129,14 +129,19 @@
- )
- )
-
--if test "x$with_sdl" != xno; then
-- AC_CHECK_HEADER(SDL/SDL.h,
-+if test "x${with_sdl}" != xno; then
-+ SDL_CFLAGS=`${SDL_CONFIG} --cflags`
-+ save_CPPFLAGS="$CPPFLAGS"
-+ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
-+
-+ AC_CHECK_HEADER(SDL.h,
- HAVE_SDL=yes
-- SDL_CFLAGS=`sdl-config --cflags`
-- SDL_LIBS=`sdl-config --libs`
-+ SDL_LIBS=`${SDL_CONFIG} --libs`
- SND_REFS="$SND_REFS snd_sdl.la",
- HAVE_SDL=no
- )
-+
-+ CPPFLAGS="$save_CPPFLAGS"
- fi
- AC_SUBST(HAVE_SDL)
- AC_SUBST(SDL_CFLAGS)
-@@ -207,14 +212,18 @@
- )
-
- if test "x${with_mysql}" != xno ; then
-+ MYSQL_CFLAGS=`mysql_config --cflags`
-+ save_CPPFLAGS="$CPPFLAGS"
-+ CPPFLAGS="$CPPFLAGS $MYSQL_CFLAGS"
-
-- AC_CHECK_HEADER(mysql/mysql.h,
-+ AC_CHECK_HEADER(mysql.h,
- HAVE_MYSQL=yes
- AC_DEFINE(HAVE_MYSQL, 1, [Define this if you have MySQL])
-- MYSQL_CFLAGS=`mysql_config --cflags`
- MYSQL_LIBS=`mysql_config --libs`,
- HAVE_MYSQL=no
- )
-+
-+ CPPFLAGS="$save_CPPFLAGS"
- fi
- AC_SUBST(MYSQL_CFLAGS)
- AC_SUBST(MYSQL_LIBS)
diff --git a/games/quetoo/pkg-plist b/games/quetoo/pkg-plist
index f73ef709de0..7507725b5c7 100644
--- a/games/quetoo/pkg-plist
+++ b/games/quetoo/pkg-plist
@@ -2,10 +2,10 @@ bin/quetoo
%%LIBDIR%%/baseq2/game.so
%%LIBDIR%%/ctf/game.so
%%QMASS%%%%LIBDIR%%/qmass/game.so
-%%LIBDIR%%/ref_glsdl.so
-%%LIBDIR%%/ref_glx.so
-%%LIBDIR%%/ref_softsdl.so
-%%LIBDIR%%/ref_softx.so
+%%LIBDIR%%/vid_glsdl.so
+%%LIBDIR%%/vid_glx.so
+%%LIBDIR%%/vid_softsdl.so
+%%LIBDIR%%/vid_softx.so
%%LIBDIR%%/snd_sdl.so
%%PORTDOCS%%%%DOCSDIR%%/README
%%QMASS%%%%PORTDOCS%%%%DOCSDIR%%/qmass-README