aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-10-19 10:02:34 +0800
committeralepulver <alepulver@FreeBSD.org>2007-10-19 10:02:34 +0800
commit4a08447cf89fa0bbbd04b7295bb5e3462c17a93c (patch)
tree2e79561dbc75dc9a52ca9d60e6bbcae04a42f008 /games
parenta61abfa9731075a3ac62c2ca3ccc74a9b8ae4869 (diff)
downloadfreebsd-ports-graphics-4a08447cf89fa0bbbd04b7295bb5e3462c17a93c.tar.gz
freebsd-ports-graphics-4a08447cf89fa0bbbd04b7295bb5e3462c17a93c.tar.zst
freebsd-ports-graphics-4a08447cf89fa0bbbd04b7295bb5e3462c17a93c.zip
- Add USE_XLIB when needed since USE_GL does not imply it anymore.
Reported by: pointyhat (via erwin)
Diffstat (limited to 'games')
-rw-r--r--games/evq3/Makefile1
-rw-r--r--games/openarena/Makefile1
-rw-r--r--games/q3cellshading/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/games/evq3/Makefile b/games/evq3/Makefile
index 69ba76a908a..8e8974cf76c 100644
--- a/games/evq3/Makefile
+++ b/games/evq3/Makefile
@@ -24,6 +24,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
USE_ZIP= yes
USE_DOS2UNIX= yes
USE_GL= yes
+USE_XLIB= yes
USE_SCONS= yes
SCONS_ARGS= warnings=0
NO_WRKSUBDIR= yes
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index a809758e727..9ad7c295efb 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -81,6 +81,7 @@ USE_SDL= sdl
MAKE_ENV+= USE_SDL_VIDEO=1
. else
USE_GL= yes
+USE_XLIB= yes
. endif
.endif
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 36fc94664af..663ac3f5c98 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -57,6 +57,7 @@ MAKE_ENV+= DLL_ONLY=true
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
USE_GL= yes
+USE_XLIB= yes
.endif
.if !defined(WITHOUT_CLIENT)