aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-12-09 03:21:23 +0800
committermarino <marino@FreeBSD.org>2013-12-09 03:21:23 +0800
commit648ba911adfba5e7cf5648c9136e9658bd54b386 (patch)
treeda311abc8d4dc06c3055717efcc1267f97689427 /games
parenta78b515c6e85b11b2d612bde83f1a8fb3c5a2b8f (diff)
downloadfreebsd-ports-graphics-648ba911adfba5e7cf5648c9136e9658bd54b386.tar.gz
freebsd-ports-graphics-648ba911adfba5e7cf5648c9136e9658bd54b386.tar.zst
freebsd-ports-graphics-648ba911adfba5e7cf5648c9136e9658bd54b386.zip
games/atris: Use gmake as specified
This port specifies gmake, but "make" was hardcoded. This becomes apparent when bmake is used to build the port (it fails). The new post-patch command allows gmake to be used as intended. PR: ports/181731 Submitted by: Jan Beich
Diffstat (limited to 'games')
-rw-r--r--games/atris/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/atris/Makefile b/games/atris/Makefile
index b62b5e1ca4c..9b1576eeab9 100644
--- a/games/atris/Makefile
+++ b/games/atris/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.sourcefiles.org/Games/Arcade/Block_Based/Tetris/
MAINTAINER= ports@FreeBSD.org
COMMENT= Atris: Alizarin Tetris
-USE_GMAKE= yes
+USES= gmake
USE_SDL= sdl ttf
GNU_CONFIGURE= yes
@@ -24,6 +24,9 @@ post-patch:
# Fix path to ${DATADIR}
${REINPLACE_CMD} -e 's|\(GAME_INSTALLDIR=\).*|\1"${DATADIR}"|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+# Fix install target to use gmake
+ ${REINPLACE_CMD} -e '/^install:/,/^$$/s/make/$$(MAKE)/' \
+ ${WRKSRC}/Makefile.in
# Fix SDL include statement
.for f in *.c *.h