aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-09 03:04:54 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-09 03:04:54 +0800
commit96b01ae44f1c727d7f936caf73781cf76ab1cd24 (patch)
tree03ee37b23e712667fab5339defe493314d564cc5 /games
parentefae09a75e40b7650cf41636fa0e8699ef9ae31d (diff)
downloadfreebsd-ports-graphics-96b01ae44f1c727d7f936caf73781cf76ab1cd24.tar.gz
freebsd-ports-graphics-96b01ae44f1c727d7f936caf73781cf76ab1cd24.tar.zst
freebsd-ports-graphics-96b01ae44f1c727d7f936caf73781cf76ab1cd24.zip
Schiff is the German word for ship.
Steer your ship(s) with the keyboard to rotate or move forward / backward. Try to avoid enemy bullets and the floating yellow rectangles. Become last ship floating to win the game. WWW: http://thepythongamebook.com/en:resources:games:schiff PR: ports/171237 Submitted by: nemysis (self) Approved by: pawel (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/schiff/Makefile45
-rw-r--r--games/schiff/distinfo4
-rw-r--r--games/schiff/files/schiff.in7
-rw-r--r--games/schiff/pkg-descr6
5 files changed, 63 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 42936d953b8..5acc76a9bcc 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -842,6 +842,7 @@
SUBDIR += sarien
SUBDIR += sauerbraten
SUBDIR += scare
+ SUBDIR += schiff
SUBDIR += schwarzweiss
SUBDIR += scid
SUBDIR += scorched3d
diff --git a/games/schiff/Makefile b/games/schiff/Makefile
new file mode 100644
index 00000000000..9f019065976
--- /dev/null
+++ b/games/schiff/Makefile
@@ -0,0 +1,45 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= schiff
+PORTVERSION= 16
+CATEGORIES= games python
+MASTER_SITES= SF/pygamebook/${PORTNAME:S/s/S/}/${PORTNAME}${PORTVERSION}.py/ \
+ SF/nemysisfreebsdp/games/:icons
+DISTFILES= ${PORTNAME}${DISTVERSION}.py \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= python
+EXTRACT_ONLY=
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Steer your ship(s) with the keyboard
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYGAME}
+
+USE_PYTHON= 2.7
+NO_BUILD= yes
+
+SUB_FILES= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.py
+PLIST_DIRS= %%DATADIR%%
+
+DESKTOP_ENTRIES="Schiff" "" ${PORTNAME} \
+ "${PORTNAME}" "Game;LogicGame;" ""
+
+do-install:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${_DISTDIR}/schiff${PORTVERSION}.py \
+ ${STAGEDIR}${DATADIR}/${PORTNAME}.py
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/games/schiff/distinfo b/games/schiff/distinfo
new file mode 100644
index 00000000000..d90b305cd45
--- /dev/null
+++ b/games/schiff/distinfo
@@ -0,0 +1,4 @@
+SHA256 (python/schiff16.py) = 85a350632ad28883a2752a817046381b1d00ec4b8c13026d0f30fa6504e17e00
+SIZE (python/schiff16.py) = 56221
+SHA256 (python/schiff.png) = 8ad9550368f8ba47978f39da2431c92f9dcba19dd9ad6273df3a09323d425d98
+SIZE (python/schiff.png) = 3437
diff --git a/games/schiff/files/schiff.in b/games/schiff/files/schiff.in
new file mode 100644
index 00000000000..41652985791
--- /dev/null
+++ b/games/schiff/files/schiff.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec %%PYTHON_CMD%% ./schiff.py "${@}"
diff --git a/games/schiff/pkg-descr b/games/schiff/pkg-descr
new file mode 100644
index 00000000000..f45e03c7761
--- /dev/null
+++ b/games/schiff/pkg-descr
@@ -0,0 +1,6 @@
+Schiff is the German word for ship.
+Steer your ship(s) with the keyboard to rotate or move forward / backward.
+Try to avoid enemy bullets and the floating yellow rectangles.
+Become last ship floating to win the game.
+
+WWW: http://thepythongamebook.com/en:resources:games:schiff