aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
committeradamw <adamw@FreeBSD.org>2003-06-12 17:46:09 +0800
commitaaf166713559a44a8e20404e1e6eb14e1758a66b (patch)
tree001522fb512c55afb05368bed1bedb1a54f687a4 /games
parentbdac09a776abef8765f436443280f4aa3ba8ca0f (diff)
downloadfreebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.gz
freebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.tar.zst
freebsd-ports-graphics-aaf166713559a44a8e20404e1e6eb14e1758a66b.zip
Remove REINPLACE commands that were rolled into gnomehack.
Diffstat (limited to 'games')
-rw-r--r--games/atomix/Makefile4
-rw-r--r--games/bombermaze/Makefile4
-rw-r--r--games/gnome-games/Makefile2
-rw-r--r--games/gnomegames/Makefile2
-rw-r--r--games/gnomegames2/Makefile2
-rw-r--r--games/gnomoku/Makefile4
6 files changed, 0 insertions, 18 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index c48d33ad9b7..d65e6da742f 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -20,8 +20,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/games/bombermaze/Makefile b/games/bombermaze/Makefile
index 5ff36ccdc43..ac19436bc0f 100644
--- a/games/bombermaze/Makefile
+++ b/games/bombermaze/Makefile
@@ -24,8 +24,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS+= -fpermissive
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index d552b9d6051..48a9091f16c 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -30,8 +30,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/games/gnomegames/Makefile b/games/gnomegames/Makefile
index 31e29cd2ae1..e8306574f6b 100644
--- a/games/gnomegames/Makefile
+++ b/games/gnomegames/Makefile
@@ -30,8 +30,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
LIBS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc[.]h|stdlib.h|g'
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index d552b9d6051..48a9091f16c 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -30,8 +30,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "*.[ch]" | xargs ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/games/gnomoku/Makefile b/games/gnomoku/Makefile
index 1e527020c5e..bdf2a7e7d45 100644
--- a/games/gnomoku/Makefile
+++ b/games/gnomoku/Makefile
@@ -23,8 +23,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-fpermissive -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>