aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-06-14 02:32:04 +0800
committerpav <pav@FreeBSD.org>2009-06-14 02:32:04 +0800
commitc4c460063cc034778f80dccfe0213e18a0c70c35 (patch)
tree9f973861ee6e92e7d4f4fa7e7652bf7452f63b02 /games
parent8cf20ab4342fac69f9d2a751428dcbf567b25971 (diff)
downloadfreebsd-ports-graphics-c4c460063cc034778f80dccfe0213e18a0c70c35.tar.gz
freebsd-ports-graphics-c4c460063cc034778f80dccfe0213e18a0c70c35.tar.zst
freebsd-ports-graphics-c4c460063cc034778f80dccfe0213e18a0c70c35.zip
- Broken on 8.x
Reported by: pointyhat
Diffstat (limited to 'games')
-rw-r--r--games/tux-aqfh/Makefile8
-rw-r--r--games/tuxkart/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/games/tux-aqfh/Makefile b/games/tux-aqfh/Makefile
index 477de2a78e7..221ce0299ce 100644
--- a/games/tux-aqfh/Makefile
+++ b/games/tux-aqfh/Makefile
@@ -25,6 +25,12 @@ CONFIGURE_ARGS= --with-plib=${LOCALBASE}
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -lusbhid ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+BROKEN= does not compile: error: plib/js.h: No such file or directory
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lplibsl -lplibssg|-lplibsl -lplibjs -lplibssg|g ; \
@@ -35,4 +41,4 @@ post-patch:
's|$$(prefix)/games|@bindir@|g ; \
s|$$(datadir)/games|$$(datadir)|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/tuxkart/Makefile b/games/tuxkart/Makefile
index e107661c0bc..2101ac734f4 100644
--- a/games/tuxkart/Makefile
+++ b/games/tuxkart/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lusbhid"
CONFIGURE_ARGS= --with-plib=${LOCALBASE}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+BROKEN= does not compile: error: plib/js.h: No such file or directory
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O6|${PTHREAD_CFLAGS}|g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
@@ -31,4 +37,4 @@ post-patch:
's|[\$$][(]prefix[)]/games|@bindir@|g ; \
s|[\$$][(]datadir[)]/games|\$$(datadir)|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>