aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-08-27 05:33:19 +0800
committerjbeich <jbeich@FreeBSD.org>2015-08-27 05:33:19 +0800
commitd50f500e1d1217c2b47c196722a852ede1fd99dc (patch)
tree0710a3f53bc5ce6ff5f35adcf10b0f138eac582d /games
parenta5a79ac00790296a538bb962ddfad032e882e7bb (diff)
downloadfreebsd-ports-graphics-d50f500e1d1217c2b47c196722a852ede1fd99dc.tar.gz
freebsd-ports-graphics-d50f500e1d1217c2b47c196722a852ede1fd99dc.tar.zst
freebsd-ports-graphics-d50f500e1d1217c2b47c196722a852ede1fd99dc.zip
devel/ponscripter-sekai, games/openbor: add TREMOR option
TREMOR is enabled by default on platforms without hardware floating point.
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 26b258366ab..34fadccf0d0 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
PORTVERSION= 3.0.r4163
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= LOCAL/jbeich \
https://svn.code.sf.net/p/${PORTNAME}/engine/engine/:svn
@@ -12,8 +12,7 @@ COMMENT= Moddable fighting game engine (aka Beats of Rage)
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
- libpng.so:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libvpx.so:${PORTSDIR}/multimedia/libvpx
USES= dos2unix gmake pkgconfig tar:xz
@@ -36,12 +35,18 @@ DESKTOP_ENTRIES="OpenBOR" \
"Game;ArcadeGame;" \
""
+OPTIONS_DEFINE= TREMOR
+OPTIONS_DEFAULT= ${MACHINE_CPU:tu:MSOFTFP:S/SOFTFP/TREMOR/}
OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT_i386= MMX # runtime detection
MMX_BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm
MMX_MAKE_ARGS= BUILD_MMX=1
+TREMOR_LIB_DEPENDS= libvorbisidec.so:${PORTSDIR}/audio/libtremor
+TREMOR_MAKE_ARGS= BUILD_TREMOR=1 BUILD_VORBIS=""
+TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+
#
# To update snapshot: make makesum BOOTSTRAP=
# Specific snapshot: make makesum SVN_FETCH= PORTVERSION=1.0.r1234