aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/EZWGL
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /graphics/EZWGL
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-graphics-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'graphics/EZWGL')
-rw-r--r--graphics/EZWGL/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/graphics/EZWGL/Makefile b/graphics/EZWGL/Makefile
index c0e794c31a0..fcdfa22d90f 100644
--- a/graphics/EZWGL/Makefile
+++ b/graphics/EZWGL/Makefile
@@ -3,7 +3,7 @@
# Date created: 4 May 1998
# Whom: Andrey Zakhvatov
#
-# $Id: Makefile,v 1.10 1998/09/19 01:36:18 hoek Exp $
+# $Id: Makefile,v 1.11 1998/10/05 02:52:24 steve Exp $
#
DISTNAME= EZWGL-1.39
@@ -21,6 +21,14 @@ WRKSRC= ${WRKDIR}/${PKGNAME}
.include "files/manpages"
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 1
+.else
+VERSION= 1.3
+.endif
+
pre-install:
-@ ${RM} ${WRKSRC}/examples/Makefile.orig
-@ ${RM} ${WRKSRC}/examples/ExampleMsg
@@ -49,10 +57,4 @@ do-install:
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-VERSION= 1
-.else
-VERSION= 1.3
-.endif
+.include <bsd.port.post.mk>