aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-01-22 01:26:30 +0800
committermi <mi@FreeBSD.org>2002-01-22 01:26:30 +0800
commit8612205f2bf7f74753fd4b4b543f72e55d542b67 (patch)
treec7454d169d6021c8c9ce5b38cbd77fda370ed8e3 /graphics/ImageMagick
parente36e9ff58716e8830e17a9201a677523554b0eb7 (diff)
downloadfreebsd-ports-graphics-8612205f2bf7f74753fd4b4b543f72e55d542b67.tar.gz
freebsd-ports-graphics-8612205f2bf7f74753fd4b4b543f72e55d542b67.tar.zst
freebsd-ports-graphics-8612205f2bf7f74753fd4b4b543f72e55d542b67.zip
Remove major-number specifications from most of the entries in
LIB_DEPENDS. ImageMagick will compile with any version of -ljpeg, -ljbig, -lmpeg2, -lbz2, -lfpx, -lfreetype, -lxml2, -lpng, -llcms. I'm not sure about -ltiff (we had the old, incompatible version ported for a while as recently as a few years ago) and -lltdl (libtool). This should make this port more resilient to upgrades to the other ports and make it easier to build by people, who already have earlier versions of the other libraries installed. The idea -- of not requiring particular versions in some/most cases -- in general was discussed on -ports.
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index a9d332b98f3..588b17de9b0 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -31,16 +31,16 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
-LIB_DEPENDS= fpx.1:${PORTSDIR}/graphics/libfpx \
- jbig.1:${PORTSDIR}/graphics/jbigkit \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
- png.5:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= fpx:${PORTSDIR}/graphics/libfpx \
+ jbig:${PORTSDIR}/graphics/jbigkit \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ lcms:${PORTSDIR}/graphics/lcms \
+ png:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- freetype.8:${PORTSDIR}/print/freetype2 \
- xml2.5:${PORTSDIR}/textproc/libxml2
+ freetype:${PORTSDIR}/print/freetype2 \
+ xml2:${PORTSDIR}/textproc/libxml2
.if !exists(/usr/bin/bzip2)
-LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS+= bz2:${PORTSDIR}/archivers/bzip2
.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
@@ -100,7 +100,7 @@ RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu-nox11
CONFIGURE_ARGS+= --without-x --without-mpeg2 --without-wmf
PLIST_SUB+= X11='@comment '
.else
-LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/graphics/libmpeg2 \
+LIB_DEPENDS+= mpeg2:${PORTSDIR}/graphics/libmpeg2 \
wmf.2:${PORTSDIR}/graphics/libwmf
BUILD_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu