aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ImageMagick
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-05-29 23:59:57 +0800
committerkwm <kwm@FreeBSD.org>2015-05-29 23:59:57 +0800
commitc6341d138d7c6157dc35807088d64fcbf625977e (patch)
treeb27ff47f348f483bcec6c30527c47035952d5955 /graphics/ImageMagick
parent86eab2f80256985dbe9e4e17e035a89910d5824b (diff)
downloadfreebsd-ports-graphics-c6341d138d7c6157dc35807088d64fcbf625977e.tar.gz
freebsd-ports-graphics-c6341d138d7c6157dc35807088d64fcbf625977e.tar.zst
freebsd-ports-graphics-c6341d138d7c6157dc35807088d64fcbf625977e.zip
Update ImageMagick to 6.9.1-3.
Diffstat (limited to 'graphics/ImageMagick')
-rw-r--r--graphics/ImageMagick/Makefile6
-rw-r--r--graphics/ImageMagick/distinfo4
-rw-r--r--graphics/ImageMagick/files/extra-magick_locale.c98
-rw-r--r--graphics/ImageMagick/pkg-plist4
4 files changed, 6 insertions, 106 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 8719136dbb0..ebeb649c28a 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ImageMagick
-DISTVERSION= 6.9.1-2
+DISTVERSION= 6.9.1-3
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -379,10 +379,6 @@ INSTALL_TARGET= install-strip
USE_GHOSTSCRIPT_BUILD=yes
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-EXTRA_PATCHES+= ${FILESDIR}/extra-magick_locale.c
-.endif
-
post-patch:
# strip library name of variable parts that can change due to
# the HDRI and Q16 option
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index 384ccccf379..00f0d8cd6cd 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ImageMagick-6.9.1-2.tar.xz) = 5391aac3fedb7d627a89f06d195a1c3b422d2235aa6e0d0d26886b2e0a10a294
-SIZE (ImageMagick-6.9.1-2.tar.xz) = 7909464
+SHA256 (ImageMagick-6.9.1-3.tar.xz) = 5fd180603e60c624c05c644a8340f4f4e92c19dc3c41d374d38f76c69cd48ba3
+SIZE (ImageMagick-6.9.1-3.tar.xz) = 7965132
diff --git a/graphics/ImageMagick/files/extra-magick_locale.c b/graphics/ImageMagick/files/extra-magick_locale.c
deleted file mode 100644
index ba12452fbd6..00000000000
--- a/graphics/ImageMagick/files/extra-magick_locale.c
+++ /dev/null
@@ -1,98 +0,0 @@
---- magick/locale.c.orig 2015-04-14 23:09:38.000000000 +0200
-+++ magick/locale.c 2015-04-27 12:00:08.997474000 +0200
-@@ -66,6 +66,14 @@
- #define MaxRecursionDepth 200
-
- /*
-+ Typedef declarations.
-+*/
-+#if defined(__CYGWIN__)
-+typedef struct _locale_t
-+ *locale_t;
-+#endif
-+
-+/*
- Static declarations.
- */
- static const char
-@@ -86,7 +94,7 @@ static SemaphoreInfo
- static SplayTreeInfo
- *locale_cache = (SplayTreeInfo *) NULL;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- static volatile locale_t
- c_locale = (locale_t) NULL;
- #endif
-@@ -99,7 +107,7 @@ static MagickBooleanType
- LoadLocaleCache(SplayTreeInfo *,const char *,const char *,const char *,
- const size_t,ExceptionInfo *);
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- /*
- %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
- % %
-@@ -229,7 +237,7 @@ static SplayTreeInfo *AcquireLocaleSplay
- return(locale_cache);
- }
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- /*
- %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
- % %
-@@ -331,7 +339,7 @@ MagickExport ssize_t FormatLocaleFileLis
- ssize_t
- n;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VFPRINTF_L)
-+#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
- {
- locale_t
- locale;
-@@ -347,7 +355,7 @@ MagickExport ssize_t FormatLocaleFileLis
- #endif
- }
- #else
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
-+#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
- {
- locale_t
- locale,
-@@ -422,7 +430,7 @@ MagickExport ssize_t FormatLocaleStringL
- ssize_t
- n;
-
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_VSNPRINTF_L)
-+#if defined(MAGICKCORE_HAVE_VSNPRINTF_L)
- {
- locale_t
- locale;
-@@ -438,7 +446,7 @@ MagickExport ssize_t FormatLocaleStringL
- #endif
- }
- #elif defined(MAGICKCORE_HAVE_VSNPRINTF)
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_USELOCALE)
-+#if defined(MAGICKCORE_HAVE_USELOCALE) && defined(MAGICKCORE_HAVE_STRTOD_L)
- {
- locale_t
- locale,
-@@ -981,7 +989,7 @@ MagickExport double InterpretLocaleValue
- value=(double) strtoul(string,&q,16);
- else
- {
--#if defined(MAGICKCORE_HAVE_LOCALE_H) && defined(MAGICKCORE_HAVE_STRTOD_L)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- locale_t
- locale;
-
-@@ -1420,7 +1428,7 @@ MagickExport void LocaleComponentTerminu
- LockSemaphoreInfo(locale_semaphore);
- if (locale_cache != (SplayTreeInfo *) NULL)
- locale_cache=DestroySplayTree(locale_cache);
--#if defined(MAGICKCORE_HAVE_LOCALE_H)
-+#if defined(MAGICKCORE_HAVE_STRTOD_L)
- DestroyCLocale();
- #endif
- UnlockSemaphoreInfo(locale_semaphore);
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index d2240bbdf85..101e7f147b6 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -620,6 +620,9 @@ man/man1/stream.1.gz
%%PORTDOCS%%%%DOCSDIR%%-6/www/advanced-unix-installation.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/advanced-windows-installation.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/animate.html
+%%PORTDOCS%%%%DOCSDIR%%-6/www/css/bootstrap.min.css
+%%PORTDOCS%%%%DOCSDIR%%-6/www/css/magick.css
+%%PORTDOCS%%%%DOCSDIR%%-6/www/js/bootstrap.min.js
%%PORTDOCS%%%%DOCSDIR%%-6/www/openmp.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/webp.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/distribute-pixel-cache.html
@@ -1467,7 +1470,6 @@ man/man1/stream.1.gz
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/type-windows.xml
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/type.xml
%%PORTDOCS%%%%DOCSDIR%%-6/www/source/wand.c
-%%PORTDOCS%%%%DOCSDIR%%-6/www/sponsors.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/stream.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/subversion.html
%%PORTDOCS%%%%DOCSDIR%%-6/www/t-shirt.html
Update for a libxml2 change that was making this code g_warn a lotDan Winship2003-03-132-1/+6 * Alias gb-2312 to gb2312 also (since iconv doesn't have "gb-2312"). IJeffrey Stedfast2003-03-071-11/+49 * (e_request_string): Make the entry activate theEttore Perazzoli2003-03-072-0/+6 * Use gnome2 proxy settingsRodney Dawes2003-03-042-8/+12 * s/gnome-xml/libxml/Rodney Dawes2003-03-032-1/+5 * include gnome-pilot cflagsJP Rosevear2003-02-282-1/+5 * New internal function to parse the locale language code. (e_iconv_init):Jeffrey Stedfast2003-02-262-28/+107 * 'uid' should not be const.Jeffrey Stedfast2003-02-242-1/+6 * helper to get the dfault account. (e_account_list_set_default): helper toNot Zed2003-02-243-5/+197 * A result of 0 no longer indicates success; GTK_RESPONSE_OK does.Hans Petter Jansson2003-02-232-1/+6 * fix memleak - free uid.Chris Toshok2003-02-202-0/+6 * Fix for Solaris Bug "31081 Mailer sender/Subject/Date fields blank forSuresh Chandrasekharan2003-02-141-0/+2 * Instead of simply ignoring bad chars, return the sentinal invalid charNot Zed2003-02-112-5/+11 * (libeutil_static_la_DEPENDENCIES): MakeEttore Perazzoli2003-02-112-6/+18 * define in terms of privincludedir.Dan Winship2003-02-0613-17/+40 * Port to GtkDialog. Strdup the text returned by GtkEntry after destroyingEttore Perazzoli2003-01-283-24/+43 * ref/sink the pilot settings to clear up that gtk warning.Chris Toshok2003-01-272-1/+10 * g_file_exists -> g_file_test. (e_pilot_map_write): don't use doc->root.Chris Toshok2003-01-262-7/+10 * GObjectify this.Chris Toshok2003-01-263-34/+35 * Enable getting the categories master list from wombat.Hans Petter Jansson2003-01-252-5/+9 * Version using $(BASE_VERSION). (econdincludedir): Likewise.Ettore Perazzoli2003-01-233-6/+16 * Changed signal names to use - instead of _ like the rest of Gtk2.Jeffrey Stedfast2003-01-184-3/+80 * New, sort of from evolution-recurid-branch.Dan Winship2003-01-184-0/+310 * New class, based on MailConfigAccount, for describing an evolution (mail)Dan Winship2003-01-179-4/+990 * Back to the land of the living we shall go.Jeffrey Stedfast2003-01-162-4/+65 * Do not #include <e-bonobo-widget.h>. (e_set_dialog_parent): Remove theEttore Perazzoli2003-01-152-6/+13 * (eutilinclude_HEADERS): Add e-dialog-utils.h.Ettore Perazzoli2003-01-152-0/+5 * change this to use GtkImage instead of GnomeCanvas.Chris Toshok2003-01-102-29/+16 * Images are now in $(datadir)/evolution/imagesEttore Perazzoli2003-01-092-1/+6 * New.Dan Winship2003-01-074-3/+37 * Add this back: Connector needs it, and there's no reason for addressbookDan Winship2003-01-074-0/+457 * A bunch of fixes to make e-util build with -DG_DISABLE_DEPRECATED andJeffrey Stedfast2003-01-038-234/+205 * (e_signal_connect_full_while_alive): Get toEttore Perazzoli2003-01-032-3/+9 * (e_signal_connect_while_alive): New.Ettore Perazzoli2002-12-203-25/+55 * Removed. Back to the fiery depths of hell from whence ye came!Jeffrey Stedfast2002-12-174-450/+7 * new function.Rodrigo Moya2002-12-113-0/+27 * fix parameter list for e_trie_searchChris Toshok2002-12-101-1/+1 * oops, forgot to add the pattern_id arg to e_trie_addJeffrey Stedfast2002-12-101-1/+1 * EMemChunk, duhJeffrey Stedfast2002-12-101-2/+2 * s/E_MemChunk/EMemChunk/Jeffrey Stedfast2002-12-101-2/+2 * New implementation of an Aho-Corasick trie.Jeffrey Stedfast2002-12-104-0/+397 * track changes to api (e_passwords_init is gone, and several functions takeChris Toshok2002-12-103-30/+66 * Allow an e-mutex to be used with standard condition variables.Not Zed2002-12-093-0/+26 * change to a more gconf-like path (with underscores, etc.) (ecmlw_save):Chris Toshok2002-12-072-2/+8 * Add a "collate" sort callback that uses the new g_collate_compare().Jeffrey Stedfast2002-12-062-9/+24 * If the language is something like "fr_FR", return both "fr_FR" and "fr" inDan Winship2002-11-272-4/+21 * Added an optional nspr pipe field. (e_msgport_new): Init nspr pipe toNot Zed2002-11-233-14/+128 * fix c&p typo.Chris Toshok2002-11-174-17/+13 * add lots of marshallers (most, if not all, for etable).Chris Toshok2002-11-176-96/+82 * deal with EBitArray/ESorter being a GObject now.Chris Toshok2002-11-156-91/+53 * add more marshallers for e-table.Chris Toshok2002-11-141-0/+4 * (e_config_listener_get_string_with_default):Ettore Perazzoli2002-11-142-5/+11 * add e-password.h (libeutil_la_SOURCES): add e-password.cChris Toshok2002-11-134-96/+68 * (add_key): g_strdup() the value in the caseEttore Perazzoli2002-11-122-1/+6 * Re-add e-proxy.c to the build.Jeffrey Stedfast2002-11-112-1/+6 * add e-categories-config.h and e-categories-master-list-wombat.hChris Toshok2002-11-094-85/+66 * fix a comment (e_localtime_with_offset returns the offset in secondsDan Winship2002-11-081-1/+1 * pass extra pixbuf paramJP Rosevear2002-11-085-7/+21 * init err to NULL so if there isn't an error we aren't left with anChris Toshok2002-11-062-4/+13 * ported to GObject.Rodrigo Moya2002-11-054-50/+55 * new simpler functions, without a default value.Rodrigo Moya2002-11-043-0/+35 * Removed unused variable. (e_config_listener_get_long_with_default):Ettore Perazzoli2002-11-043-4/+11 * add marshal building stuff, add e-util-marshal.c to SOURCES, and addChris Toshok2002-11-0310-124/+167 * First big sync of my GNOME 2 porting work (incomplete, and stillEttore Perazzoli2002-11-0214-35/+54 * ported to GConf and GObject.Rodrigo Moya2002-11-024-184/+175 * compilation fixes for GNOME 2 porting.Rodrigo Moya2002-11-023-7/+10 * (E_MAKE_X_TYPE): Update for libbonobo 2.0.Ettore Perazzoli2002-11-021-20/+25 * merging the gal-2 branch back to the trunk.Mike Kestner2002-11-0112-1087/+145 * Fixes #32764Rodrigo Moya2002-10-252-27/+50 * Cast chars to unsigned char before passing to ctype macros since they areDan Winship2002-10-252-17/+24 * [ Fixes evolution bug #26355 ] use g_utf8_collate here instead of strcmp.Chris Toshok2002-10-211-2/+3 * new helper function, g_strdown with forced C locale (e_iconv_init): useRadek Doulik2002-09-271-4/+21 * added a comment about the fix for #30918.Rodrigo Moya2002-09-262-0/+7 * gtk_object_ref the component listener before emitting the "component_died"Rodrigo Moya2002-09-232-0/+10 * Fix some non-ANSI switch statementsDan Winship2002-09-233-0/+9 * Make locale_charset a char *, not const char *. Kills a warning in theDan Winship2002-09-202-2/+3 * apply patch for 27447 from Matt Avery for a bug in the solaris iconvMike Kestner2002-09-181-2/+3 * [ Fixes #27546 ] add "di" to e_name_western_complex_last_table.Chris Toshok2002-09-122-1/+8 * update the local copy (if we've got one) so that we don't return values ifRodrigo Moya2002-09-052-0/+34 * New. Like mktime(3), but assumes the input time is UTC.Dan Winship2002-09-053-5/+68 * Don't call g_list_foreach with the free func if the free func is NULL.Dan Winship2002-08-302-1/+7 * Convert file: urls too. Fixes bug #29557.Jeffrey Stedfast2002-08-292-1/+5 * New convenience function to initialise the proxy settings for soup to use.Jeffrey Stedfast2002-08-295-0/+142 * new functions. (property_change_cb, add_key): added support for FLOATRodrigo Moya2002-08-273-2/+110 * If gdk_window_foreign_new returned NULL, we're probably screwed, but tryPeter Williams2002-08-272-0/+15 * call g_strdup in the correct place, or we'll return the internal copy.Rodrigo Moya2002-08-272-2/+7 * only set the key if the value is different from what we've already readRodrigo Moya2002-08-262-0/+18 * added "key_changed" signal to class. (property_change_cb): emitRodrigo Moya2002-08-233-34/+156 * Remove an e_path directory, and its parent "subfolders" dir if it's nowDan Winship2002-08-233-0/+54 * Add bug fix number.JP Rosevear2002-08-221-0/+2 * if the year was two digits, add the current centuryJP Rosevear2002-08-222-1/+25 * new class for config database access and monitoring.Rodrigo Moya2002-08-204-0/+375 * new class for controlling a component, to detect when it dies.Rodrigo Moya2002-08-164-0/+284 * Do slightly better error handling for close() and loop until it closesJeffrey Stedfast2002-08-081-3/+4 * Changed to handle saving to a temp file first, this allows us to remove aJeffrey Stedfast2002-08-071-3/+26 * Bumped version to 0.19.99.18Jeffrey Stedfast2002-08-072-1/+312 * Remove the logic that assumes "Rupert> " is a citation, since it misfiresDan Winship2002-08-052-28/+22 * Don't use "isprint(c)" to mean "c >= 32 && c < 128" since it doesn't inDan Winship2002-08-012-13/+24 * If the user has enabled IPv6 support, use getaddrinfo to resolve hostnamesJeffrey Stedfast2002-07-312-9/+183 * Return the actual count, rather than always 0!Not Zed2002-07-252-1/+6 * Install libversit.a so that people compiling against the addressbook canPeter Williams2002-07-182-37/+54 * Cast to a string type. (term_eval_castint): Cast to an int type.Not Zed2002-07-163-3/+83 * #include <string.h>Dan Winship2002-07-102-0/+5 * *** empty log message ***Rodrigo Moya2002-07-031-1/+1 * Ă‘changed to return a gboolean (TRUE if the icon is found, FALSE if not).Rodrigo Moya2002-07-033-7/+14 * Use connect_while_alive, so we're not called after we've quit. See bugNot Zed2002-06-172-4/+10 * Protect against EINTR (irix?), see bug #24086.Not Zed2002-06-032-4/+12 * New.Ettore Perazzoli2002-05-073-1/+12 * Destroy our mutex too. (e_thread_new): Add thread to a new list of allNot Zed2002-05-063-0/+55 * Documented this function as not necessarily stripping shellChristopher James Lahey2002-05-022-0/+2 * Set the gettext-domain here.Christopher James Lahey2002-05-021-0/+6 * Added a sed job on po/Makefile.in.in here.Christopher James Lahey2002-04-301-1/+5 * Changed this to handle large numbers. (e_create_directory): Changed thisChristopher James Lahey2002-04-301-65/+111 * Use DBL_DIG to compute how much buffer space to use here.Christopher James Lahey2002-04-272-3/+8 * Ansification patch from danw.Christopher James Lahey2002-04-264-11/+11 * Don't leak the base64 encoded password buffer.Jeffrey Stedfast2002-04-202-11/+19 * New wrapper around gethostbyaddr_r if the system has it, else a whole newJeffrey Stedfast2002-04-173-79/+150 * Handle parsing negative integers.Jeffrey Stedfast2002-04-122-7/+23 * #include <parser.h> and <xmlmemory.h> instead of <gnome-xml/parser.h> andEttore Perazzoli2002-04-111-2/+4 * open a file selection dialog with the given title and return the selectedJP Rosevear2002-03-303-0/+70 * Use iconv-detect.c to generate a iconv-detect.h file containingJeffrey Stedfast2002-03-301-13/+33 * Added widgets/e-option-menu.lo.Christopher James Lahey2002-03-262-0/+61 * New. New.Ettore Perazzoli2002-03-234-0/+96 * Document the fact that this takes two locale charset strings and one UTF8Dan Winship2002-03-222-7/+13 * Replaced e_marshal_BOOL__STRING with this since the function it was usedChristopher James Lahey2002-03-132-11/+15 * Added e-table-search.lo.Christopher James Lahey2002-03-122-0/+25 * #include <string.h> for strcmp.Jeffrey Stedfast2002-03-052-2/+9 * Fix for if the buffer ends with an email address (and no newline).Dan Winship2002-02-232-0/+7 * New signal for when the width of the column changes.Christopher James Lahey2002-02-132-0/+22 * add row and column definesJP Rosevear2002-02-09