aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/Mesa3/Makefile
diff options
context:
space:
mode:
authorjseger <jseger@FreeBSD.org>1997-11-01 21:46:11 +0800
committerjseger <jseger@FreeBSD.org>1997-11-01 21:46:11 +0800
commit5a7ffb5a3385505c1bff7b81c89dd5ed4f59b4ca (patch)
treeddd5b6c72e93690a4faa29701a0255e81e4840a7 /graphics/Mesa3/Makefile
parent776ed78a372d073648e2e1a06e92c30e0169547d (diff)
downloadfreebsd-ports-graphics-5a7ffb5a3385505c1bff7b81c89dd5ed4f59b4ca.tar.gz
freebsd-ports-graphics-5a7ffb5a3385505c1bff7b81c89dd5ed4f59b4ca.tar.zst
freebsd-ports-graphics-5a7ffb5a3385505c1bff7b81c89dd5ed4f59b4ca.zip
Update from Mesa-2.2 to Mesa-2.4. No longer include the demos because they are
in a separate package now. Make myself MAINTAINER.
Diffstat (limited to 'graphics/Mesa3/Makefile')
-rw-r--r--graphics/Mesa3/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index b3d948be855..9c8330df842 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -1,21 +1,23 @@
# New ports collection makefile for: Mesa
-# Version required: 2.2
+# Version required: 2.4
# Date created: Tue Feb 7 12:02:49 1995
# Whom: hsu
#
-# $Id: Makefile,v 1.18 1997/09/30 19:20:00 max Exp $
+# $Id: Makefile,v 1.19 1997/09/30 19:21:40 max Exp $
#
-DISTNAME= Mesa-2.2
+DISTNAME= MesaLib-2.4
+PKGNAME= Mesa-2.4
CATEGORIES= graphics
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= jseger@FreeBSD.ORG
+WRKSRC= ${WRKDIR}/${PKGNAME}
ALL_TARGET= freebsd
USE_X11= yes
-LIBS= libMesaGL libMesaGLU libMesaaux libMesatk
-SHLIB_VERSION= 13.2
+LIBS= libMesaGL libMesaGLU
+SHLIB_VERSION= 13.4
do-install:
.for file in ${LIBS}
@@ -29,12 +31,6 @@ do-install:
.endfor
@${MKDIR} ${PREFIX}/include/GL
${INSTALL_DATA} ${WRKSRC}/include/GL/* ${PREFIX}/include/GL
- @${MKDIR} ${PREFIX}/share/examples/Mesa
- ${CP} -Rp ${WRKSRC}/samples ${PREFIX}/share/examples/Mesa
- ${CP} -Rp ${WRKSRC}/demos ${PREFIX}/share/examples/Mesa
- ${CP} -Rp ${WRKSRC}/book ${PREFIX}/share/examples/Mesa
- ${CP} -Rp ${WRKSRC}/widgets-sgi ${PREFIX}/share/examples/Mesa
- @${RM} -f ${PREFIX}/share/examples/Mesa/widgets-sgi/Makefile~
${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>