aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/Mesa3/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1998-03-10 17:26:11 +0800
committertg <tg@FreeBSD.org>1998-03-10 17:26:11 +0800
commit90e0f056524090989483714f66a928256ee70673 (patch)
treee4d368ff3319dee664690d2a036c394f9b23ebc5 /graphics/Mesa3/Makefile
parent77fbccabbf472efac62db85286f05c5ffb96e09e (diff)
downloadfreebsd-ports-graphics-90e0f056524090989483714f66a928256ee70673.tar.gz
freebsd-ports-graphics-90e0f056524090989483714f66a928256ee70673.tar.zst
freebsd-ports-graphics-90e0f056524090989483714f66a928256ee70673.zip
Build and install Mesaaux and Mesatk libs.
PR: 5919 Submitted by: Donald Burr <dburr@POBoxes.com>
Diffstat (limited to 'graphics/Mesa3/Makefile')
-rw-r--r--graphics/Mesa3/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index 8ad6323055b..b5633b5148c 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -3,21 +3,22 @@
# Date created: Tue Feb 7 12:02:49 1995
# Whom: hsu
#
-# $Id: Makefile,v 1.21 1997/11/22 02:05:20 jseger Exp $
+# $Id: Makefile,v 1.22 1998/02/15 17:13:13 jseger Exp $
#
DISTNAME= MesaLib-2.6
PKGNAME= Mesa-2.6
CATEGORIES= graphics
MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} MesaDemos-2.6.tar.gz
MAINTAINER= jseger@FreeBSD.ORG
WRKSRC= ${WRKDIR}/${PKGNAME}
-ALL_TARGET= freebsd
+ALL_TARGET= freebsd-386
USE_X11= yes
-LIBS= libMesaGL libMesaGLU
+LIBS= libMesaGL libMesaGLU libMesaaux libMesatk
SHLIB_VERSION= 13.6
do-install:
@@ -33,6 +34,8 @@ do-install:
.endfor
@${MKDIR} ${PREFIX}/include/GL
${INSTALL_DATA} ${WRKSRC}/include/GL/* ${PREFIX}/include/GL
+ ${INSTALL_DATA} ${WRKSRC}/include/glaux.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/include/gltk.h ${PREFIX}/include
${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>