aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/eog2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-08 06:24:32 +0800
committermarcus <marcus@FreeBSD.org>2004-11-08 06:24:32 +0800
commitfb8541d2d8cfc686242832e1c242a6e16a71f562 (patch)
treeeb4a9f17e9018ff5a01b23a7dcb55603930cc5cf /graphics/eog2
parent9d873617ccf0d009f3c169794dbfcb0741259b2e (diff)
downloadfreebsd-ports-graphics-fb8541d2d8cfc686242832e1c242a6e16a71f562.tar.gz
freebsd-ports-graphics-fb8541d2d8cfc686242832e1c242a6e16a71f562.tar.zst
freebsd-ports-graphics-fb8541d2d8cfc686242832e1c242a6e16a71f562.zip
Presenting GNOME 2.8 for FreeBSD (2.8.1 to be exact).
This release notes detailing all of the new goodies in GNOME 2.8 can be found at http://www.gnome.org/start/2.8/notes/, and the list of what was fixed in GNOME 2.8.1 can be found at http://lists.gnome.org/archives/gnome-announce-list/2004-October/msg00056.html. This release, as well as all of our others, would not have been possible without the great efforts of our FreeBSD GNOME Team. The list of current members can be found at http://www.freebsd.org/gnome/contact.html (including our newest member, Michael Johnson <ahze@FreeBSD.org>). Special thanks also goes out to all of the loyal FreeBSD GNOME users that put up with crashes and hangs to test and debug GNOME on FreeBSD. We would especially like to thank those users that provided patches for GNOME 2.7 and 2.8: Franz Klammer <klammer@webonaut.com> Piotr Smyrak <piotr.smyrak@heron.pl> Radek Kozlowski <radek@raadradd.com> Khairil Yusof <kaeru@pd.jaring.my> Yasuda Keisuke <kysd@po.harenet.ne.jp> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Vladimir Grebenschikov <vova@fbsd.ru> GNOME 2.8 also features a new, FreeBSD-specific splashscreen that was designed by jimmac for GNOME 2.8, then daemonized by Franz Klammer <klammer@webonaut.com> and Radek Kozlowski <radek@raadradd.com>. As with GNOME 2.6, you cannot just "portupgrade" to GNOME 2.8. There is a script provided at http://www.marcuscom.com/downloads/gnome_upgrade28.sh that will aid in the upgrade process. Full documentation on the GNOME 2.8 upgrade is coming following this commit. From all of us at FreeBSD GNOME, ENJOY!
Diffstat (limited to 'graphics/eog2')
-rw-r--r--graphics/eog2/Makefile14
-rw-r--r--graphics/eog2/distinfo4
-rw-r--r--graphics/eog2/files/patch-libeog_eog-info-view.c24
-rw-r--r--graphics/eog2/pkg-plist26
4 files changed, 22 insertions, 46 deletions
diff --git a/graphics/eog2/Makefile b/graphics/eog2/Makefile
index 66f1946d638..31c161e719a 100644
--- a/graphics/eog2/Makefile
+++ b/graphics/eog2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= eog2
-PORTVERSION= 2.6.1
-PORTREVISION= 4
+PORTVERSION= 2.8.1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.6
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
DISTNAME= eog-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,16 +20,21 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier intlhack eel2 libgnomeprintui \
- librsvg2
+ librsvg2 desktopfileutils
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+GCONF_SCHEMAS= eog.schemas
+
.include <bsd.port.pre.mk>
.if defined(WITH_EXIF) || exists(${LOCALBASE}/lib/libexif.so.10)
LIB_DEPENDS+= exif.10:${PORTSDIR}/graphics/libexif
.endif
+post-install:
+ @-update-desktop-database > /dev/null
+
.include <bsd.port.post.mk>
diff --git a/graphics/eog2/distinfo b/graphics/eog2/distinfo
index 6e4800d6ec5..df37f92b689 100644
--- a/graphics/eog2/distinfo
+++ b/graphics/eog2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/eog-2.6.1.tar.bz2) = a7207082b9034e9e24ec7adde744c3a9
-SIZE (gnome2/eog-2.6.1.tar.bz2) = 863021
+MD5 (gnome2/eog-2.8.1.tar.bz2) = 2bad4006f3ccf15b0153d7b9facbc961
+SIZE (gnome2/eog-2.8.1.tar.bz2) = 834279
diff --git a/graphics/eog2/files/patch-libeog_eog-info-view.c b/graphics/eog2/files/patch-libeog_eog-info-view.c
deleted file mode 100644
index a9050fa7ccc..00000000000
--- a/graphics/eog2/files/patch-libeog_eog-info-view.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- libeog/eog-info-view.c.orig Wed Oct 13 16:42:12 2004
-+++ libeog/eog-info-view.c Wed Oct 13 16:43:41 2004
-@@ -246,6 +246,7 @@
- EogInfoView *view;
- EogInfoViewPrivate *priv;
- char *path;
-+ char entryval[4096];
-
- view = EOG_INFO_VIEW (data);
- priv = view->priv;
-@@ -255,11 +256,11 @@
- path = g_hash_table_lookup (priv->id_path_hash, GINT_TO_POINTER (entry->tag));
-
- if (path != NULL) {
-- set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
-+ set_row_data (store, path, exif_tag_get_name (entry->tag), exif_entry_get_value (entry, entryval, sizeof(entryval)));
- }
- else {
- path = set_row_data (store, NULL,
-- exif_tag_get_name (entry->tag), exif_entry_get_value (entry));
-+ exif_tag_get_name (entry->tag), exif_entry_get_value (entry, entryval, sizeof(entryval)));
-
- g_hash_table_insert (priv->id_path_hash,
- GINT_TO_POINTER (entry->tag),
diff --git a/graphics/eog2/pkg-plist b/graphics/eog2/pkg-plist
index 0791bc90ec9..8965a0bbc56 100644
--- a/graphics/eog2/pkg-plist
+++ b/graphics/eog2/pkg-plist
@@ -1,19 +1,10 @@
bin/eog
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/eog.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/eog.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/eog.schemas > /dev/null || /usr/bin/true
-libdata/bonobo/servers/GNOME_EOG.server
-libdata/bonobo/servers/GNOME_EOG_Collection.server
-libexec/eog-collection-view
-libexec/eog-image-viewer
share/gnome/applications/eog.desktop
+@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/eog/glade/eog.glade
-share/gnome/eog/gpi-dialog.glade
-share/gnome/gnome-2.0/ui/eog-collection-view-ui.xml
-share/gnome/gnome-2.0/ui/eog-image-view-ctrl-ui.xml
-share/gnome/gnome-2.0/ui/eog-image-view-ui.xml
-share/gnome/gnome-2.0/ui/eog-shell-ui.xml
+share/gnome/gnome-2.0/ui/eog-gtk-ui.xml
share/gnome/help/eog/C/eog.xml
+share/gnome/help/eog/C/figures/eog_save_as_window.png
share/gnome/help/eog/C/figures/eog_start_window.png
share/gnome/help/eog/C/legal.xml
share/gnome/help/eog/de/eog.xml
@@ -46,7 +37,6 @@ share/gnome/help/eog/zh_CN/legal.xml
share/gnome/help/eog/zh_TW/eog.xml
share/gnome/help/eog/zh_TW/figures/eog_start_window.png
share/gnome/help/eog/zh_TW/legal.xml
-share/gnome/idl/Eog.idl
share/gnome/omf/eog/eog-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/eog/eog-C.omf 2>/dev/null || /usr/bin/true
share/gnome/omf/eog/eog-de.omf
@@ -74,6 +64,8 @@ share/gnome/pixmaps/eog/loading.png
share/gnome/pixmaps/eog/orient-horizontal.png
share/gnome/pixmaps/eog/orient-vertical.png
share/gnome/pixmaps/eog/right-down.png
+share/gnome/pixmaps/eog/stock-flip-horizontal-16.png
+share/gnome/pixmaps/eog/stock-flip-vertical-16.png
share/gnome/pixmaps/eog/stock-rotate-90-16.png
share/gnome/pixmaps/eog/stock-rotate-270-16.png
share/gnome/pixmaps/eog/stock-rotate-180-16.png
@@ -85,6 +77,7 @@ share/locale/az/LC_MESSAGES/eog.mo
share/locale/be/LC_MESSAGES/eog.mo
share/locale/bg/LC_MESSAGES/eog.mo
share/locale/bn/LC_MESSAGES/eog.mo
+share/locale/bs/LC_MESSAGES/eog.mo
share/locale/ca/LC_MESSAGES/eog.mo
share/locale/cs/LC_MESSAGES/eog.mo
share/locale/cy/LC_MESSAGES/eog.mo
@@ -118,9 +111,12 @@ share/locale/mk/LC_MESSAGES/eog.mo
share/locale/ml/LC_MESSAGES/eog.mo
share/locale/mn/LC_MESSAGES/eog.mo
share/locale/ms/LC_MESSAGES/eog.mo
+share/locale/nb/LC_MESSAGES/eog.mo
+share/locale/ne/LC_MESSAGES/eog.mo
share/locale/nl/LC_MESSAGES/eog.mo
share/locale/nn/LC_MESSAGES/eog.mo
share/locale/no/LC_MESSAGES/eog.mo
+share/locale/or/LC_MESSAGES/eog.mo
share/locale/pa/LC_MESSAGES/eog.mo
share/locale/pl/LC_MESSAGES/eog.mo
share/locale/pt/LC_MESSAGES/eog.mo
@@ -135,13 +131,13 @@ share/locale/sr@Latn/LC_MESSAGES/eog.mo
share/locale/sv/LC_MESSAGES/eog.mo
share/locale/ta/LC_MESSAGES/eog.mo
share/locale/th/LC_MESSAGES/eog.mo
+share/locale/tk/LC_MESSAGES/eog.mo
share/locale/tr/LC_MESSAGES/eog.mo
share/locale/uk/LC_MESSAGES/eog.mo
share/locale/vi/LC_MESSAGES/eog.mo
share/locale/wa/LC_MESSAGES/eog.mo
share/locale/zh_CN/LC_MESSAGES/eog.mo
share/locale/zh_TW/LC_MESSAGES/eog.mo
-@dirrm share/gnome/pixmaps/eog
@dirrm share/gnome/omf/eog
@dirrm share/gnome/help/eog/zh_TW/figures
@dirrm share/gnome/help/eog/zh_TW
@@ -165,7 +161,6 @@ share/locale/zh_TW/LC_MESSAGES/eog.mo
@dirrm share/gnome/help/eog/de
@dirrm share/gnome/help/eog/C/figures
@dirrm share/gnome/help/eog/C
-@dirrm share/gnome/help/eog
@dirrm share/gnome/eog/glade
@dirrm share/gnome/eog
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/eog/eog-C.omf 2>/dev/null || /usr/bin/true
@@ -179,3 +174,4 @@ share/locale/zh_TW/LC_MESSAGES/eog.mo
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/eog/eog-sv.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/eog/eog-zh_CN.omf 2>/dev/null || /usr/bin/true
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/eog/eog-zh_TW.omf 2>/dev/null || /usr/bin/true
+@unexec update-desktop-database > /dev/null || /usr/bin/true