aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gephex
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-12-05 05:37:05 +0800
committerrafan <rafan@FreeBSD.org>2006-12-05 05:37:05 +0800
commitaefc96b4ec4d838e0db692f088fa0feaaf95edb1 (patch)
tree467b92050ce6c99580e61d1e1991de878ce82be1 /graphics/gephex
parente84e4460980a025d17f6787bd2b71da6a450ac96 (diff)
downloadfreebsd-ports-graphics-aefc96b4ec4d838e0db692f088fa0feaaf95edb1.tar.gz
freebsd-ports-graphics-aefc96b4ec4d838e0db692f088fa0feaaf95edb1.tar.zst
freebsd-ports-graphics-aefc96b4ec4d838e0db692f088fa0feaaf95edb1.zip
- Respect X11BASE for Qt
- Define USE_XLIB since it is used Reported by: pointyhat
Diffstat (limited to 'graphics/gephex')
-rw-r--r--graphics/gephex/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/gephex/Makefile b/graphics/gephex/Makefile
index 60a544fd02c..58fe8e82919 100644
--- a/graphics/gephex/Makefile
+++ b/graphics/gephex/Makefile
@@ -24,8 +24,12 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-V4L --without-ASOUNDLIB --without-LINUX_JOYSTICK \
--without-FFMPEG --without-AVIFILE --without-MPEG3 \
--without-LIBPNG --without-SDL --without-SDL_IMAGE \
- --without-SDL_TTF --without-AALIB --disable-static
+ --without-SDL_TTF --without-AALIB --disable-static \
+ --with-qt-libdir="${X11BASE}/lib" \
+ --with-qt-incdir="${X11BASE}/include" \
+ --with-qt-bindir="${X11BASE}/bin"
USE_QT_VER= 3
+USE_XLIB= yes
WANT_SDL= yes
USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/${PORTNAME}-${PORTVERSION:R}