aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gmt/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-02-03 16:42:41 +0800
committeredwin <edwin@FreeBSD.org>2003-02-03 16:42:41 +0800
commit09be3652c70a619fcdf129ae38ebc9fdd3038abf (patch)
tree453c64baaa2c60191debf8c81f59feffe940cfe2 /graphics/gmt/Makefile
parent029f2d362ed04ff59a8cb4c1050c516c43b41de8 (diff)
downloadfreebsd-ports-graphics-09be3652c70a619fcdf129ae38ebc9fdd3038abf.tar.gz
freebsd-ports-graphics-09be3652c70a619fcdf129ae38ebc9fdd3038abf.tar.zst
freebsd-ports-graphics-09be3652c70a619fcdf129ae38ebc9fdd3038abf.zip
New port: graphics/gmt
The Generic Mapping Tools data processing and display software package. PR: ports/37972 Submitted by: Stefan `Sec` Zehl <sec@ice.42.org>
Diffstat (limited to 'graphics/gmt/Makefile')
-rw-r--r--graphics/gmt/Makefile91
1 files changed, 91 insertions, 0 deletions
diff --git a/graphics/gmt/Makefile b/graphics/gmt/Makefile
new file mode 100644
index 00000000000..7b59e4aa697
--- /dev/null
+++ b/graphics/gmt/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: gmt
+# Date created: 10 May 2001
+# Whom: sec@42.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmt
+PORTVERSION= 3.4.1
+CATEGORIES= graphics
+MASTER_SITES= ftp://gmt.soest.hawaii.edu/pub/gmt/ \
+ ftp://falcon.grdl.noaa.gov/pub/gmt/ \
+ ftp://ftp.iag.usp.br/pub/gmt/ \
+ ftp://ftp.geologi.uio.no/pub/gmt/ \
+ ftp://life.csu.edu.au/pub/gmt/ \
+ ftp://ftp.eos.hokudai.ac.jp/pub/gmt/
+DISTNAME= GMT${PORTVERSION}
+DISTFILES= ${EXTRACT_ONLY} ${EXTRACT_SUB}
+DIST_SUBDIR= gmt
+EXTRACT_ONLY= ${DISTNAME}_progs${EXTRACT_SUFX} \
+ ${DISTNAME}_man${EXTRACT_SUFX}
+
+MAINTAINER= sec@42.org
+
+LIB_DEPENDS= netcdf.1:${PORTSDIR}/math/netcdf
+
+EXTRACT_SUB= GMT_share${EXTRACT_SUFX}
+
+USE_BZIP2= YES
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}/${PORTNAME} \
+ --enable-wrapbin=${PREFIX}/bin \
+ --enable-wrapman=${PREFIX}/man \
+ --enable-shared
+MAKE_ENV+= NETCDFHOME=${LOCALBASE}
+INSTALL_TARGET= install install-data install-man install-wrapper
+
+post-extract:
+ @for file in ${EXTRACT_SUB}; do \
+ if ! (cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
+ then \
+ exit 1; \
+ fi \
+ done
+
+.ifdef(WITH_EVERYTHING)
+WITH_COAST_HIGH=YES
+WITH_COAST_FULL=YES
+WITH_FAST_TRIANGLE=YES
+WITH_SUPPL=YES
+.endif
+
+# High-rez coastlines (8M):
+.ifdef(WITH_COAST_HIGH)
+EXTRACT_SUB+= GMT_high${EXTRACT_SUFX}
+PLIST_SUB+= COAST_HIGH=""
+.else
+PLIST_SUB+= COAST_HIGH="@comment "
+.endif
+
+# Full-rez coastlines (28M):
+.ifdef(WITH_COAST_FULL)
+EXTRACT_SUB+= GMT_full${EXTRACT_SUFX}
+PLIST_SUB+= COAST_FULL=""
+.else
+PLIST_SUB+= COAST_FULL="@comment "
+.endif
+
+# Jonathan Shewchuck's Delauney triangulation routines (non-GPL)
+.ifdef(WITH_FAST_TRIANGLE)
+EXTRACT_SUB+= triangle${EXTRACT_SUFX}
+RESTRICTED= No commercial use
+RESTRICTED_FILES= triangle${EXTRACT_SUFX}
+CONFIGURE_ARGS+= --enable-triangle
+.endif
+
+WITH_SUPPL?= YES
+# Supplemental programs which use GMT
+.if defined(WITH_SUPPL) && ${WITH_SUPPL} != "NO"
+EXTRACT_ONLY+= ${DISTNAME}_suppl${EXTRACT_SUFX}
+INSTALL_TARGET+= install-suppl
+PLIST_SUB+= SUPPL=""
+post-configure:
+ ${TOUCH} ${WRKSRC}/src/mex/.skip
+.else
+PLIST_SUB+= SUPPL="@comment "
+.endif
+
+MANL= GMT.l
+
+.include <bsd.port.mk>