aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/hpoj/files
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-06-01 16:06:38 +0800
committerobraun <obraun@FreeBSD.org>2003-06-01 16:06:38 +0800
commit76087c33f15151945ead5ed84017ee2ac9a04ed8 (patch)
treed99ad38b08d6cd0437b96ac72650f3d851afa25a /graphics/hpoj/files
parenta4c7de3bc553e10102c117138652f0c9018723f3 (diff)
downloadfreebsd-ports-graphics-76087c33f15151945ead5ed84017ee2ac9a04ed8.tar.gz
freebsd-ports-graphics-76087c33f15151945ead5ed84017ee2ac9a04ed8.tar.zst
freebsd-ports-graphics-76087c33f15151945ead5ed84017ee2ac9a04ed8.zip
Use libio on alpha (-STABLE & -CURRENT).
PR: ports/52633 Submitted by: maintainer
Diffstat (limited to 'graphics/hpoj/files')
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-Makefile.in11
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp12
-rw-r--r--graphics/hpoj/files/extra-patch-mlcd-ParPort.h14
3 files changed, 37 insertions, 0 deletions
diff --git a/graphics/hpoj/files/extra-patch-mlcd-Makefile.in b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
new file mode 100644
index 00000000000..76a6fdaa14f
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-Makefile.in
@@ -0,0 +1,11 @@
+--- mlcd/Makefile.in.orig Sat May 24 08:03:14 2003
++++ mlcd/Makefile.in Sat May 24 08:03:37 2003
+@@ -35,7 +35,7 @@
+ for link in $(LINKS) ; do ln -s . $$link ; done
+
+ $(GOAL): $(OBJS)
+- $(CXX) -o $(GOAL) $(OBJS)
++ $(CXX) -o $(GOAL) -lio $(OBJS)
+
+ clean:
+ rm -f $(OBJS) $(GOAL) $(LINKS)
diff --git a/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp b/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
new file mode 100644
index 00000000000..4d62bc3f52a
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-ParPort.cpp
@@ -0,0 +1,12 @@
+--- mlcd/ParPort.cpp.orig Sat May 24 08:03:20 2003
++++ mlcd/ParPort.cpp Sat May 24 08:03:48 2003
+@@ -926,9 +926,6 @@
+ #elif defined(PAR_PLATFORM_FREEBSD)
+ #include <unistd.h>
+ #include <fcntl.h>
+- extern "C" {
+- #include <machine/cpufunc.h>
+- }
+ #else
+ /* TODO: Handle these more gracefully! */
+ #error Undefined platform
diff --git a/graphics/hpoj/files/extra-patch-mlcd-ParPort.h b/graphics/hpoj/files/extra-patch-mlcd-ParPort.h
new file mode 100644
index 00000000000..ae352910e70
--- /dev/null
+++ b/graphics/hpoj/files/extra-patch-mlcd-ParPort.h
@@ -0,0 +1,14 @@
+--- mlcd/ParPort.h.orig Sat May 24 08:02:19 2003
++++ mlcd/ParPort.h Sat May 24 07:59:13 2003
+@@ -27,6 +27,11 @@
+
+ #define ERROR_NO_DATA ERROR /* TODO: Remove. */
+
++extern "C" {
++extern u_char inb (u_int port);
++extern void outb(u_int port, u_char data);
++}
++
+ class ParPort {
+ protected: // ATTRIB
+ int portType;