aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/hugin
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2015-02-27 15:39:43 +0800
committervd <vd@FreeBSD.org>2015-02-27 15:39:43 +0800
commitc4beff3b219b0e8a25ca3163723ec4f33852b1b1 (patch)
treeed323f6f37f57885b498a885717ada812aa2e9ae /graphics/hugin
parent628785e98b0e900a062f8ac62c3c393b01171cec (diff)
downloadfreebsd-ports-graphics-c4beff3b219b0e8a25ca3163723ec4f33852b1b1.tar.gz
freebsd-ports-graphics-c4beff3b219b0e8a25ca3163723ec4f33852b1b1.tar.zst
freebsd-ports-graphics-c4beff3b219b0e8a25ca3163723ec4f33852b1b1.zip
Try to use the same compiler as graphics/OpenEXR
PR: 197898
Diffstat (limited to 'graphics/hugin')
-rw-r--r--graphics/hugin/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 79e1d8cb4a1..9ec3d167415 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -32,7 +32,7 @@ PANOMATIC_DESC= Install graphics/panomatic
AUTOPANOSIFTC_DESC= Install graphics/autopano-sift-c
USES= cmake gettext pkgconfig tar:bzip2 desktop-file-utils python \
- shared-mime-info
+ shared-mime-info compiler:features
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
@@ -43,6 +43,15 @@ USE_GL= glew glut
INSTALLS_ICONS= yes
+.include <bsd.port.pre.mk>
+
+# If default compiler is GCC, upgrade it because
+# g++ 4.2 is too old. Basically, use the same compiler as graphics/OpenEXR
+# see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=197898
+.if ${COMPILER_TYPE} == gcc
+USE_GCC= yes
+.endif
+
# work around a bug in cmake (?). Without this we get an error like:
# cd /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx && /usr/bin/c++ -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__ -D_THREAD_SAFE -O2 -fno-strict-aliasing -pipe -pthread;-D_THREAD_SAFE -O3 -DNDEBUG -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin_base -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/foreign/vigra -I/usr/local/include -I/usr/local/include/OpenEXR -isystem /usr/local/lib/wx/include/gtk2-ansi-release-2.8 -isystem /usr/local/include/wx-2.8 -I/usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1 -o CMakeFiles/huginbasewx.dir/ImageCache.o -c /usr/ports/graphics/hugin/work/hugin-0.7.r3135/src/hugin1/base_wx/ImageCache.cpp
# c++: No input files specified
@@ -72,4 +81,4 @@ RUN_DEPENDS+= panomatic:${PORTSDIR}/graphics/panomatic
RUN_DEPENDS+= autopano:${PORTSDIR}/graphics/autopano-sift-c
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>