aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/icoutils
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-11-30 10:12:08 +0800
committerlioux <lioux@FreeBSD.org>2005-11-30 10:12:08 +0800
commitceda7b8bbfc7b0eea8c4ce75d5ecbf73d1e8f75c (patch)
treea01865cf07ba9e17e5303bbb1856d647b1dd796a /graphics/icoutils
parenta03325662ef2c790b66cb04ff5045c75450d3b1d (diff)
downloadfreebsd-ports-graphics-ceda7b8bbfc7b0eea8c4ce75d5ecbf73d1e8f75c.tar.gz
freebsd-ports-graphics-ceda7b8bbfc7b0eea8c4ce75d5ecbf73d1e8f75c.tar.zst
freebsd-ports-graphics-ceda7b8bbfc7b0eea8c4ce75d5ecbf73d1e8f75c.zip
1) Fix build on ${OSVERSION} < 500000: replace stdint.h with
inttypes.h 2) Add missing USE_PERL5_RUN 3) Bump PORTREVISION due to (2)
Diffstat (limited to 'graphics/icoutils')
-rw-r--r--graphics/icoutils/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index aca9d64594f..8309dc4340c 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= icoutils
PORTVERSION= 0.26.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +18,8 @@ COMMENT= Convert/extract images in Microsoft Windows(R) icon/cursor files
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_GETTEXT= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -31,6 +33,13 @@ PLIST_FILES= \
bin/icotool \
bin/wrestool
+post-patch:
+ @${FIND} ${WRKSRC} -type f -print0 | \
+ ${XARGS} -0 -x -n 10 \
+ ${REINPLACE_CMD} -E \
+ -e 's|<stdint.h>|<inttypes.h>|' \
+ -e 's|/usr/bin/perl|${PERL5}|'
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000