aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/jpeg-mmx
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
committerasami <asami@FreeBSD.org>1995-06-24 19:42:32 +0800
commitd21b71cc5a3e11bccc9aa5fe5763254cd565d9a5 (patch)
tree560e7eb8a07c987120c853aef90742f320b09b93 /graphics/jpeg-mmx
parent8d54bac5baa3871cb4702456e31c93aedc116bd5 (diff)
downloadfreebsd-ports-graphics-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.gz
freebsd-ports-graphics-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.tar.zst
freebsd-ports-graphics-d21b71cc5a3e11bccc9aa5fe5763254cd565d9a5.zip
Add
post-install: pkg_add -m ${PREFIX}/lib to Makefiles and @exec ldconfig -m %D to packing lists of ports that install shared libraries. This should get rid of a huge chunk of confusion for novice users! All hail Paul Kranenburg! :)
Diffstat (limited to 'graphics/jpeg-mmx')
-rw-r--r--graphics/jpeg-mmx/Makefile5
-rw-r--r--graphics/jpeg-mmx/pkg-plist1
2 files changed, 5 insertions, 1 deletions
diff --git a/graphics/jpeg-mmx/Makefile b/graphics/jpeg-mmx/Makefile
index 675d78dc547..6a67ba54dde 100644
--- a/graphics/jpeg-mmx/Makefile
+++ b/graphics/jpeg-mmx/Makefile
@@ -3,7 +3,7 @@
# Date created: 6 November 1994
# Whom: smace
#
-# $Id: Makefile,v 1.6 1995/04/09 07:09:34 asami Exp $
+# $Id: Makefile,v 1.7 1995/04/16 02:14:19 asami Exp $
#
DISTNAME= jpegsrc.v5b
@@ -15,4 +15,7 @@ MASTER_SITES= ftp://ftp.uu.net/graphics/jpeg/ \
WRKSRC= ${WRKDIR}/jpeg-5b
GNU_CONFIGURE= yes
+post-install:
+ ldconfig -m ${PREFIX}/lib
+
.include <bsd.port.mk>
diff --git a/graphics/jpeg-mmx/pkg-plist b/graphics/jpeg-mmx/pkg-plist
index 04b9069ce80..b89c6b68dff 100644
--- a/graphics/jpeg-mmx/pkg-plist
+++ b/graphics/jpeg-mmx/pkg-plist
@@ -12,4 +12,5 @@ include/jpeglib.h
include/jmorecfg.h
include/jerror.h
lib/libjpeg.so.5.1
+@exec ldconfig -m %B
lib/libjpeg.a