aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2016-03-25 22:06:09 +0800
committerkwm <kwm@FreeBSD.org>2016-03-25 22:06:09 +0800
commit69b51b145ee0e34a2a00b80630609b0bed2528a0 (patch)
treeedf85d3b26f4b2cc70cba4abee96c4b2ca3a5842 /graphics/libGL
parent1a083c5a37ee76fd91e5b69a7edc13135df2196f (diff)
downloadfreebsd-ports-graphics-69b51b145ee0e34a2a00b80630609b0bed2528a0.tar.gz
freebsd-ports-graphics-69b51b145ee0e34a2a00b80630609b0bed2528a0.tar.zst
freebsd-ports-graphics-69b51b145ee0e34a2a00b80630609b0bed2528a0.zip
Update Mesa to 11.1.2.
Switch to using llvm 3.7. Obtained from: graphics team development repo
Diffstat (limited to 'graphics/libGL')
-rw-r--r--graphics/libGL/Makefile.common16
-rw-r--r--graphics/libGL/distinfo4
-rw-r--r--graphics/libGL/files/patch-src__gallium__auxiliary__util__u_cpu_detect.c11
-rw-r--r--graphics/libGL/files/patch-src__gallium__drivers__r300__r300_chipset.c24
-rw-r--r--graphics/libGL/files/patch-src__loader__Makefile.in20
5 files changed, 25 insertions, 50 deletions
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 6c8f9541c2c..9b9c76aa5de 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -18,7 +18,7 @@
MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
-MESABASEVERSION= 11.0.8
+MESABASEVERSION= 11.1.2
# if there is a subversion, don't include the '-' between 7.11-rc2.
MESASUBVERSION=
@@ -67,7 +67,9 @@ INSTALL_TARGET= install-strip
COMPONENT= ${PORTNAME:tl:C/^lib//:C/mesa-//}
-MESA_LLVM_VER=36
+MESA_LLVM_VER=37
+
+CONFIGURE_ARGS+= --with-sha1=libcrypto
# DRI3 needs PRIME support in the kernel to work
CONFIGURE_ARGS+= --disable-dri3
@@ -92,7 +94,15 @@ BUILD_DEPENDS+= libclc>=0.0.r222830:${PORTSDIR}/devel/libclc
# We need the clang port too even if it is not used to compile because
# Clover needs some of the clang includes to build.
.if ${COMPONENT:Mdri} != "" || ${COMPONENT:Mclover} != "" || ${COMPONENT:Mosmesa} != ""
-BUILD_DEPENDS+= clang${MESA_LLVM_VER}>=0:${PORTSDIR}/lang/clang${MESA_LLVM_VER}
+_USES_pre_configure+= 290:clover-pre-configure
+
+# .if !exists() evaluates too early before cairo has a chance to be installed
+clover-pre-configure:
+ @if [ -e ${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER} ] && \
+ ! [ -e ${LOCALBASE}/bin/clang${MESA_LLVM_VER} ]; then \
+ ${ECHO_MSG} "Your llvm${MESA_LLVM_VER} is not build with clang support, which is required."; \
+ ${FALSE}; \
+ fi
.endif
CONFIGURE_ARGS+= --enable-opencl \
diff --git a/graphics/libGL/distinfo b/graphics/libGL/distinfo
index 9d2e07a3d75..756a5ef25ee 100644
--- a/graphics/libGL/distinfo
+++ b/graphics/libGL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mesa-11.0.8.tar.xz) = 5696e4730518b6805d2ed5def393c4293f425a2c2c01bd5ed4bdd7ad62f7ad75
-SIZE (mesa-11.0.8.tar.xz) = 7282812
+SHA256 (mesa-11.1.2.tar.xz) = 8f72aead896b340ba0f7a4a474bfaf71681f5d675592aec1cb7ba698e319148b
+SIZE (mesa-11.1.2.tar.xz) = 7561920
diff --git a/graphics/libGL/files/patch-src__gallium__auxiliary__util__u_cpu_detect.c b/graphics/libGL/files/patch-src__gallium__auxiliary__util__u_cpu_detect.c
deleted file mode 100644
index f8441c85dbb..00000000000
--- a/graphics/libGL/files/patch-src__gallium__auxiliary__util__u_cpu_detect.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gallium/auxiliary/util/u_cpu_detect.c.orig 2014-09-19 18:23:33 UTC
-+++ src/gallium/auxiliary/util/u_cpu_detect.c
-@@ -52,7 +52,7 @@
- #include <machine/cpu.h>
- #endif
-
--#if defined(PIPE_OS_FREEBSD)
-+#if defined(PIPE_OS_FREEBSD) || defined(PIPE_OS_DRAGONFLY)
- #include <sys/types.h>
- #include <sys/sysctl.h>
- #endif
diff --git a/graphics/libGL/files/patch-src__gallium__drivers__r300__r300_chipset.c b/graphics/libGL/files/patch-src__gallium__drivers__r300__r300_chipset.c
deleted file mode 100644
index c1f766250ba..00000000000
--- a/graphics/libGL/files/patch-src__gallium__drivers__r300__r300_chipset.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./src/gallium/drivers/r300/r300_chipset.c.orig 2014-01-06 22:15:40.000000000 +0100
-+++ ./src/gallium/drivers/r300/r300_chipset.c 2014-02-23 22:01:50.000000000 +0100
-@@ -53,6 +53,21 @@
- if (!os_get_process_name(proc_name, sizeof(proc_name)))
- return;
-
-+#if defined(__DragonFly__) || \
-+ defined(__FreeBSD__) || \
-+ defined(__NetBSD__) || \
-+ defined(__OpenBSD__)
-+ const char *progname, *program_invocation_short_name;
-+
-+ progname = getprogname();
-+ program_invocation_short_name = strrchr(progname, '/');
-+ if (program_invocation_short_name) {
-+ program_invocation_short_name++;
-+ } else {
-+ program_invocation_short_name = progname;
-+ }
-+#endif
-+
- for (i = 0; i < Elements(list); i++) {
- if (strcmp(list[i], proc_name) == 0) {
- caps->zmask_ram = 0;
diff --git a/graphics/libGL/files/patch-src__loader__Makefile.in b/graphics/libGL/files/patch-src__loader__Makefile.in
index 9b46a248398..5d68bfd80e0 100644
--- a/graphics/libGL/files/patch-src__loader__Makefile.in
+++ b/graphics/libGL/files/patch-src__loader__Makefile.in
@@ -1,11 +1,11 @@
---- src/loader/Makefile.in.orig 2015-08-24 10:41:51.309456000 +0200
-+++ src/loader/Makefile.in 2015-08-24 10:42:39.452059000 +0200
-@@ -505,7 +505,7 @@
- noinst_LTLIBRARIES = libloader.la
- libloader_la_CPPFLAGS = $(DEFINES) -I$(top_srcdir)/include \
- -I$(top_srcdir)/src $(VISIBILITY_CFLAGS) $(LIBUDEV_CFLAGS) \
-- $(am__append_1) $(am__append_3)
-+ $(LIBDEVQ_CFLAGS) $(am__append_1) $(am__append_3)
+--- src/loader/Makefile.in.orig 2015-12-04 10:21:50.951759000 +0100
++++ src/loader/Makefile.in 2015-12-04 10:27:14.391665000 +0100
+@@ -531,7 +531,7 @@
+ $(LIBDRM_CFLAGS) \
+ $(LIBUDEV_CFLAGS)
+
+-libloader_la_CPPFLAGS = $(AM_CPPFLAGS) $(am__append_1)
++libloader_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBDEVQ_CFLAGS) $(am__append_1)
libloader_la_SOURCES = $(LOADER_C_FILES)
- libloader_la_LIBADD = $(am__append_2) $(am__append_4)
- all: all-am
+ libloader_la_LIBADD = $(am__append_2) $(am__append_3)
+ @HAVE_DRI3_TRUE@libloader_dri3_helper_la_SOURCES = \