aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libgnomecanvas
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2001-05-21 10:29:52 +0800
committerade <ade@FreeBSD.org>2001-05-21 10:29:52 +0800
commit0cac11ffb6c6aca730e853fa18933505bc95942d (patch)
tree6b94656dd29b3fbf763b4a59e39922fac5a9770c /graphics/libgnomecanvas
parentc19371237b42639291036c0b927cad63d410993e (diff)
downloadfreebsd-ports-graphics-0cac11ffb6c6aca730e853fa18933505bc95942d.tar.gz
freebsd-ports-graphics-0cac11ffb6c6aca730e853fa18933505bc95942d.tar.zst
freebsd-ports-graphics-0cac11ffb6c6aca730e853fa18933505bc95942d.zip
Split gdk-pixbuf into the non-GNOME part (gdk-pixbuf) and the
GNOME part (gnomecanvas) to allow for other ports to access the lower level parts of gdk-pixbuf without the "excess baggage" of even a minimal GNOME environment. Submitted by: sobomax (with extensive patches - complain to me)
Diffstat (limited to 'graphics/libgnomecanvas')
-rw-r--r--graphics/libgnomecanvas/Makefile34
-rw-r--r--graphics/libgnomecanvas/pkg-comment1
-rw-r--r--graphics/libgnomecanvas/pkg-descr6
-rw-r--r--graphics/libgnomecanvas/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/graphics/libgnomecanvas/Makefile b/graphics/libgnomecanvas/Makefile
new file mode 100644
index 00000000000..ecf501723d1
--- /dev/null
+++ b/graphics/libgnomecanvas/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomecanvas
+# Date created: 18 May 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomecanvas
+CATEGORIES= graphics gnome
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+MASTERDIR= ${.CURDIR}/../gdk-pixbuf
+
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOMELIBS= yes
+
+BUILD_CANVAS= yes
+
+NAME= gnomecanvaspixbuf
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${NAME}Conf.sh ${PREFIX}/etc
+ cd ${WRKSRC}/gdk-pixbuf/.libs && \
+ ${MKDIR} ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} ../gnome-canvas-pixbuf.h ${PREFIX}/include/gdk-pixbuf/ && \
+ ${INSTALL_DATA} lib${NAME}.a ${PREFIX}/lib && \
+ ${INSTALL_PROGRAM} lib${NAME}.so.1 ${PREFIX}/lib && \
+ ${LN} -sf lib${NAME}.so.1 ${PREFIX}/lib/lib${NAME}.so
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/libgnomecanvas/pkg-comment b/graphics/libgnomecanvas/pkg-comment
new file mode 100644
index 00000000000..e5a8b45b1fe
--- /dev/null
+++ b/graphics/libgnomecanvas/pkg-comment
@@ -0,0 +1 @@
+A graphic library for GNOME
diff --git a/graphics/libgnomecanvas/pkg-descr b/graphics/libgnomecanvas/pkg-descr
new file mode 100644
index 00000000000..8900db783bf
--- /dev/null
+++ b/graphics/libgnomecanvas/pkg-descr
@@ -0,0 +1,6 @@
+The GNOMECanvas library provides a number of features:
+
+ - Image loading facilities.
+ - Rendering of a GdkPixBuf into various formats:
+ drawables (windows, pixmaps), GdkRGB buffers.
+ - A cache interface
diff --git a/graphics/libgnomecanvas/pkg-plist b/graphics/libgnomecanvas/pkg-plist
new file mode 100644
index 00000000000..12399271f73
--- /dev/null
+++ b/graphics/libgnomecanvas/pkg-plist
@@ -0,0 +1,5 @@
+etc/gnomecanvaspixbufConf.sh
+include/gdk-pixbuf/gnome-canvas-pixbuf.h
+lib/libgnomecanvaspixbuf.a
+lib/libgnomecanvaspixbuf.so
+lib/libgnomecanvaspixbuf.so.1