aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libgphoto2
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-03-09 02:01:11 +0800
committerpav <pav@FreeBSD.org>2009-03-09 02:01:11 +0800
commite7df0ce97af8e4acc018e85a0080442e0a51cfbe (patch)
tree5152697a50fc561a0c3af0ab60f93b9e074f42ca /graphics/libgphoto2
parenta16782ab9f1007df2410b82d7050ecb7263e1bca (diff)
downloadfreebsd-ports-graphics-e7df0ce97af8e4acc018e85a0080442e0a51cfbe.tar.gz
freebsd-ports-graphics-e7df0ce97af8e4acc018e85a0080442e0a51cfbe.tar.zst
freebsd-ports-graphics-e7df0ce97af8e4acc018e85a0080442e0a51cfbe.zip
- Another round of usb20 patches
PR: ports/132420 Submitted by: Phillip N. <pneumann@gmail.com>, kan
Diffstat (limited to 'graphics/libgphoto2')
-rw-r--r--graphics/libgphoto2/Makefile3
-rw-r--r--graphics/libgphoto2/files/extra-patch-usb2011
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index fb4f101e75b..b38512d23f2 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -40,7 +40,8 @@ PLIST_SUB+= NLS=""
.if ${OSVERSION} < 800064
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.else
-CONFIGURE_ENV+= LIBUSB_LIBS="-L/usr/lib -lusb20" LIBUSB_CFLAGS="-I/usr/include/dev/usb"
+CONFIGURE_ENV+= LIBUSB_LIBS="-L/usr/lib -lusb20" LIBUSB_CFLAGS="-I/usr/include/dev/usb -I/usr/include"
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-usb20
.endif
post-patch:
diff --git a/graphics/libgphoto2/files/extra-patch-usb20 b/graphics/libgphoto2/files/extra-patch-usb20
new file mode 100644
index 00000000000..adcfd231785
--- /dev/null
+++ b/graphics/libgphoto2/files/extra-patch-usb20
@@ -0,0 +1,11 @@
+--- libgphoto2_port/usb/libusb.c.orig 2008-11-21 19:24:40.000000000 +0100
++++ libgphoto2_port/usb/libusb.c 2009-03-08 18:58:56.000000000 +0100
+@@ -33,6 +33,8 @@
+ #include <string.h>
+
+ #include <usb.h>
++#include <libusb20.h>
++#include <libusb20_compat10.h>
+
+ #include <gphoto2/gphoto2-port.h>
+ #include <gphoto2/gphoto2-port-result.h>