aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/linux_mesa3/Makefile
diff options
context:
space:
mode:
authorcracauer <cracauer@FreeBSD.org>1998-10-09 00:29:25 +0800
committercracauer <cracauer@FreeBSD.org>1998-10-09 00:29:25 +0800
commit4bbea3a88a2641ed02f7dbb97657b1d31b183b3b (patch)
tree5793ae33ae61799cb2e0ed1eecfaf65cdc1dd252 /graphics/linux_mesa3/Makefile
parent70031fb6f6cb0ca9a731a9871d4d9e8362a892e0 (diff)
downloadfreebsd-ports-graphics-4bbea3a88a2641ed02f7dbb97657b1d31b183b3b.tar.gz
freebsd-ports-graphics-4bbea3a88a2641ed02f7dbb97657b1d31b183b3b.tar.zst
freebsd-ports-graphics-4bbea3a88a2641ed02f7dbb97657b1d31b183b3b.zip
This port compiles and installs a Linux shared library of Mesa
accessing glide/3dfx cards. To be used with linux_devel.
Diffstat (limited to 'graphics/linux_mesa3/Makefile')
-rw-r--r--graphics/linux_mesa3/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/linux_mesa3/Makefile b/graphics/linux_mesa3/Makefile
new file mode 100644
index 00000000000..a2cc4678cbc
--- /dev/null
+++ b/graphics/linux_mesa3/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Mesa for Linux compat
+# Version required: 2.6
+# Date created: Oct, 8 1998
+# Whom: cracauer
+#
+# $Id: Makefile,v 1.25 1998/09/27 16:06:21 steve Exp $
+#
+
+DISTNAME= MesaLib-2.6
+PKGNAME= linux_mesa-2.6
+CATEGORIES= emulators
+MASTER_SITES= ftp://iris.ssec.wisc.edu/pub/Mesa/
+
+MAINTAINER= cracauer@cons.org
+
+ALL_TARGET= linux-glide
+MAKE_ENV= PATH=${PREFIX}/usr/bin:$$PATH
+NO_FILTER_SHLIBS=yes
+
+PREFIX= /compat/linux
+WRKSRC= ${WRKDIR}/Mesa-2.6/src
+BUILD_DEPENDS= /compat/linux/usr/lib/libglide2x.so:${PORTSDIR}/emulators/linux_glide \
+ /compat/linux/usr/bin/gcc:${PORTSDIR}/devel/linux_devel
+
+post-extract:
+ -${MKDIR} ${WRKSRC}/../lib/
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/../lib/libMesaGL.so.2.6 ${PREFIX}/usr/lib/.
+ ${LN} -fs libMesaGL.so.2.6 ${PREFIX}/usr/lib/libMesaGL.so.2
+ ${LN} -fs libMesaGL.so.2.6 ${PREFIX}/usr/lib/libMesaGL.so
+ ${LN} -fs libMesaGL.so.2.6 ${PREFIX}/usr/lib/libGL.so
+ @${MKDIR} ${PREFIX}/usr/include/GL
+ ${INSTALL_DATA} ${WRKSRC}/../include/GL/* ${PREFIX}/usr/include/GL/.
+ ${INSTALL_DATA} ${WRKSRC}/../include/glaux.h ${PREFIX}/usr/include/.
+ ${INSTALL_DATA} ${WRKSRC}/../include/gltk.h ${PREFIX}/usr/include/.
+ -/compat/linux/sbin/ldconfig
+
+.include <bsd.port.mk>