aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/orca
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-06 10:35:26 +0800
committeredwin <edwin@FreeBSD.org>2003-10-06 10:35:26 +0800
commita82a8332bb08c412496a5930499cd6daeb874aec (patch)
tree5fe5e042cfc0208de85431843d26f34aa276c2f0 /graphics/orca
parent12ded0db5e739230415aa99012bd286d0c69fd8d (diff)
downloadfreebsd-ports-graphics-a82a8332bb08c412496a5930499cd6daeb874aec.tar.gz
freebsd-ports-graphics-a82a8332bb08c412496a5930499cd6daeb874aec.tar.zst
freebsd-ports-graphics-a82a8332bb08c412496a5930499cd6daeb874aec.zip
New port: orca text data grapher (uses rrdtool)
orca makes great graphs, using rrdtool http://www.orcaware.com/orca/ PR: ports/48448 Submitted by: John Sellens <jsellens@generalconcepts.com>
Diffstat (limited to 'graphics/orca')
-rw-r--r--graphics/orca/Makefile36
-rw-r--r--graphics/orca/distinfo1
-rw-r--r--graphics/orca/files/patch-Makefile.in20
-rw-r--r--graphics/orca/files/patch-src_Makefile.in11
-rw-r--r--graphics/orca/pkg-descr21
-rw-r--r--graphics/orca/pkg-message4
-rw-r--r--graphics/orca/pkg-plist15
7 files changed, 108 insertions, 0 deletions
diff --git a/graphics/orca/Makefile b/graphics/orca/Makefile
new file mode 100644
index 00000000000..27ba52f20f6
--- /dev/null
+++ b/graphics/orca/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: orca
+# Date created: 18 February 2003
+# Whom: jsellens
+#
+# $FreeBSD$
+#
+
+PORTNAME= orca
+PORTVERSION= 0.27b3
+CATEGORIES= graphics
+MASTER_SITES= http://www.orcaware.com/orca/pub/
+
+MAINTAINER= jsellens@generalconcepts.com
+COMMENT= Tool for plotting arbitrary data from text files onto a Web server
+
+# needs some happy Perl modules
+# I think Data::Dumper is installed as part of the FreeBSD base install
+# How can I test for a version of one of these? e.g. Storable.pm should
+# be >= version 2.05, p5-TimeDate >=1.40
+BUILD_DEPENDS= \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Math/Interpolate.pm:${PORTSDIR}/math/p5-Math-Interpolate \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-html-dir=${PREFIX}/www/data/orca
+
+MAN1= orca.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/orca/distinfo b/graphics/orca/distinfo
new file mode 100644
index 00000000000..368cc5522dc
--- /dev/null
+++ b/graphics/orca/distinfo
@@ -0,0 +1 @@
+MD5 (orca-0.27b3.tar.gz) = e9e204abc37fe65ad9fbf8c250df1217
diff --git a/graphics/orca/files/patch-Makefile.in b/graphics/orca/files/patch-Makefile.in
new file mode 100644
index 00000000000..c50c6646b40
--- /dev/null
+++ b/graphics/orca/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Wed Aug 7 20:08:36 2002
++++ Makefile.in Tue Feb 18 23:58:27 2003
+@@ -1,6 +1,7 @@
+ @SET_MAKE@
+
+-SUBDIRS = packages lib src @ORCALLATOR_SUBDIR@ docs contrib
++# SUBDIRS = packages lib src @ORCALLATOR_SUBDIR@ docs contrib
++SUBDIRS = packages lib src docs contrib
+ prefix = @prefix@
+ MKDIR = @MKDIR@
+ MAKE_RRDTOOL = @MAKE_RRDTOOL@
+@@ -30,8 +31,6 @@
+
+ install: $(INSTALL_RRDTOOL)
+ $(MKDIR) $(VAR_DIR)
+- $(MKDIR) $(ORCALLATOR_DIR)
+- $(MKDIR) $(RRD_DIR)/orcallator
+ @for dir in $(SUBDIRS); do \
+ if test -d $$dir; then \
+ echo "cd $$dir"; \
diff --git a/graphics/orca/files/patch-src_Makefile.in b/graphics/orca/files/patch-src_Makefile.in
new file mode 100644
index 00000000000..11de46f4eca
--- /dev/null
+++ b/graphics/orca/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Wed Jul 31 01:20:01 2002
++++ src/Makefile.in Tue Feb 18 23:19:08 2003
+@@ -9,7 +9,7 @@
+ RRD_DIR = @RRD_DIR@
+ VAR_DIR = @VAR_DIR@
+ ORCALLATOR_DIR = $(VAR_DIR)/orcallator
+-PERL_SCRIPTS = orca upgrade_installation
++PERL_SCRIPTS = orca
+ SHELL_SCRIPTS =
+ TARGETS = $(PERL_SCRIPTS) $(SHELL_SCRIPTS)
+
diff --git a/graphics/orca/pkg-descr b/graphics/orca/pkg-descr
new file mode 100644
index 00000000000..ff764f0b272
--- /dev/null
+++ b/graphics/orca/pkg-descr
@@ -0,0 +1,21 @@
+This is a port of Orca which is Blair Zajac's incredibly useful
+tool for making web-viewable graphs of arbitrary data from text
+files.
+
+Uses a configuration file which describes which text files to read,
+what the columns in the files mean, and how that information should
+be graphed.
+
+Often run as a daemon, automatically updating as files change.
+Often run with the Orcallator.se script for Solaris machines and
+corresponding configuration file (just because you collect the data
+on a Solaris box doesn't mean you have to graph it on one too).
+
+Written in Perl, uses RRDtool for data storage and graph generation.
+
+Lots more information and examples at
+WWW: http://www.orcaware.com/orca/
+
+
+- John
+jsellens@generalconcepts.com
diff --git a/graphics/orca/pkg-message b/graphics/orca/pkg-message
new file mode 100644
index 00000000000..6914a99e1b9
--- /dev/null
+++ b/graphics/orca/pkg-message
@@ -0,0 +1,4 @@
+
+Note that the orcallator and contrib components have not been
+installed in this version of the port. I suspect that this is
+probably acceptable at this point.
diff --git a/graphics/orca/pkg-plist b/graphics/orca/pkg-plist
new file mode 100644
index 00000000000..7c17e57bcaa
--- /dev/null
+++ b/graphics/orca/pkg-plist
@@ -0,0 +1,15 @@
+bin/orca
+lib/Orca/Config.pm
+lib/Orca/Constants.pm
+lib/Orca/DataFile.pm
+lib/Orca/HTMLFile.pm
+lib/Orca/ImageFile.pm
+lib/Orca/NewState.pm
+lib/Orca/OldState.pm
+lib/Orca/OpenFileHash.pm
+lib/Orca/RRDFile.pm
+lib/Orca/SourceFile.pm
+lib/Orca/SourceFileIDs.pm
+lib/Orca/Utils.pm
+@dirrm var/orca
+@dirrm lib/Orca