aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/osgedit/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-01-24 14:44:37 +0800
committerijliao <ijliao@FreeBSD.org>2003-01-24 14:44:37 +0800
commit5beb1a33d9ccc3bf1d8193b82b98a5497b53c9af (patch)
treefc246315d02731e943333a30dc3ae86eb6e12279 /graphics/osgedit/Makefile
parent2858d3c7fc78cf8416e9dcd570fe910b73c37666 (diff)
downloadfreebsd-ports-graphics-5beb1a33d9ccc3bf1d8193b82b98a5497b53c9af.tar.gz
freebsd-ports-graphics-5beb1a33d9ccc3bf1d8193b82b98a5497b53c9af.tar.zst
freebsd-ports-graphics-5beb1a33d9ccc3bf1d8193b82b98a5497b53c9af.zip
add osgedit 0.3.0
An open editor for an open scenegraph
Diffstat (limited to 'graphics/osgedit/Makefile')
-rw-r--r--graphics/osgedit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/osgedit/Makefile b/graphics/osgedit/Makefile
new file mode 100644
index 00000000000..21f4a514781
--- /dev/null
+++ b/graphics/osgedit/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: osgedit
+# Date created: Jan 23, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= osgedit
+PORTVERSION= 0.3.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${X11BASE}/lib/libosg.so:${PORTSDIR}/graphics/osg
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gtkgl-2.0.1:${PORTSDIR}/x11-toolkits/gtkglarea2 \
+ intl.4:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+RUN_DEPENDS= ${X11BASE}/lib/libosg.so:${PORTSDIR}/graphics/osg
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+.include <bsd.port.mk>