aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pixie
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-10-16 13:50:55 +0800
committeritetcu <itetcu@FreeBSD.org>2006-10-16 13:50:55 +0800
commit8f526fdbca5b9b5543caf5f437c535f8f68b6adc (patch)
tree6183bbc18c0ff9801128ee62ba36a311e1f4fc3b /graphics/pixie
parenta4d724c5fff186f65094b91056cebd453bd7ed5a (diff)
downloadfreebsd-ports-graphics-8f526fdbca5b9b5543caf5f437c535f8f68b6adc.tar.gz
freebsd-ports-graphics-8f526fdbca5b9b5543caf5f437c535f8f68b6adc.tar.zst
freebsd-ports-graphics-8f526fdbca5b9b5543caf5f437c535f8f68b6adc.zip
- install all needed share libs
- Add a missing static library to pkg-plist so that it gets deinstalled correctly. - USE_LDCONFIG so that the user doesn't have to specify LD_LIBRARY_PATH and kill the now obsolete pkg-message. PR: ports/104251 Submitted by: Sergey Zaharchenko <doublef-ctm@yandex.ru> Approved by: portmgr (clement)
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile10
-rw-r--r--graphics/pixie/files/pkg-message.in5
-rw-r--r--graphics/pixie/pkg-plist3
3 files changed, 6 insertions, 12 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index e0756b11924..ab25564b6d5 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -28,14 +28,13 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/in
CXXFLAGS="${CXXFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
LIBS="${PTHREAD_LIBS}"
-USE_LDCONFIG= yes
-LDCONFIG_DIRS= %%PREFIX%%/lib/${PORTNAME}
+CONFIGURE_ARGS+= --with-docdir=${PREFIX}/share/doc/${PORTNAME} --with-shaderdir=${PREFIX}/share/${PORTNAME}/shaders --with-modeldir=${PREFIX}/share/${PORTNAME} --with-texturedir=${PREFIX}/share/${PORTNAME} --with-proceduraldir=${PREFIX}/share/${PORTNAME} --with-displaysdir=${PREFIX}/lib/${PORTNAME}
+USE_LDCONFIG= %%PREFIX%%/lib/${PORTNAME}
WRKSRC= ${WRKDIR}/Pixie
PIXIE_EXES= precomp rndr sdrc sdrinfo show texmake
PIXIE_SHLIBS= file framebuffer rgbe
-SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
.include <bsd.port.pre.mk>
@@ -64,7 +63,7 @@ do-install:
# libs
# avoid conflicts by installing in separate dir
@${MKDIR} ${PREFIX}/lib/${PORTNAME}
-.for i in sdr ri
+.for i in sdr ri common
${INSTALL_DATA} ${WRKSRC}/src/${i}/.libs/lib${i}.a \
${PREFIX}/lib/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/src/${i}/.libs/lib${i}.so.0 \
@@ -101,7 +100,4 @@ do-install:
.endfor
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/graphics/pixie/files/pkg-message.in b/graphics/pixie/files/pkg-message.in
deleted file mode 100644
index 63cbbb28645..00000000000
--- a/graphics/pixie/files/pkg-message.in
+++ /dev/null
@@ -1,5 +0,0 @@
-******************************************************************************
- Before running any Pixie executable make sure to add the following
- directory to your LD_LIBRARY_PATH environment variable:
- %%PREFIX%%/lib/%%PORTNAME%%
-******************************************************************************
diff --git a/graphics/pixie/pkg-plist b/graphics/pixie/pkg-plist
index e1658e75523..c43a321314e 100644
--- a/graphics/pixie/pkg-plist
+++ b/graphics/pixie/pkg-plist
@@ -12,6 +12,9 @@ include/pixie/sdr.h
include/pixie/shadeop.h
lib/pixie/file.so
lib/pixie/framebuffer.so
+lib/pixie/libcommon.a
+lib/pixie/libcommon.so
+lib/pixie/libcommon.so.0
lib/pixie/libri.a
lib/pixie/libri.so
lib/pixie/libri.so.0