aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pixie
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-06-05 07:47:03 +0800
committermnag <mnag@FreeBSD.org>2006-06-05 07:47:03 +0800
commite8ef876d1c7d709e16b208cf3a210e2769cb4bee (patch)
tree14a6f74feb84d3f97c0a26eafbd1570d4680996d /graphics/pixie
parent02bf6272e00be5250498da096209489c5851b779 (diff)
downloadfreebsd-ports-graphics-e8ef876d1c7d709e16b208cf3a210e2769cb4bee.tar.gz
freebsd-ports-graphics-e8ef876d1c7d709e16b208cf3a210e2769cb4bee.tar.zst
freebsd-ports-graphics-e8ef876d1c7d709e16b208cf3a210e2769cb4bee.zip
- Update to 1.6.3
- portlint(1) PR: 98275 Submitted by: maintainer
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile11
-rw-r--r--graphics/pixie/distinfo6
-rw-r--r--graphics/pixie/files/patch-configure.in35
3 files changed, 34 insertions, 18 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index dbc1fc89fe2..0171a032b8d 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pixie
-PORTVERSION= 1.5.5
+PORTVERSION= 1.6.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +21,8 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_GL= yes
USE_X_PREFIX= yes
-USE_AUTOTOOLS= automake:15:env autoconf:253 libtool:15
+ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
+USE_AUTOTOOLS= autoconf:259 aclocal:19 automake:19 libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
CXXFLAGS="${CXXFLAGS} -O -fPIC -I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -44,18 +45,14 @@ NOT_FOR_ARCHS= alpha
.endif
.if ${OSVERSION} >= 600000 && ${ARCH} == "sparc64"
-BROKEN= "doesn't compile because of internal gcc failure"
+BROKEN= doesn't compile because of internal gcc failure
.endif
post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
-
pre-configure:
- @(cd ${WRKSRC} && ${ACLOCAL} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} --add-missing && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} -i)
@${REINPLACE_CMD} -e '/^_LT_AC_SHELL_INIT/d' ${WRKSRC}/aclocal.m4
do-install:
diff --git a/graphics/pixie/distinfo b/graphics/pixie/distinfo
index 77c7b330edb..cc219307a66 100644
--- a/graphics/pixie/distinfo
+++ b/graphics/pixie/distinfo
@@ -1,3 +1,3 @@
-MD5 (Pixie-src-1.5.5.tgz) = fbd01a2974ccdfe7887111da4ae76aa8
-SHA256 (Pixie-src-1.5.5.tgz) = c199ab9b470232b45d64bb22f7c6091751985cae5192d487f0cc8a86e3318ed3
-SIZE (Pixie-src-1.5.5.tgz) = 6110365
+MD5 (Pixie-src-1.6.3.tgz) = fa36424619d5dda8515f009e01df2207
+SHA256 (Pixie-src-1.6.3.tgz) = 19cd9aee4b360cde8bb12862b6e312498fd3a257d58d6d133150324a433180b6
+SIZE (Pixie-src-1.6.3.tgz) = 6125284
diff --git a/graphics/pixie/files/patch-configure.in b/graphics/pixie/files/patch-configure.in
index d62e365896c..3b54c04a888 100644
--- a/graphics/pixie/files/patch-configure.in
+++ b/graphics/pixie/files/patch-configure.in
@@ -1,6 +1,8 @@
---- configure.in.orig Tue Nov 22 06:30:25 2005
-+++ configure.in Wed Jan 25 00:38:57 2006
-@@ -23,5 +23,5 @@
+--- configure.in.orig
++++ configure.in
+@@ -23,9 +23,9 @@
+ dnl ---------------------------------------------------
+ dnl Check standard libraries
dnl
-AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
+dnl AC_CHECK_LIB(dl, dlopen,,[AC_MSG_ERROR([dl library is not found])],)
@@ -8,7 +10,11 @@
-AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
+dnl AC_CHECK_LIB(pthread, pthread_create,,[AC_MSG_ERROR([pthread library is not found])],)
-@@ -52,5 +52,9 @@
+ dnl ---------------------------------------------------
+ dnl Find X
+@@ -52,18 +52,24 @@
+ dnl Find FLTK
+ dnl
+saved_LIBS="${LIBS}"
+
@@ -19,13 +25,26 @@
-AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL" have_fltk=true])
+AC_CHECK_LIB(fltk_gl,main,[LIBFLTKGL="-lfltk_gl -lGL -lstdc++" have_fltk=true])
AM_CONDITIONAL(BUILD_SHOW, test x$have_fltk = xtrue)
-@@ -63,3 +67,3 @@
+
++LIBS="${saved_LIBS}"
++
+ dnl ---------------------------------------------------
+ dnl Find libtiff
+ dnl
+
+ saved_LIBS="$LIBS"
-AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
+dnl AC_CHECK_HEADER(tiffio.h,,AC_MSG_ERROR([tiffio.h not found]))
AC_CHECK_LIB(tiff,TIFFOpen,,[AC_MSG_ERROR([libtiff not found])],)
-@@ -100,3 +104,3 @@
+
+ TIFF_LIBS="$LIBS"
+@@ -141,7 +147,7 @@
+ dnl
+
AC_ARG_ENABLE(selfcontained,
--AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup]),
-+AC_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup]),
+-AS_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup (overrides custom directory settings)]),
++AC_HELP_STRING([--enable-selfcontained],[Build for a selfcontained setup (overrides custom directory settings)]),
[case "${enableval}" in
+ yes) docdir="${prefix}/doc"
+ shaderdir="${prefix}/shaders"