aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/poppler
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /graphics/poppler
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-graphics-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-graphics-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-graphics-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile66
-rw-r--r--graphics/poppler/distinfo6
-rw-r--r--graphics/poppler/files/patch-configure11
-rw-r--r--graphics/poppler/files/patch-glib_Makefile.in37
-rw-r--r--graphics/poppler/files/patch-qt_Makefile.in39
-rw-r--r--graphics/poppler/pkg-plist28
6 files changed, 160 insertions, 27 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 48275124af6..f12fb706614 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -3,25 +3,71 @@
# Whom: marcus@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports/graphics/poppler/Makefile,v 1.14 2005/09/03 04:44:58 ahze Exp $
+# $MCom: ports/graphics/poppler/Makefile,v 1.23 2006/04/12 17:10:20 ahze Exp $
#
PORTNAME= poppler
-PORTVERSION= 0.4.5
+PORTVERSION= 0.5.1
+PORTREVISION?= 0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= A PDF rendering library
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= A PDF rendering library
-USE_X_PREFIX= yes
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+
+CONFLICTS= xpdf-[0-9]*
USE_GMAKE= yes
+USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix gnomehack gtk20
+USE_GNOME= gnomehack gnometarget
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-zlib \
- --disable-poppler-qt
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ --enable-xpdf-headers \
+ --with-html-dir=${DOCSDIR}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(SLAVEPORT)
+LIB_DEPENDS+= poppler.1:${PORTSDIR}/graphics/poppler
+.if ${SLAVEPORT}=="gtk"
+CONFIGURE_ARGS+=--enable-poppler-glib
+USE_GNOME+= gtk20
+BUILD_WRKSRC= ${WRKSRC}/glib
+INSTALL_WRKSRC= ${WRKSRC}/glib
+.elif ${SLAVEPORT}=="qt"
+CONFIGURE_ARGS+=--enable-poppler-qt
+USE_QT_VER+= 3
+BUILD_WRKSRC= ${WRKSRC}/qt
+INSTALL_WRKSRC= ${WRKSRC}/qt
+# blah.. USE_QT_VER can't be defined after bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.kde.mk"
+.endif
+.else
+CONFIGURE_ARGS+=--disable-poppler-glib --disable-poppler-qt \
+ --disable-poppler-qt4
+MAN1= pdffonts.1 pdfimages.1 pdfinfo.1 \
+ pdftohtml.1 pdftops.1 pdftotext.1 pdftoppm.1
+.endif
+
+post-patch:
+.if defined(SLAVEPORT) && ${SLAVEPORT}=="qt"
+ @${REINPLACE_CMD} -e 's|/usr/local/qt/include|${X11BASE}/include|; \
+ s|/usr/local/qt/lib|${X11BASE}/lib|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$QTDIR|${X11BASE}|' ${WRKSRC}/configure
+.endif
+
+post-install:
+.if defined(SLAVEPORT)
+.if ${SLAVEPORT}=="gtk"
+ ${INSTALL_DATA} ${WRKSRC}/poppler-glib.pc ${PREFIX}/libdata/pkgconfig
+.elif ${SLAVEPORT}=="qt"
+ ${INSTALL_DATA} ${WRKSRC}/poppler-qt.pc ${PREFIX}/libdata/pkgconfig
+.endif
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/poppler/distinfo b/graphics/poppler/distinfo
index 288cfd4c1df..ba73162585d 100644
--- a/graphics/poppler/distinfo
+++ b/graphics/poppler/distinfo
@@ -1,3 +1,3 @@
-MD5 (poppler-0.4.5.tar.gz) = 2bb1c75aa3f9c42f0ba48b5492e6d32c
-SHA256 (poppler-0.4.5.tar.gz) = e5094a7587e53744ade899394ff5679e1dab2438ee0c9db137b1220c439f0639
-SIZE (poppler-0.4.5.tar.gz) = 783752
+MD5 (poppler-0.5.1.tar.gz) = a136cd731892f4570933034ba97c8704
+SHA256 (poppler-0.5.1.tar.gz) = 2ee3f06d64dd703a2411428169fe21c17f6358950bb797d52ca8eebd1dcf1abe
+SIZE (poppler-0.5.1.tar.gz) = 954930
diff --git a/graphics/poppler/files/patch-configure b/graphics/poppler/files/patch-configure
new file mode 100644
index 00000000000..72b0d9459e1
--- /dev/null
+++ b/graphics/poppler/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Apr 12 12:53:56 2006
++++ configure Wed Apr 12 13:06:36 2006
+@@ -24849,7 +24849,7 @@
+ fi
+ fi
+
+-if test "x$have_qt" == "xyes"; then
++if test "x$have_qt" = "xyes"; then
+ POPPLER_QT_CXXFLAGS="-I$qt_incdir"
+ POPPLER_QT_LIBS="$qt_libdir/$qt_test_library"
+ :
diff --git a/graphics/poppler/files/patch-glib_Makefile.in b/graphics/poppler/files/patch-glib_Makefile.in
new file mode 100644
index 00000000000..111a8521c47
--- /dev/null
+++ b/graphics/poppler/files/patch-glib_Makefile.in
@@ -0,0 +1,37 @@
+--- glib/Makefile.in.orig Wed Mar 8 20:40:26 2006
++++ glib/Makefile.in Wed Mar 8 20:42:17 2006
+@@ -65,7 +65,6 @@ LTLIBRARIES = $(lib_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+ @BUILD_CAIRO_OUTPUT_TRUE@am__DEPENDENCIES_2 = $(am__DEPENDENCIES_1)
+ libpoppler_glib_la_DEPENDENCIES = \
+- $(top_builddir)/poppler/libpoppler.la \
+ $(top_builddir)/poppler/libpoppler-cairo.la \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_2)
+@@ -78,7 +77,7 @@ PROGRAMS = $(noinst_PROGRAMS)
+ am_test_poppler_glib_OBJECTS = test-poppler-glib.$(OBJEXT)
+ test_poppler_glib_OBJECTS = $(am_test_poppler_glib_OBJECTS)
+ test_poppler_glib_DEPENDENCIES = \
+- $(top_builddir)/poppler/libpoppler.la libpoppler-glib.la \
++ $(top_builddir)/poppler/libpoppler-cairo.la libpoppler-glib.la \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_2)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) -I$(top_builddir)/poppler
+@@ -306,7 +305,7 @@ libpoppler_glib_la_SOURCES = \
+ poppler-private.h
+
+ libpoppler_glib_la_LIBADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ $(top_builddir)/poppler/libpoppler-cairo.la \
+ $(POPPLER_GLIB_LIBS) \
+ $(FREETYPE_LIBS) \
+@@ -317,7 +316,7 @@ test_poppler_glib_SOURCES = \
+ test-poppler-glib.c
+
+ test_poppler_glib_LDADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ libpoppler-glib.la \
+ $(POPPLER_GLIB_LIBS) \
+ $(FREETYPE_LIBS) \
diff --git a/graphics/poppler/files/patch-qt_Makefile.in b/graphics/poppler/files/patch-qt_Makefile.in
new file mode 100644
index 00000000000..29d9a5fa298
--- /dev/null
+++ b/graphics/poppler/files/patch-qt_Makefile.in
@@ -0,0 +1,39 @@
+--- qt/Makefile.in.orig Thu Jan 12 21:37:56 2006
++++ qt/Makefile.in Thu Jan 12 21:38:47 2006
+@@ -63,16 +63,14 @@
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+ am__DEPENDENCIES_1 =
+-libpoppler_qt_la_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
+- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
++libpoppler_qt_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+ am_libpoppler_qt_la_OBJECTS = poppler-document.lo poppler-fontinfo.lo \
+ poppler-page.lo poppler-page-transition.lo
+ libpoppler_qt_la_OBJECTS = $(am_libpoppler_qt_la_OBJECTS)
+ PROGRAMS = $(noinst_PROGRAMS)
+ am_test_poppler_qt_OBJECTS = test-poppler-qt.$(OBJEXT)
+ test_poppler_qt_OBJECTS = $(am_test_poppler_qt_OBJECTS)
+-test_poppler_qt_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
+- libpoppler-qt.la $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
++test_poppler_qt_DEPENDENCIES = libpoppler-qt.la $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir) -I$(top_builddir)/poppler
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+@@ -273,7 +271,7 @@
+ poppler-private.h
+
+ libpoppler_qt_la_LIBADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ $(POPPLER_QT_LIBS) \
+ $(FREETYPE_LIBS)
+
+@@ -281,7 +279,7 @@
+ test-poppler-qt.cpp
+
+ test_poppler_qt_LDADD = \
+- $(top_builddir)/poppler/libpoppler.la \
++ -lpoppler \
+ libpoppler-qt.la \
+ $(POPPLER_QT_LIBS) \
+ $(FREETYPE_LIBS)
diff --git a/graphics/poppler/pkg-plist b/graphics/poppler/pkg-plist
index eafc607a97a..dde9794b661 100644
--- a/graphics/poppler/pkg-plist
+++ b/graphics/poppler/pkg-plist
@@ -1,11 +1,16 @@
+bin/pdffonts
+bin/pdfimages
+bin/pdfinfo
+bin/pdftohtml
+bin/pdftoppm
+bin/pdftops
+bin/pdftotext
include/poppler/Annot.h
include/poppler/Array.h
include/poppler/BaseFile.h
include/poppler/BuiltinFont.h
include/poppler/BuiltinFontTables.h
include/poppler/CMap.h
-include/poppler/CairoFontEngine.h
-include/poppler/CairoOutputDev.h
include/poppler/Catalog.h
include/poppler/CharCodeToUnicode.h
include/poppler/CharTypes.h
@@ -38,25 +43,26 @@ include/poppler/PSOutputDev.h
include/poppler/PSTokenizer.h
include/poppler/Page.h
include/poppler/Parser.h
+include/poppler/ProfileData.h
+include/poppler/SecurityHandler.h
include/poppler/SplashOutputDev.h
include/poppler/Stream-CCITT.h
include/poppler/Stream.h
include/poppler/TextOutputDev.h
include/poppler/UTF8.h
+include/poppler/UGooString.h
include/poppler/UnicodeMap.h
include/poppler/UnicodeMapTables.h
include/poppler/UnicodeTypeTable.h
include/poppler/XRef.h
-include/poppler/glib/poppler-action.h
-include/poppler/glib/poppler-document.h
-include/poppler/glib/poppler-enums.h
-include/poppler/glib/poppler-page.h
-include/poppler/glib/poppler.h
+include/poppler/XpdfPluginAPI.h
+include/poppler/goo/FixedPoint.h
include/poppler/goo/GooHash.h
include/poppler/goo/GooList.h
include/poppler/goo/GooMutex.h
include/poppler/goo/GooString.h
include/poppler/goo/GooTimer.h
+include/poppler/goo/GooVector.h
include/poppler/goo/gfile.h
include/poppler/goo/gmem.h
include/poppler/goo/gtypes.h
@@ -84,19 +90,13 @@ include/poppler/splash/SplashT1FontFile.h
include/poppler/splash/SplashTypes.h
include/poppler/splash/SplashXPath.h
include/poppler/splash/SplashXPathScanner.h
-lib/libpoppler-glib.a
-lib/libpoppler-glib.la
-lib/libpoppler-glib.so
-lib/libpoppler-glib.so.0
lib/libpoppler.a
lib/libpoppler.la
lib/libpoppler.so
-lib/libpoppler.so.0
+lib/libpoppler.so.1
libdata/pkgconfig/poppler-cairo.pc
-libdata/pkgconfig/poppler-glib.pc
libdata/pkgconfig/poppler-splash.pc
libdata/pkgconfig/poppler.pc
@dirrm include/poppler/splash
@dirrm include/poppler/goo
-@dirrm include/poppler/glib
@dirrm include/poppler