aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-gdchart/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-07-16 15:25:22 +0800
committervanilla <vanilla@FreeBSD.org>2001-07-16 15:25:22 +0800
commitb4bc2839bbcb623fe429a03f061a7fa91f8ac3ba (patch)
tree681109d242b6bdd3948bb81ae9757c8ee4eb01df /graphics/py-gdchart/Makefile
parentae0d2da4166ec9aedd9aca21854387f7f46355cb (diff)
downloadfreebsd-ports-graphics-b4bc2839bbcb623fe429a03f061a7fa91f8ac3ba.tar.gz
freebsd-ports-graphics-b4bc2839bbcb623fe429a03f061a7fa91f8ac3ba.tar.zst
freebsd-ports-graphics-b4bc2839bbcb623fe429a03f061a7fa91f8ac3ba.zip
It's pything binding of gdchart.
PR: ports/28242 Submitted by: Hye-Shik Chang <perky@python.or.kr>
Diffstat (limited to 'graphics/py-gdchart/Makefile')
-rw-r--r--graphics/py-gdchart/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/py-gdchart/Makefile b/graphics/py-gdchart/Makefile
new file mode 100644
index 00000000000..32026c838e7
--- /dev/null
+++ b/graphics/py-gdchart/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-gdchart
+# Date created: 18 June 2001
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+
+PORTNAME= gdchart
+PORTVERSION= 0.6
+CATEGORIES= graphics python
+MASTER_SITES= http://athani.pair.com/msteed/software/gdchart/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= perky@python.or.kr
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgdchart.a:${PORTSDIR}/graphics/gdchart
+
+USE_PYTHON= yes
+USE_GMAKE= yes
+MAKE_ENV= GD_INCLUDE=${LOCALBASE}/include/gd \
+ GDCHART_INCLUDE=${LOCALBASE}/include \
+ PYTHON_INCLUDE=${PYTHON_INCLUDEDIR} \
+ LOCALBASE=${LOCALBASE}
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g} \
+ EXAMPLE_DIR=${EXAMPLE_DIR:S/^${LOCALBASE}\///g}
+MODULE_FILES= chart.py gdchart.so
+EXAMPLE_FILES= test.html test.py CHANGES
+EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+do-install:
+.for file in ${MODULE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PYTHON_SITELIBDIR}
+.endfor
+.if !defined(NO_PORTDOCS)
+ ${MKDIR} ${EXAMPLE_DIR}
+.for file in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLE_DIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>