aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/qt4-svg
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
committerlofi <lofi@FreeBSD.org>2007-08-03 06:37:40 +0800
commit92df36cb4f060e53f821e67dff720610621261e0 (patch)
treec51388c2c26e8fc4241309ebb4a13b91e275da69 /graphics/qt4-svg
parentf7bec0a60889d39376e4a9a13050951960059bb2 (diff)
downloadfreebsd-ports-graphics-92df36cb4f060e53f821e67dff720610621261e0.tar.gz
freebsd-ports-graphics-92df36cb4f060e53f821e67dff720610621261e0.tar.zst
freebsd-ports-graphics-92df36cb4f060e53f821e67dff720610621261e0.zip
- bsd.qt.mk:
QT_COMPONENTS can now be depended on at runtime or buildtime only by specifiying them as <component>_build or <component>_run, respectively. Specifying <component> without any suffix will depend on the component at both build- and runtime just like before. - Convert Qt core ports to use the new dependency switches. - Add a patch to corelib to fix Qt4 on ARM, submitted by: Björn König <bkoenig@alpha-tierchen.de>
Diffstat (limited to 'graphics/qt4-svg')
-rw-r--r--graphics/qt4-svg/Makefile15
-rw-r--r--graphics/qt4-svg/pkg-plist1
2 files changed, 4 insertions, 12 deletions
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 67b4ada6bb6..7dd3a3e403b 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui xml
+QT_COMPONENTS= qmake_build moc_build corelib gui xml
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -45,15 +45,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
-.if defined(PKGNAMESUFFIX) && (${PKGNAMESUFFIX} == "-debug" || ${PKGNAMESUFFIX} == "-static-debug")
-CONFIGURE_ARGS+=-debug
-.endif
-.if defined(PKGNAMESUFFIX) && (${PKGNAMESUFFIX} == "-static" || ${PKGNAMESUFFIX} == "-static-debug")
-CONFIGURE_ARGS+=-static
-.endif
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -66,10 +57,10 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/qt4-svg/pkg-plist b/graphics/qt4-svg/pkg-plist
index 7699fb340b9..63683b71cda 100644
--- a/graphics/qt4-svg/pkg-plist
+++ b/graphics/qt4-svg/pkg-plist
@@ -18,5 +18,6 @@ lib/libQtSvg.so
lib/libQtSvg.so.4
lib/libQtSvg.so.4.3
lib/libQtSvg.so.4.3.0
+%%DEBUG%%lib/libQtSvg.so.4.3.0.debug
libdata/pkgconfig/QtSvg.pc
@dirrm include/QtSvg