aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ruby-redact
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /graphics/ruby-redact
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-graphics-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'graphics/ruby-redact')
-rw-r--r--graphics/ruby-redact/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/ruby-redact/Makefile b/graphics/ruby-redact/Makefile
index 6c7bdec710c..1c8ca764b8a 100644
--- a/graphics/ruby-redact/Makefile
+++ b/graphics/ruby-redact/Makefile
@@ -15,16 +15,16 @@ MAINTAINER= alexbl@FreeBSD.org
COMMENT= An edje compiler written in ruby
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/imlib2.so:${PORTSDIR}/graphics/ruby-imlib2 \
- ${RUBY_SITELIBDIR}/eet.rb:${PORTSDIR}/devel/ruby-eet \
- ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
+ ${RUBY_SITELIBDIR}/eet.rb:${PORTSDIR}/devel/ruby-eet
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
+USE_RAKE= yes
NO_BUILD= yes
.include <bsd.port.pre.mk>
do-install:
- @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/ install
+ @cd ${WRKSRC} && ${RAKE_BIN} PREFIX=${PREFIX}/ install
.include <bsd.port.post.mk>