aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sng
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /graphics/sng
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-graphics-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-graphics-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-graphics-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/sng')
-rw-r--r--graphics/sng/Makefile6
-rw-r--r--graphics/sng/files/patch-sngc.c10
-rw-r--r--graphics/sng/files/patch-sngd.c25
3 files changed, 36 insertions, 5 deletions
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
index 3b193d2cbc7..87fdc7cfdbf 100644
--- a/graphics/sng/Makefile
+++ b/graphics/sng/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sng
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
@@ -16,9 +17,10 @@ COMMENT= Compiler/decompiler for Scriptable Network Graphics
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/rgb
RUN_DEPENDS= ${LOCALBASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/rgb
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-png-inc=${LOCALBASE}/include \
--with-rgbtxt=${LOCALBASE}/lib/X11/rgb.txt
@@ -26,7 +28,7 @@ CONFIGURE_ARGS= --with-png-inc=${LOCALBASE}/include \
MAN1= sng.1
PLIST_FILES= bin/sng bin/sng_regress
-pre-patch:
+no-pre-patch:
@${REINPLACE_CMD} -e 's|-static||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '33,34s|^static ||' ${WRKSRC}/sngd.c
diff --git a/graphics/sng/files/patch-sngc.c b/graphics/sng/files/patch-sngc.c
new file mode 100644
index 00000000000..14992c78630
--- /dev/null
+++ b/graphics/sng/files/patch-sngc.c
@@ -0,0 +1,10 @@
+--- sngc.c.orig 2010-11-05 18:29:14.000000000 +0100
++++ sngc.c 2012-05-04 07:33:36.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <ctype.h>
+ #define PNG_INTERNAL
+ #include "png.h"
++#include "pngpriv.h"
+
+ #include "sng.h"
+
diff --git a/graphics/sng/files/patch-sngd.c b/graphics/sng/files/patch-sngd.c
index d6259018e75..55906805031 100644
--- a/graphics/sng/files/patch-sngd.c
+++ b/graphics/sng/files/patch-sngd.c
@@ -1,6 +1,25 @@
---- sngd.c.orig 2003-11-15 20:25:10.000000000 +0100
-+++ sngd.c 2010-03-29 16:10:17.000000000 +0200
-@@ -793,17 +793,17 @@
+--- sngd.c.orig 2012-05-04 08:20:04.000000000 +0200
++++ sngd.c 2012-05-04 08:42:54.000000000 +0200
+@@ -10,6 +10,7 @@
+ #define PNG_INTERNAL
+ #include "config.h" /* for RGBTXT */
+ #include "png.h"
++#include "pngpriv.h"
+ #include "sng.h"
+
+ png_structp png_ptr;
+@@ -726,8 +727,8 @@
+ }
+ #ifdef PNG_FLOATING_POINT_SUPPORTED
+ #ifndef MNG_INTERFACE
+- fprintf(fpout, " width: %g\n", info_ptr->scal_pixel_width);
+- fprintf(fpout, " height: %g\n", info_ptr->scal_pixel_height);
++ fprintf(fpout, " width: %s\n", info_ptr->scal_s_width);
++ fprintf(fpout, " height: %s\n", info_ptr->scal_s_height);
+ #else
+ fprintf(fpout, " width: %g\n", info_ptr->scal.pixel_width);
+ fprintf(fpout, " height: %g\n", info_ptr->scal.pixel_height);
+@@ -794,17 +795,17 @@
fprintf(fpout, "tRNS {\n");
switch (info_ptr->color_type) {
case PNG_COLOR_TYPE_GRAY: