aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/svgalib
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-05 08:26:28 +0800
committeredwin <edwin@FreeBSD.org>2002-11-05 08:26:28 +0800
commite141abcbe3f5d0e27c242db86d315b391df98ce8 (patch)
treeb4c1203c3bf53f6c7998947918bb09ed1e6b1e57 /graphics/svgalib
parent68c28b7e88f792688b4eac72dced216968bcc7b0 (diff)
downloadfreebsd-ports-graphics-e141abcbe3f5d0e27c242db86d315b391df98ce8.tar.gz
freebsd-ports-graphics-e141abcbe3f5d0e27c242db86d315b391df98ce8.tar.zst
freebsd-ports-graphics-e141abcbe3f5d0e27c242db86d315b391df98ce8.zip
Fix damage done by replacing PERL into REINPLACE_CMD.
Noticed on: bento
Diffstat (limited to 'graphics/svgalib')
-rw-r--r--graphics/svgalib/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/svgalib/Makefile b/graphics/svgalib/Makefile
index 526396b78c3..abae3357918 100644
--- a/graphics/svgalib/Makefile
+++ b/graphics/svgalib/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://www.svgalib.org/
MAINTAINER= sobomax@FreeBSD.org
USE_GMAKE= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
ALL_TARGET= shared static
@@ -34,7 +33,10 @@ MAN${i}!= /bin/cat ${FILESDIR}/man${i}
.endfor
pre-patch:
- ${REINPLACE_CMD} -e 's.\x0D..' ${WRKSRC}/utils/gtf/*
+ for file in ${WRKSRC}/utils/gtf/*.h; do \
+ ${TR} -d '\015' < $${file} > $${file}.new; \
+ ${MV} $${file}.new $${file}; \
+ done
${MKDIR} ${WRKSRC}/include/linux
post-install: