aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tif22pnm/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-01-07 20:53:49 +0800
committerijliao <ijliao@FreeBSD.org>2003-01-07 20:53:49 +0800
commit0a257d10fe37b8dc8ab408374dfd9949af9a80a2 (patch)
tree1ee489ab8f6934c72cb4cc9faeefd3198a587223 /graphics/tif22pnm/Makefile
parent15bdfe4e7f4a0e7629b7542d0a6710c40ac0c234 (diff)
downloadfreebsd-ports-graphics-0a257d10fe37b8dc8ab408374dfd9949af9a80a2.tar.gz
freebsd-ports-graphics-0a257d10fe37b8dc8ab408374dfd9949af9a80a2.tar.zst
freebsd-ports-graphics-0a257d10fe37b8dc8ab408374dfd9949af9a80a2.zip
add tif22pnm 0.06
Converts TIFF- sampled images to PNM image
Diffstat (limited to 'graphics/tif22pnm/Makefile')
-rw-r--r--graphics/tif22pnm/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
new file mode 100644
index 00000000000..b06be320867
--- /dev/null
+++ b/graphics/tif22pnm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: tif22pnm
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tif22pnm
+PORTVERSION= 0.06
+CATEGORIES= graphics
+MASTER_SITES= http://www.inf.bme.hu/~pts/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
+ --with-libtiff-idir=${LOCALBASE}/include
+
+do-build:
+ @(cd ${WRKSRC} ; ${LOCALBASE}/bin/bash do.sh compile)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tif22pnm ${PREFIX}/bin
+
+.include <bsd.port.mk>