aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/tif22pnm/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-21 05:10:48 +0800
committerpav <pav@FreeBSD.org>2005-10-21 05:10:48 +0800
commit9fa42e6a47e0f6eb12ae127160a730d76235cd0c (patch)
treeac5bed27abdabc779d8ec41f8051ad3af17262bc /graphics/tif22pnm/Makefile
parent8dec7c9885dcb540575873123ea10609d0458398 (diff)
downloadfreebsd-ports-graphics-9fa42e6a47e0f6eb12ae127160a730d76235cd0c.tar.gz
freebsd-ports-graphics-9fa42e6a47e0f6eb12ae127160a730d76235cd0c.tar.zst
freebsd-ports-graphics-9fa42e6a47e0f6eb12ae127160a730d76235cd0c.zip
- Update to 0.12
PR: ports/87739 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'graphics/tif22pnm/Makefile')
-rw-r--r--graphics/tif22pnm/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index 4ee62f0869d..d62167174cc 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -7,18 +7,17 @@
#
PORTNAME= tif22pnm
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= graphics
MASTER_SITES= http://www.inf.bme.hu/~pts/
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts TIFF- sampled images to PNM image
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
@@ -26,11 +25,15 @@ CONFIGURE_ARGS= --with-libtiff-ldir=${LOCALBASE}/lib \
PLIST_FILES= bin/png22pnm bin/tif22pnm
-post-patch:
- @${REINPLACE_CMD} -e 's| -O2| ${CFLAGS}|g' ${WRKSRC}/do.sh
+TIF22PNM_SRCS= ptspnm.c minigimp.c miniglib.c ptstiff3.c tif22pnm.c
+PNG2PNM_SRCS= png22pnm.c
do-build:
- @(cd ${WRKSRC} ; ${LOCALBASE}/bin/bash do.sh compile)
+ cd ${WRKSRC} \
+ && ${CC} ${CFLAGS} -DNDEBUG -I${LOCALBASE}/include \
+ ${TIF22PNM_SRCS} -o tif22pnm -L${LOCALBASE}/lib -ltiff \
+ && ${CC} ${CFLAGS} -DNDEBUG `pkg-config libpng12 --cflags` \
+ ${PNG2PNM_SRCS} -o png22pnm `pkg-config libpng12 --libs`
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/png22pnm ${PREFIX}/bin