aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/xaos
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2001-02-28 17:31:18 +0800
committerjkoshy <jkoshy@FreeBSD.org>2001-02-28 17:31:18 +0800
commitbc53c0924b3e49f352cb2ef4e50b832bcb67f1f0 (patch)
tree672aa382ef36cf7fc334d55d0fa61080977e2d34 /graphics/xaos
parentd042e78c6043709af63a0820d4426e467672202a (diff)
downloadfreebsd-ports-graphics-bc53c0924b3e49f352cb2ef4e50b832bcb67f1f0.tar.gz
freebsd-ports-graphics-bc53c0924b3e49f352cb2ef4e50b832bcb67f1f0.tar.zst
freebsd-ports-graphics-bc53c0924b3e49f352cb2ef4e50b832bcb67f1f0.zip
Do not install SVGAlib support unless the user asks for it.
PR: ports/24896 Submitted by: Ilya Martynov <ilya@martynov.org>
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile6
-rw-r--r--graphics/xaos/files/patch-ai11
2 files changed, 17 insertions, 0 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index de90b0015f6..d2197f1f942 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -17,6 +17,9 @@ DISTNAME= XaoS-${PORTVERSION}
MAINTAINER= jkoshy@freebsd.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
+.if defined(WITH_SVGALIB)
+LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+.endif
USE_XLIB= yes
@@ -24,6 +27,9 @@ USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+.if !defined(WITH_SVGALIB)
+CONFIGURE_ARGS= --with-svga-driver=no
+.endif
CFLAGS= -DHAVE_SYS_PARAM_H \
-I${PREFIX}/include \
diff --git a/graphics/xaos/files/patch-ai b/graphics/xaos/files/patch-ai
new file mode 100644
index 00000000000..58ced091756
--- /dev/null
+++ b/graphics/xaos/files/patch-ai
@@ -0,0 +1,11 @@
+--- configure-- Thu Mar 5 03:19:12 1998
++++ configure Wed Feb 28 14:20:17 2001
+@@ -5522,7 +5522,7 @@
+ #define SVGA_DRIVER 1
+ EOF
+
+- STICKY='chmod +s $(bindir)/xaos; chown root $(bindir)/xaos; chgrp root $(bindir)/xaos'
++ STICKY='chmod +s $(bindir)/xaos; chown root $(bindir)/xaos; chgrp wheel $(bindir)/xaos'
+ DRIVERDIRS="$DRIVERDIRS ui/ui-drv/svga"
+ DRIVERLIBS="$DRIVERLIBS lib/libuisvga.a"
+ if test "x$ac_cv_func_pthread_sighandler" = xyes; then