aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/yafray/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 11:29:55 +0800
committerwill <will@FreeBSD.org>2003-06-03 11:29:55 +0800
commite4760c0dd202e29641db100b47dc7e00f11e0b0a (patch)
tree6213e13fda36d486eab8438cc9bd885e24ae93cc /graphics/yafray/Makefile
parentaab1209ddc77626669ff2eac207271b223fac8da (diff)
downloadfreebsd-ports-graphics-e4760c0dd202e29641db100b47dc7e00f11e0b0a.tar.gz
freebsd-ports-graphics-e4760c0dd202e29641db100b47dc7e00f11e0b0a.tar.zst
freebsd-ports-graphics-e4760c0dd202e29641db100b47dc7e00f11e0b0a.zip
Add yafray 0.0.3, a fast XML based raytracer.
PR: 52405 Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'graphics/yafray/Makefile')
-rw-r--r--graphics/yafray/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
new file mode 100644
index 00000000000..a97bcb31f2a
--- /dev/null
+++ b/graphics/yafray/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: yafray
+# Date created: 18 May 2003
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= yafray
+PORTVERSION= 0.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.coala.uniovi.es/~jandro/noname/downloads/
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= A fast XML based raytracer
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math
+.endif
+
+pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500041
+LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
+
+ @${REINPLACE_CMD} -E -e \
+ 's|^CXX =.+$$|CXX=${CXX}|; \
+ s|-O3||; \
+ s|-ffast-math||; \
+ s|-Wall|${CXXFLAGS}|' \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.post.mk>