aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-08 20:18:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-08 20:18:45 +0800
commit09cb3c291f7c9f0cbdf563ddc594f5f15e87a87f (patch)
tree4bad34704e1368fd288e6155afe1f8ec2ce1a6b6 /graphics
parent3bcc31a31d799fee99a9840381970bacd94a086e (diff)
downloadfreebsd-ports-graphics-09cb3c291f7c9f0cbdf563ddc594f5f15e87a87f.tar.gz
freebsd-ports-graphics-09cb3c291f7c9f0cbdf563ddc594f5f15e87a87f.tar.zst
freebsd-ports-graphics-09cb3c291f7c9f0cbdf563ddc594f5f15e87a87f.zip
- Support custom LOCALBASE
- Fix poppler-gtk dependency Reported by: QATty
Diffstat (limited to 'graphics')
-rw-r--r--graphics/osg-devel/Makefile2
-rw-r--r--graphics/osg/Makefile4
2 files changed, 5 insertions, 1 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 2381faf5198..b530281b7cb 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -211,6 +211,8 @@ USE_XORG+= xrandr
.endif
post-patch:
+ @${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index 61ff1650be6..2d8f3eae9ec 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -177,7 +177,7 @@ PLIST_SUB+= SVG="@comment "
.if defined(WITH_PDF)
FORCE_PC_REQUIRE+=POPPLER
-LIB_DEPENDS+= poppler-glib.3:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
PLIST_SUB+= PDF=""
.else
FORCE_PC_IGNORE+=POPPLER
@@ -200,6 +200,8 @@ USE_XORG+= xrandr
.endif
post-patch:
+ @${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt