aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2010-10-16 04:54:22 +0800
committerkmoore <kmoore@FreeBSD.org>2010-10-16 04:54:22 +0800
commit0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2 (patch)
tree9edca83c5624dbb8d8da9c6132b1e46c0dba6f90 /graphics
parent29e168c9d1e2abe9221d5ffabeaeea1e29d66899 (diff)
downloadfreebsd-ports-graphics-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.tar.gz
freebsd-ports-graphics-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.tar.zst
freebsd-ports-graphics-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.zip
Improve handing of LD_LIBRARY_PATH when doing non-standard LOCALBASE builds.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qt4-iconengines/Makefile2
-rw-r--r--graphics/qt4-imageformats/Makefile2
-rw-r--r--graphics/qt4-pixeltool/Makefile2
-rw-r--r--graphics/qt4-svg/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/graphics/qt4-iconengines/Makefile b/graphics/qt4-iconengines/Makefile
index 3fbd8c78439..9b3dfcd8bac 100644
--- a/graphics/qt4-iconengines/Makefile
+++ b/graphics/qt4-iconengines/Makefile
@@ -24,7 +24,7 @@ HAS_CONFIGURE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
diff --git a/graphics/qt4-imageformats/Makefile b/graphics/qt4-imageformats/Makefile
index 9c21375da7a..19b4f7a0d7a 100644
--- a/graphics/qt4-imageformats/Makefile
+++ b/graphics/qt4-imageformats/Makefile
@@ -29,7 +29,7 @@ HAS_CONFIGURE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
diff --git a/graphics/qt4-pixeltool/Makefile b/graphics/qt4-pixeltool/Makefile
index 63a522876db..6db311d1ac8 100644
--- a/graphics/qt4-pixeltool/Makefile
+++ b/graphics/qt4-pixeltool/Makefile
@@ -24,7 +24,7 @@ HAS_CONFIGURE= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index b880a95ad0e..2400c6bc8cf 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -25,7 +25,7 @@ USE_LDCONFIG= ${PREFIX}/lib/qt4
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \